Du bist hier::--Excel Formeln – Anzahl unterschiedlicher Einträge mit Bedinungen anzeigen

Excel Formeln – Anzahl unterschiedlicher Einträge mit Bedinungen anzeigen

[imgr=logo-470.png]logo-80.png?nocache=1309248352904[/imgr]In diesem Excel Artikel werde ich ihnen erklären, wie Sie es schaffen, dass die Anzahl von unterschiedlichen Datensätzen, die aus zwei Werten bestehen, angezeigt werden, wenn eine oder mehrere Bedingungen erfüllt sein müssen.

In dem Artikel hier habe ich ihnen gezeigt, wie man es schafft, dass die Anzahl an unterschiedlichen Spalteneinträgen angezeigt wird. Dabei wurden aber einfach nur die Anzahl der verschiedenen Einträge angezeigt, ohne dass noch eine Bedingung erfüllt sein musste. Soll das aber auch der Fall sein, so geht das auch. Hier werde ich ihnen zeigen, wie es ist, wenn der Datensatz aus zwei Werten besteht, aber selbstverständlich können Sie die Formel auch so umändern, dass nur ein Datensatz vorhanden sein muss, oder aber, dass Sie auch mehrere Bedingungen stellen können. Wie genau das funktioniert, sehen Sie nun.

Beginn:

Bevor Sie damit anfangen die Bedingungen einzugeben, oder die Anzahl an Zeilen anzuzeigen, in denen die Bedingungen erfüllt sind, müssen Sie erst einmal ihre Datensätze eintragen. Benutzen Sie dafür die Spalten A und B. Wie weit Sie nach unten gehen, ist für die Formel, die Sie weiter unten finden egal, da Sie die beiden Spalten bis zu den Zellen A100 bzw. B100 mit einbeziehen. Tragen Sie nun also die Datensätze ein, die immer aus zwei Werten bestehen. Einem Wert aus Spalte A und einem zweiten aus Spalte B. Da ich später die Anzahl an den verschiedenen Datensätzen auslesen möchte, die in Spalte B ein „x“ als Wert haben, habe ich auch darauf geachtet, dass das „x“ öfters verwendet wurde und manche Werte auch doppelt eingetragen wurden. Möchten Sie die Funktion nur testen, so rate ich ihnen das auch so zu machen, wenn Sie aber schon mit ihren richtigen Werten arbeiten möchten, so verwenden Sie selbstverständlich diese. Haben Sie ihre Werte nun eingetragen und ihre Tabelle sieht ungefähr so aus wie meinem im Screenshot, dann können Sie nun zum nächsten Teil der Anleitung übergehen, in dem ich ihnen zeigen werde, wie Sie es jetzt schaffen, dass die Anzahl an Zeilen ausgegeben wird, die verschieden sind, aber dennoch eine Bedingung oder auch mehrere erfüllen müssen.

(Zur Darstellung in Originalgröße Abbildungen anklicken)
01-excel-formeln-anzahl-unterschiedlicher-eintraege-mit-bedingungen-anzeigen-beginn-470.png?nocache=1308950988247

Anzahl an den unterschiedlichen Einträgen mit Bedingungen anzeigen:

Nachdem die Datensätze nun eingetragen wurden, können Sie damit beginnen die Anzahl auszugeben, wie viele verschiedene Einträge vorkommen und dabei noch auf eine Bedingung geachtet wird. Dazu benötigen Sie natürlich eine Formel. Am besten ist es, wenn Sie die Formel nicht in eine Zelle der Spalte A oder der Spalte B eintragen, da Sie sonst die Möglichkeit verlieren weitere Datensätze einfach darunter zu schreiben und Sie sonst die Formel noch ändern müssen, damit kein Zirkelbezug entsteht. Aus diesem Grund bietet sich die Zelle C1 eigentlich ideal an. Schreiben Sie hier nun die folgende Formel hinein:

=SUMMENPRODUKT((VERGLEICH(A1:A100&"";A1:A100&"";)=ZEILE(1:100))*(B1:B100="x")*(A1:A100<>""))

Diese Formel ist keine Matrixformel, also werden Sie, sofern sie die gleichen Zellbezüge wie ich gewählt haben, sofort das richtige Ergebnis sehen, nachdem Sie die Formel eingegeben haben. In meinem Fall war das die Zahl „5“, da in den Zeilen 2, 4, 6, 8 und 10 neue Einträge auftreten, die auch die Bedingung erfüllt haben. In meinem Beispiel habe ich als Bedingung den Wert „x“ in der Spalte B gewählt. Haben Sie für die beiden Spalten nicht A und B gewählt, so können Sie das in der Formel ganz einfach abändern. Statt „A1:A100“ schreiben Sie dann einfach den Zellbezug von der Spalte, in der nicht die Bedingung stehen soll. Das gleiche machen Sie mit dem Zellbezug „B1:B100“. Möchten Sie, dass noch eine neue Bedingung erfüllt sein soll, so geben Sie hinter „(A1:A100<>"")“ einen neuen Faktor mit einer Bedingung ein. Dieser muss durch ein Multiplikationszeichen ( * ) getrennt sein. Eine neue Formel, die in der Spalte C noch den Buchstaben „z“ als Bedingung hat, würde dann also so aussehen:

=SUMMENPRODUKT((VERGLEICH(A1:A100&"";A1:A100&"";)=ZEILE(1:100))*(B1:B100="x")*(A1:A100<>"")*(C1:C100="z"))

Zur Erklärung sein noch zu sagen, dass der Faktor „(A1:A100<>"")“ bewirkt, dass in der Spalte A ein Wert stehen muss, damit die Bedingung erfüllt sein kann. Nur ein „x“ in der Spalte B und kein Wert in der gleichen Zeile bei Spalte A liefert also kein neues Ergebnis. Haben Sie die Formel so eingegeben und ihnen wird nicht das richtige Ergebnis angezeigt, so liegt das höchstwahrscheinlich daran, dass in der Spalte A der Wert schon einmal vorgekommen ist, in der Spalte B aber nicht der Wert eingetragen war, damit die Bedingung erfüllt wurde. Dann ändert es auch nichts daran, wenn die Bedingung in einer anderen Zeile mal erfüllt wurde, sie muss immer beim ersten Auftreten des neuen Zeichens in der Spalte A gleich erfüllt werden. Zur Verdeutlichung: Würde ich jetzt das „x“ aus der Zelle B10 löschen, so würde in der Zelle C1 nur noch „4“ angezeigt, obwohl die Kombination aus „8“ und „x“ nochmal in Zeile 12 auftritt. Leider kann man das in der Formel nicht verändern.

02-excel-formeln-anzahl-unterschiedlicher-eintraege-mit-bedingungen-anzeigen-formel-470.png?nocache=1308951016016

Nun wissen Sie, wie man die Anzahl an Zeilen ausgeben kann, die verschiedene Werte haben und eine Bedingung erfüllen. Die Lösung dafür findet man in einer einzigen Formel, die jedoch leider einen kleinen Fehler besitzt, den man dann ausbessert, indem man die Datensätze richtig ordnet.

Von |2018-07-25T14:21:23+00:00Juli 1st, 2011|Kategorien: Tabellenkalkulation|0 Kommentare

Über den Autor:

Hinterlassen Sie einen Kommentar