Du bist hier::--Excel Formeln – Prüfen, ob eine Spalte sortiert ist

Excel Formeln – Prüfen, ob eine Spalte sortiert ist

In diesem Artikel zu Excel werde ich ihnen zeigen, wie Sie überprüfen können, ob eine Spalte sortiert ist. Dabei kann man auf aufsteigend und absteigend überprüfen und sowohl Zahlen als auch Text werden von der Formel richtig behandelt.

Nehmen wir an, Sie haben eine Spalte, in der Sie Zahlen aufgelistet haben und mit der niedrigsten Zahl beginnen. Das denken Sie zu mindestens. Wahrscheinlich werden Sie sich nun darauf verlassen und denken, dass die Zahl in der Zeile 5 auch die fünftniedrigste ist. Sind Sie sich jedoch nicht ganz sicher, dass das so ist, da Sie vielleicht sehr viele Einträge in der Spalte haben und sie so unübersichtlich ist, dann benötigen Sie eine Funktion, mit der Sie überprüfen können, ob die Spalte wirklich geordnet ist. Wie man das mit einer einzigen Formel schafft, erfahren Sie nun.

Beginn:

Zu aller erst müssen Sie in eine Spalte ihre Werte eintragen. Am besten nehmen Sie dafür die Spalte A, da die Formel so ausgelegt ist, dass die Spalte A untersucht wird. Ist es bei ihnen nicht möglich, so vergessen Sie nicht, dass Sie die Formel dann noch umändern müssen. Wie ich oben schon kurz angesprochen habe, kann die Formel sowohl auf Ziffern oder Zahlen, als auch auf Text oder Buchstaben reagieren. Geben Sie jedoch Zahlen und Text ein, so wird die Formel nur den ersten Teil der gleichen Daten (entweder Zahlen oder Text) überprüfen, ob dieser geordnet ist. Geben Sie nun in die Spalte A nun ihre gewünschten Werte ein, wobei jeder Wert natürlich wieder in eine neue Zelle geschrieben wird. Haben Sie nun ihren Inhalt eingegeben und ihre Tabelle sieht aktuell so ähnlich aus wie eine aus den Screenshots, dann können Sie im nächsten Schritt lesen, wie Sie eine Spalte darauf überprüfen, ob ihre Inhalte aufsteigend sortiert sind.

(Zur Darstellung in Originalgröße Abbildungen anklicken)
01-excel-fomeln-pruefen-ob-eine-spalte-sortiert-ist-beginn-buchstaben-absteigend-200.png?nocache=130988613735102-excel-fomeln-pruefen-ob-eine-spalte-sortiert-ist-beginn-buchstaben-aufsteigend-200.png?nocache=130988615711903-excel-fomeln-pruefen-ob-eine-spalte-sortiert-ist-beginn-zahlen-absteigend-200.png?nocache=130988619351204-excel-fomeln-pruefen-ob-eine-spalte-sortiert-ist-beginn-zahlen-aufsteigend-200.png?nocache=1309886214945

Prüfen, ob die Spalte aufsteigend sortiert ist:

Zuerst werde ich ihnen zeigen, mit welcher Formel Sie überprüfen können, ob die Inhalte in der Spalte A aufsteigend sortiert sind. Dazu benötigen Sie eine freie Zelle, in welche die Formel eingetragen werden kann. Nehmen Sie dafür keine Zelle in der Spalte A, da fast die komplette Spalte A (bis ca. Zeile 1000) für die Formel belegt ist und somit ein Fehler bezüglich eines Zirkelbezuges entstehen würde, wenn Sie sie in die Spalte A eintragen würden. Nehmen Sie deshalb einfach die Zelle B1. Schreiben Sie hier nun folgendes hinein:

=SUMME(N((A2:A1001)
Tragen Sie die Formel ein, so werden Sie in der Zelle den Fehler „#WERT!“ angezeigt bekommen. Das ist kein Fehler in der Formel, sondern liegt einfach daran, dass die Formel eine Matrixformel ist. Das bedeutet für Sie nun, dass Sie noch die folgenden drei Schritte durchführen müssen, damit die Formel richtig ausgeführt wird. Zuerst klicken Sie nochmals in die Zelle, in die Sie die Formel geschrieben haben, in meinem Fall also die Zelle B1. Anschließend klicken Sie oben in die Bearbeitungszeile der Formel. Haben Sie auch das gemacht, so drücken Sie auf ihrer Tastatur nun gleichzeitig die Tasten STRG+SHIFT+Enter. Dadurch wird die Formel richtig ausgeführt. In der Zelle selbst sehen Sie nun den Ausgabewert. Ist ihre Spalte A aufsteigend sortiert, so wird ihnen hier nun „WAHR“ angezeigt, wie es bei mir der Fall war. Andernfalls sehen Sie hier nun „FALSCH“. Neben der korrekten Anzeige hat sich aber, wie bei Matrixformeln üblich, auch das Aussehen der Formel verändert. Die Formel lautet jetzt nämlich:

{=SUMME(N((A2:A1001)
Soll bei ihnen nicht die Spalte A darauf überprüft werden, ob sie sortiert ist, sondern eine andere, so müssen Sie einfach den Zellbezug ändern. Das bedeutet konkret, dass Sie nur das „A“ in der Formel überall ändern müssen, wo es als Teil eines Zellbezugs auftritt.

05-excel-fomeln-pruefen-ob-eine-spalte-sortiert-ist-buchstaben-aufsteigend-pruefen-470.png?nocache=1309886291194

Wie schon gesagt, funktioniert diese Formel aber nicht nur bei Buchstaben oder Text, sondern auch bei Zahlen. Ohne, dass ich die Formel verändert habe, dafür aber die Buchstaben durch Zahlen ersetzt habe, wird trotzdem wieder „WAHR“ in der Zelle B1 angezeigt.

06-excel-fomeln-pruefen-ob-eine-spalte-sortiert-ist-zahlen-aufsteigend-pruefen-470.png?nocache=1309886309122

Prüfen, ob die Spalte absteigend sortiert ist:

Natürlich ist es ihnen auch möglich zu überprüfen, ob die Spalte absteigend sortiert ist. Da das natürlich nicht das Gegenteil von der ersten Formel ist, benötigen Sie hier wieder eine neue Formel (Das Ergebnis „FALSCH“ kann ja auch bedeuten, dass überhaupt nicht sortiert ist). Löschen Sie nun also zuerst den aktuellen Inhalt der Zelle B1. Danach tragen Sie hier folgendes ein:

=SUMME(N(A2:A1001 > A1:A1000))=0

Wie vorhin auch ist auch diese Formel eine Matrixformel, was bedeutet, dass der Fehler, der ihnen aktuell in der Zelle angezeigt wird, kein Grund zu Bedenken ist. Um den Fehler zu beheben, müssen Sie wieder die Standardaktion ausführen, die bei einer Matrixformel nötig ist. Klicken Sie dazu erneut in die Zelle, in der die Formel steht, in meinem Beispiel also B1. Danach klicken Sie oben in die Bearbeitungszeile der Formel. Haben Sie auch das gemacht, so drücken Sie nun wieder STRG+SHIFT+Enter. Nun sehen Sie in der Zelle den Wert, ob die Spalte A geordnet ist. Ist das der Fall, so wird ihnen nun ein „WAHR“ angezeigt, andernfalls dementsprechend „FALSCH“. Wie vorhin auch, hat sich die Formel wieder verändert. Nun sieht sie so aus:

{=SUMME(N(A2:A1001 > A1:A1000))=0}

Wenn Sie nicht die Spalte A überprüfen möchten, so ändern Sie wie oben auch schon einfach das „A“ in allen Zellbezügen so ab, dass ihre Spalte mit einbezogen wird.

07-excel-fomeln-pruefen-ob-eine-spalte-sortiert-ist-buchstaben-absteigend-pruefen-470.png?nocache=1309886356985

Wie Sie sich wahrscheinlich schon denken können, ist diese Funktion natürlich wieder für den Umgang mit Zahlen gerüstet. Dazu habe ich die Formel in der Zelle B1 einfach unverändert gelassen und dafür die Buchstaben in der Spalte A in  Ziffern verwandelt. Wie Sie sehen können, hat auch das bestens funktioniert, da wieder „WAHR“ angezeigt wird.

08-excel-fomeln-pruefen-ob-eine-spalte-sortiert-ist-zahlen-absteigend-pruefen-470.png?nocache=1309886377346

Nun wissen Sie, wie man mithilfe einer Formel überprüfen kann, ob eine Spalte aufsteigend oder absteigend sortiert ist. Möchten Sie überprüfen, ob überhaupt etwas sortiert ist, dann müssen Sie einfach beide Formeln ausführen und schauen, ob bei beiden der Wert „FALSCH“ geliefert wird. Möchten Sie, dass der Inhalt der Spalte A anschließend wirklich korrekt sortiert wird, so geht das ganz einfach mit der „Sortieren“ Funktion oben rechts in der Zeile.

Von |2018-07-25T14:16:54+00:00August 8th, 2011|Kategorien: Tabellenkalkulation|1 Kommentar

Über den Autor:

Ein Kommentar

  1. Klaus.2 8. August 2011 um 17:51 Uhr

    Hallo Supportnet-Admins, hallo yannick_b!

    Die angegebenen Formeln
    1. =SUMME(N((A2:A1001)
    2. {=SUMME(N((A2:A1001)
    können schon aus formalen Gründen (Syntaxfehler: jeweils 3 öffnende, aber nur eine schließende Klammer) nicht funktionieren.

    Nicht mal richtig abschreiben kann der Autor! Ich empfehle einen weiteren Blick auf http://www.excelformeln.de/formeln.html?welcher=76.

    Ausführlichere Bemerkungen zur HONORAR-SCHINDEREI des Autoren und der fehlenden Qualitätskontrolle durch die Supportnet-Verantwortlichen siehe http://www.supportnet.de/faqscomthread/2376905.

    Mit freundlichen Grüßen
    Klaus

    (E-Mail-Adresse auf Anfrage)

Hinterlassen Sie einen Kommentar