Du bist hier::--Excel Formeln – Rechts vom Text stehende Zahlen addieren

Excel Formeln – Rechts vom Text stehende Zahlen addieren

Sie möchten in Excel die Zahlen mehrere Zellen, in denen sowohl Text, als auch am Ende Ziffern vorkommen addieren, Sie wissen aber nicht wie das funktioniert? Dann lesen sie hier in diesem Artikel wie das funktioniert. Mit einer einzelnen Formel kann man dieses Problem lösen.

Hier habe ich ihnen bereits erklärt, wie man Zahlen addiert, die am Anfang einer Zelle mit Textinhalt stehen. Dafür benötigt man entweder gleichlange Zahlen, oder aber einen gleichlangen Text. Steht die Zahl hingegen rechts des Textes, so sind die Längen kein Problem. Wie das geht erfahren Sie jetzt.

Schreiben Sie zu Beginn einfach in die Zellen A1-A3 Text und anschließend dahinter eine Zahl. Diese Zahl kann direkt an dem Text hängen, kann aber auch einfach durch ein Leerzeichen getrennt sein. Das ist für diese Formel völlig irrelevant. Desweiteren muss nicht einmal ein Text vorkommen, eine einfache Auflistung von Zahlen würde auch funktionieren, dafür gibt es aber eine leichtere Möglichkeit zum addieren.  Ich habe für mein Beispiel jetzt einfach drei verschiedenlange Wörter („Schweine“, „Hunde“ und „Katzen“) und mit den Zahlen „13“, „5“ und „124“ auch drei Zahlen gewählt, die eine verschiedene Anzahl an Ziffern haben.
In die andere Zelle, in der am Ende die Summe erscheinen soll, schreiben Sie nun folgende Matrixformel:

=SUMME(A1:A3)+SUMME(WENN(ISTZAHL(A1:A3);0;WENN(ISTZAHL(LINKS(RECHTS(A1:A3;SPALTE(1:1));1)*1);LINKS(RECHTS(A1:A3;SPALTE(1:1));1)*10^(SPALTE(1:1)-1);0)))

Da es eine Matrixformel ist, reicht es nicht aus, diese Formel per Enter Taste zu bestätigen. Sie müssen stattdessen gleichzeitig STRG+SHIFT+Enter drücken. Anschließend verwandelt sich die Formel dazu:

{=SUMME(A1:A3)+SUMME(WENN(ISTZAHL(A1:A3);0;WENN(ISTZAHL(LINKS(RECHTS(A1:A3;SPALTE(1:1));1)*1);LINKS(RECHTS(A1:A3;SPALTE(1:1));1)*10^(SPALTE(1:1)-1);0)))}

(Zur Darstellung in Originalgröße Abbildungen anklicken)
01-excel-formeln-rechts-vom-text-stehende-zahlen-addieren-470.png?nocache=1308270113887

Das war auch schon alles, was Sie wissen müssen, wenn Sie die Zahlen am Ende einer Zelle addieren möchten. Mit dem hier errechneten Wert können Sie natürlich noch weiterrechnen, statt „SUMME“, können Sie aber auch „MITTELWERT“ oder eine sonstige Rechenfunktion von Excel benutzen.

Von |2018-07-25T14:24:21+00:00Juni 18th, 2011|Kategorien: Tabellenkalkulation|0 Kommentare

Über den Autor:

Hinterlassen Sie einen Kommentar