Du bist hier::--Excel Formeln – Text oder Zahlen rechtsbündig in einzelne Zellen aufteilen

Excel Formeln – Text oder Zahlen rechtsbündig in einzelne Zellen aufteilen

In diesem Artikel lernen Sie, wie Sie in Excel einen Text oder eine Zahl rechtsbündig auf einzelne Zellen aufteilen können und dabei noch auf mögliche gegebene Nachkommastellen eingehen. Leider gibt es auch dazu keine vorgefertigte Formel in Excel, so dass Sie dafür wieder eine Anleitung benötigen.

Sie haben einen Text und möchten dabei jedes Zeichen in eine einzelne Zelle schreiben und der Text soll rechtsbündig orientiert sein? Lesen Sie diesen Artikel und Sie werden merken, wie leicht das mit ein paar Formeln funktioniert.

Beginn:

Zu aller erst schreiben Sie in die Spalte 1 die Zahlen oder Wörter die aufgeteilt werden sollen. Möchten Sie die Beispiele der Anleitung nach befolgen, so schreiben Sie nun in diese Zellen erst einmal ein paar Zahlen. Zur besseren Verdeutlichung nehmen Sie bestenfalls Zahlen mit Komma, ebenso wie Zahlen ohne Komma.

Formel für Nachkommastellen:

Möchten Sie nun angeben, dass alle Zahlen, die Sie hier eingeben haben als einzelne Zeichen angezeigt werden, aber in dem Format, dass alle Zahlen zwei Nachkommastellen besitzen, so benötigen Sie dafür eine spezielle Formel. Schreiben Sie deshalb in Zelle J1 nun folgendes:

=WENN(SPALTEN(J1:$J1)>LÄNGE(TEXT($A1;"###0,00"));"";LINKS(RECHTS(TEXT($A1;"###0,00");SPALTEN(J1:$J1));1))

Hier gibt es nun einiges zu beachten. Zuerst sei gesagt, dass die Formel keine Matrixformel ist und Sie sie somit automatisch korrekt angenommen wird, wenn Sie sie eingeben. Desweiteren gibt es in dieser Formel bestimmte Stellen. Zum Beispiel gibt die „0,00“ in der Formel an, wie die Zahl formatiert sein soll. Möchten Sie also drei Nachkommastellen, so geben Sie hier „0,000“ ein. Desweiteren müssen Sie darauf achten, dass wenn Sie mit der Ausgabe nicht in Zelle J1 anfangen bzw. aufhören, dass die Angabe oben in der Formel auch ausgebessert werden muss.

(Zur Darstellung in Originalgröße Abbildungen anklicken)
01-excel-formeln-text-oder-zahlen-rechtsbuendig-in-zellen-teilen-nachkommastellen-j1-470.png?nocache=1308579995615

Haben Sie alles so eingestellt, wie Sie es möchten, so kopieren Sie diese Formel auch auf alle anderen Zellen, die sich weiter links in dieser Spalte befinden. Klicken Sie dazu die Zelle nochmals an und fahren Sie mit der Maus über ihre rechte untere Ecke, woraufhin sich der Mauszeiger in ein Kreuz verwandelt. Nun klicken Sie und halten die Maus gedrückt, während Sie bis zur Zelle B1 fahren. Hier lassen Sie die Maus nun wieder los. Jetzt steht die komplette Zahl der Zelle A1 rechts aufgeteilt. Das gleiche machen Sie selbstverständlich auch für die anderen Zeilen, also die anderen Zahlen.

02-excel-formeln-text-oder-zahlen-rechtsbuendig-in-zellen-teilen-nachkommastellen-fertig-470.png?nocache=1308580008975

Formel ohne extra Nachkommastellen bzw. Text:

Möchten Sie, dass die Zahlen die Sie links eingegeben haben keine extra Nachkommastellen rechts bekommen, so brauchen Sie hierfür wieder eine neue Formel. Löschen Sie nun erst einmal den Inhalt der Zellen von B1-J3. Die Zahlen in den Zellen A1-A3 können Sie so beibehalten. In die Zelle J5 schreiben Sie nun die folgende Excelformel:

=WENN(SPALTEN(J5:$J5)>LÄNGE($A5);"";LINKS(RECHTS($A5;SPALTEN(J5:$J5));1))

Da dies auch keine Matrixformel ist, wird die Angabe sofort korrekt angezeigt. Das einzige was hier noch zu sagen ist, ist dass wenn Sie die Formel nicht in Zelle J5 schreiben, den Zellbezug oben entsprechend verändern.

03-excel-formeln-text-oder-zahlen-rechtsbuendig-in-zellen-teilen-kein-komma-j1-470.png?nocache=1308580025503

Nun kopieren Sie wieder die Formel. Klicken Sie die Zelle also wieder an und fahren Sie mit der Maus über ihre rechte untere Ecke bis der Mauszeiger zu einem Kreuz wird. Nun klicken Sie und halten die Maus gedrückt während Sie mit der Maus auf das Feld J1 fahren. Hier lassen Sie die Maus wieder los. Nun steht in dieser Zelle die gesamte Zahl ohne extra Nachkommastellen. Selbstverständlich machen Sie das in den anderen Zellen auch.

04-excel-formeln-text-oder-zahlen-rechtsbuendig-in-zellen-teilen-kein-komma-fertig-470.png?nocache=1308580047399

Dieselbe Formel funktioniert übrigens auch perfekt für Text. Das können Sie sehen, wenn Sie in der Spalte A die Zahlen einfach durch Text ersetzen, die Formeln rechts aber unverändert lassen. Nun werden rechts die einzelnen Zeichen des Wortes angezeigt, natürlich, wie alles andere auch, wieder rechtsbündig.

05-excel-formeln-text-oder-zahlen-rechtsbuendig-in-zellen-teilen-text-fertig-470.png?nocache=1308580123377

Nun wissen Sie Bescheid, wie man Excel so einstellen kann, dass der Inhalt einer Zelle auf seine einzelnen Zeichen aufgeteilt und anschließend rechtsbündig angezeigt wird.

Von |2018-07-25T14:23:39+00:00Juni 22nd, 2011|Kategorien: Tabellenkalkulation|0 Kommentare

Über den Autor:

Hinterlassen Sie einen Kommentar