Excel #NV ersetzen ... - ISTNV oder ISTFEHLER klappen nicht

253 Aufrufe
Gefragt 7 Mai in Tabellenkalkulation von jcl
Grundsätzlich möchte, dass bei einer Formel, sofern sie kein Ergebnis liefern würde, das Standard-Resultat #NV durch eine 0 ersetzt wird, damit ich später aus allen Formelergebnissen einer Zeile eine Summe bilden kann.

Hierzu habe ich dank WWW-Suche folgende Formel kreiert:

=WENN(ISTNV(SVERWEIS($A5;'Tabelle1'!$A:$C;3;FALSCH));0;SVERWEISS($A5;'Tabelle1'!$A:$C;3;FALSCH))

Im Netz heißt es ISTNV könne auch durch ISTFEHLER ersetzt werden.

Während es sonst im Netz überall als die ultimative Lösung dargestellt wird, funktioniert es bei mir nur dann, wenn tatsächlich die Formel keine Lösung hätte (also wenn #NV sonst gekommen wäre, wird jetzt 0 eingetragen).
Problem ist: Wenn in Wirklichkeit die Formel aber eine Zahl liefern soll (was vorher mit einfach SVERWEIS-Formel auch gut klappte), dann kommt jetzt die Meldung "Fehler: Ungültiger Name". Ich wüsste nicht, wo tatsächlich ein Fehler sein sollte. Die Tabelle "Tabelle1" gibt es und dort gibt es auch die entsprechenden Felder und Infos (Formel funktioniert ja wie gesagt auch wenn kein Ergebnis erwartbar).

Kann jemand helfen?

3 Antworten

0 Punkte
Beantwortet 7 Mai von rainberg Profi (14,880 Punkte)
Hallo,

probier's mal so

=WENNFEHLER(SVERWEISS($A5;'Tabelle1'!$A:$C;3;FALSCH);"")

Vorausgesetzt deine Excelversion ist >= 2007

Gruß
Rainer
0 Punkte
Beantwortet 7 Mai von rainberg Profi (14,880 Punkte)
Korrektur:

SVERWEIS natürlich ohne Doppel-S
0 Punkte
Beantwortet 7 Mai von jcl
Das klappt! Super! Vielen Dank!
...