50 Aufrufe
Gefragt in Tabellenkalkulation von rastermen Mitglied (108 Punkte)

Guten Tag,

in meiner Tabelle habe ich diese Zellen miteinander verkettet und funktioniert.

WENN(B1159="";VERKETTEN(TEIL(C1159;1;51);"  ";D1159;"";E1159;"  ";F1159;WENN(F1159>0;"g";"")))

Wo ich nicht weiterkomme- wenn ich die Formel erweitere:

 WENN(B1159="X";VERKETTEN(TEIL(C1159;1;51);" ";WENN(B1159="";VERKETTEN(TEIL(C1159;1;51);"  ";D1159;"";E1159;"  ";F1159;WENN(F1159>0;"g";""));"")))

einbringe. Wenn ein "X" in in B1 steht funktioniert es, ist B1 leer wird jetzt "Falsch" ausgegeben.

Danke im Vorraus

Gruß Rudolf

3 Antworten

0 Punkte
Beantwortet von m-o Profi (12.9k Punkte)

Hallo Rudolf,

ich denke, dass du die Formel so haben willst:

=WENN(B1159="X";VERKETTEN(TEIL(C1159;1;51);WENN(B1159="";VERKETTEN(TEIL(C1159;1;51);"  ";D1159;"";E1159;"  ";F1159;WENN(F1159>0;"g";""));"")))

Gruß

M.O.

0 Punkte
Beantwortet von rastermen Mitglied (108 Punkte)

Hallo M.O.

Danke für Deine Antwort.

Habe deine Formel kopiert und eingesetzt und das selbe Ergebnis erzielt.

"Wenn ein "X" in in B1 steht funktioniert es, ist B1 leer wird jetzt "Falsch" ausgegeben. "

Wäre es Dir möglich nochmals darüber zu Schauen ?

Herzlichen Dank

Gruß Rudolf

0 Punkte
Beantwortet von rastermen Mitglied (108 Punkte)

Hallo M.O.

habe die Lösung gefunden:

=WENN(B1159="X";VERKETTEN(TEIL(C1159;1;51);WENN(B1159="";VERKETTEN(

=WENN(B1159="X";C1159;WENN(B1159="";VERKETTEN(...........

da ich nur das eine Feld brauche.

Gruß

Rudolf

...