69 Aufrufe
Gefragt in Tabellenkalkulation von czerno Einsteiger (24 Punkte)
Guten Morgen liebes Forum,

ich habe schon gegoogelt und gemacht und getan aber irgendwie stehe ich auf dem Schlauch.

Ich habe folgenden VBA-Code:

Sub FORMELARRAY()
Sheets("Eingabetabelle").Range("A14").FormulaArray = "=SVERWEIS(C14&B14;WAHL({1.2};Personalnummern!$A$2:$A$999&Personalnummern!$B$2:$B$999;Personalnummern!$C$2:$C$999);2;FALSCH)"
End Sub

Ziel dieser Formel ist es in dem Tabellenblatt Eingabetabelle in Zelle A14 die Matrix-Formel =SVERWEIS(C14&B14;WAHL({1.2};Personalnummern!$A$2:$A$999&Personalnummern!$B$2:$B$999;Personalnummern!$C$2:$C$999);2;FALSCH)

einzufügen. Allerdings bekomme ich eine Fehlermeldung

Laufzeitfehler '1004': Die FormulaArray-Eigenschaft des Range-Objektes kann nicht festgelegt werden.

Ich sehe leider den Wald vor lauter Bäumen nicht. Kann mir einer helfen?

Grüße und Danke

Czerno

1 Antwort

0 Punkte
Beantwortet von m-o Profi (13.2k Punkte)

Hallo Czerno,

laut der Online-Hilfe zu FormulaArray müssen die Bezüge in RC-Format angegeben werden und du musst auch die englischen Ausdrücke nutzen:

Sub FORMELARRAY()

Sheets("Eingabetabelle").Range("A14").FormulaArray = "=VLOOKUP(RC[2]&RC[1],CHOOSE({1,2},Personalnummern!R2C1:R999C1&Personalnummern!R2C2:R999C2,Personalnummern!R2C3:R999C3),2,FALSE)"

End Sub

Hierbei hilft auch der Makrorekorder wink.

Gruß

M.O.

...