59 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Mitglied (332 Punkte)

Hallo habe ein für mich großes Problem

vielleicht weiß jemand eine Lösung für mich.

Was mache ich falsch? in den Zellen

Zelle AX 2 bis AX 4 steht die Formel =AY2-ZEILE()/100

Zelle AY 2 bis AY 4 steht die Formel =ABS(AX 2)

Zelle AZ 2 Bis AZ 4 beziehen sich auf Namensfelder z:B. =L6

Zelle BB 2 Bis BB 4 steht die Formel =WENNFEHLER(SVERWEIS(KGRÖSSTE(Ay2:Ay4;1);Ay2:Az4;2;FALSCH);"") in BB3 (AX2:AX4;2)usw.

Bis zur Rangfolge ist alle OK. 

In AY 2 steht die Zahl 7,98           In AY 3 steht die Zahl 0,03          In AY 4 steht die Zahl 6,04

Funktioniert auch ü

Nun mein Problem

Rang 1

In Zelle AB9 soll der Name mit dem höchsten Wert erscheinen ist auch der Fall also 7,98 von AY2

Rang 2

In Zelle AB10 soll der Name mit dem 2 höchsten Wert erscheinen, also 6,04 von AY3

Doch dieser erscheint in Zelle AB 13 wo eigentlich der mit dem niedrigsten Wert stehen sollte, also 0,03 aus Zelle AY 3.

                                                                                          Wert     Name

Meine Formel der Zellen AB 9 bis AB 13 lauten =WENN(AY2<>0;BC2;"") Diese Formel habe ich mit > probiert geht nicht mit < auch nicht. Eine 1 eine 2 gesetzt funktioniert auch nicht

Wo befindet sich mein Fehler, wer kann mir helfen.

Für Hilfe wäre ich sehr Dankbar

1 Antwort

0 Punkte
Beantwortet von addeguddi Mitglied (332 Punkte)
ausgewählt von halfstone
 
Beste Antwort

Hallo habe den Fahler gefunden.

da diese Liste ziemlich umfangreich ist habe ich bei der Wenn Funktion den Fehler gefunden. Die Zellen AY haben dadurch falsch berechnet Die Formel dafür 

Richtig ist =WENN(Q6>Q7;5)+WENN(Q10>Q9;5)+WENN(Q6<Q7;0;1)+WENN(Q10<Q9;0;1)

Fehler=WENN(Q6>Q7;5)+WENN(Q10>Q9;5)+WENN(Q6<Q7;1)+WENN(Q10<Q9;1

Nun ist alles gut.

Funktioniert super

...