36 Aufrufe
Gefragt in Tabellenkalkulation von jojo1978 Einsteiger_in (59 Punkte)

Hallo,

Ich habe folgende Problem:

Ich habe in Spalte A unterschiedliche Nummern und in Spalte B die dazugehörigen Wochen (KW).

Nun möchte ich wissen wie häufig die unterschiedlichen Nummern in der dazugehörigen Woche vorkommt?

In meinem Beispiel müsste dann rauskommen:

KW26  = 3
KW27 =  2

Kann mir hierzu jemand eine Formel erstellen? 

Nummern KW
BB6280230655 26
BB6280230655 26
BB6280230655 26
BB6280230655 26
BB6280230655 26
BB6280230653 26
BB6280230653 26
BB6280230653 26
BB6280230653 26
BB6280230653 26
BB6280230656 26
BB6280230656 26
BB6280230656 26
BB6280230656 26
BB6280230656 26
BB6286300035 27
BB6286300035 27
BB6286300035 27
BB6286300035 27
BB6286300035 27
BB6286300035 27
BB6286300035 27
BB6286300045 27
BB6286300045 27

 Vielen Dank für Euer Unterstützung.

Grüße jojo

2 Antworten

+1 Punkt
Beantwortet von m-o Profi (15.2k Punkte)

Hallo Jojo,

in dem folgenden Beispiel für die 26. Kalenderwoche stehen deine Nummern in Spalte A und die Kalenderwoche in Spalte B in dem Bereich von A15 bis B38 (ohne die Überschriften).

=SUMME(WENN((B15:B38=26)*(A15:A38<>"");1/ZÄHLENWENNS(A15:A38;A15:A38;B15:B38;26)))

Achtung! Es handelt sich um eine Matrixformel. Daher mit Strg + Umschalt + RETURN abschließen!

Achte darauf, dass sich die Bereichsangaben immer entsprechen.

Die Formel habe ich hier gefunden und angepasst: Link

Gruß

M.O.

0 Punkte
Beantwortet von jojo1978 Einsteiger_in (59 Punkte)
Hallo M.O.

danke für deine Antwort.

in meinem Beispiel Funktioniert es.

Jetzt werde ich es mal auf meine ganze Tabelle übertragen (-:

Danke für deine Unterstützung.

jojo
...