Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Auswahl-Funktion





Frage

Hab sone Lotto-Aufgabe zu lösen. Ich habe in meiner Tabelle von den letzten 20 Ziehungen jeweils die 6 Zahlen zu stehen. Von diesen Zahlen soll ich jetzt die absolute und relative Häufigkeit ermitteln. Weiß jemand was hier mit absolut und relativ gemeint ist? Und dann soll ich automatisch einen Tipp mit den am wenigsten gezogenen Zahlen erstellen lassen. Ich hab also erstmal in Spalte A alle Zahlen von 1-49 geschrieben und Spalte B daneben für die jeweiligen Zahlen, wie oft sie in den Ziehungen gezogen wurden. Jetzt ists aber so, dass ja ein Tipp aus nur 6 Zahlen besteht. Ich hab aber nur 2 Zahlen die gar nicht gezogen wurden (in Spalte B ne 0) und 9 Zahlen die einmal gezogen wurden. Jetzt kommen also für die am wenigsten gezogenen Zahlen insgesamt 11 Zahlen in Frage, wobei die 2 Nuller auf jeden Fall als wirklich am wenigsten gezogene Zahlen enthalten sein müssen. Kann ich jetzt durch irgend eine Formel erreichen, dass er aus den einmal-gezogenen Zahlen nur noch 4 auswählt (auslost)?

Antwort 1 von Lauzijungs

Kann mir hier wirklich niemand helfen?

Antwort 2 von Aliba

Hi Lauzijungs,

In A1 bis A49 stehen die Zahlen 1 bis 49
In SpalteB stehen die gezogenen Zahlen (bislang 120, können aber auch mehr werden)
Formel in C1 und bis C49 nach unten ziehen (absolute Häufigkeit)
=ZÄHLENWENN(B:B;A1)+ZUFALLSZAHL()/100000
Format in diesen Zellen: Zahl, keine Dezimalstellen
Spalte D als % mit 2 Nachkommastellen formatieren.
Formel in D1 und bis D49 nach unten kopieren:
=C1/ANZAHL2(B:B)

Zellen E1 bis E6 als Zahl ohne Dezimalstellen formatieren:
Formel in E1, bis E6 nach unten ziehen:
=INDEX($A$1:$A$49;VERGLEICH(KKLEINSTE($C$1:$C$49;ZEILE(A1));$C$1:$C$49;0))

ACHTUNG!! Der Vorschlag für die Lottotips verändert sich bei jeder Berechnung oder Wertänderung in der Tabelle.

CU Aliba

Antwort 3 von Lauzijungs

Hi Aliba,

danke erstmal für deine ersten Ansätze. Sie haben mir schon etwas weitergeholfen.
Nur bei dem Schritt der Formeln in Zelle E, gibts bei mir nen kleines Problem. Wenn ich die Formel einfüge und dann runterziehe, steht bei mir immer die gleiche Zahl da.
Liegt das an der Formel oder hab ich was falsch gemacht?

Antwort 4 von Aliba

Hi Lauzijungs,

da muss irgend etwas falsch sein, kann jetzt natürlich nicht sagen, was das ist.
Am besten mailst Du mir mal Deine Datei.
ali-gitti@t-online.de

CU Aliba

Antwort 5 von Lauzijungs

Hi Aliba,

hat sich erledigt. War mein Fehler. Ich hatte bei der Formel in Spalte B aus Versehen nur den ersten Teil geschrieben, ohne das mit der Zufallszahl.
Danke nochmal für deine Tipps.

MfG
Lauzijungs

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: