Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Mittelwert ohne 0 in Zellen nicht in Bereichen ermitteln





Frage

Moin, ich habe ein kleines Problem und bin auch kurz vor dem Ziel. Ich habe 10 Messungen mit 500 zeitlich aufgelösten Werten. Nun möchte ich jeweils immer die zeitgleichen Werte zu einem Mittelwert zusammenfassen. Es gibt aber auch Zellen in denen eine Null steht, diese soll nicht mitgerechnet werden. Also, wenn ich von 10 Werten nur 8 mit Zahlen habe, dann soll der Teiler auch nur 8 betragen. Ich habe schon zwei Lösungen gefunden, die auch funktionieren: =SUMME(A1:A12)/ZÄHLENWENN(A1:A12;"<>0") =MITTELWERT(WENN(A1:A12;A1:A12)) Das Problem hierbei ist, das die Zellen nicht zusammenhängend sind. Die Werte stehen etwa so in dem Sheet: O7, O507, O1008, O1508! Wenn mir jemand helfen könnte, wie ich nicht einen Bereich, bei einer der beiden Formel angebe, sondern einzelne Zelle, dat wäre supper! THX! Demian

Antwort 1 von Saarbauer

Hallo,

das gleiche Problem, vielleicht geht das auch bei dir

http://www.supportnet.de/threads/172771

Gruß

Helmut