Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

bedingtes zählen





Frage

hallo, folgendes problem: ich habe 2 splten in A sind buchstaben von a-d und in spalte B sind zahlen von 1-5. nun will ich die zahlen 1,3 und 5 ZÄHLEN, aber nur wenn in der zeile davor ein a steht. ich habe schon sämtliche ergebnisse heruabekommen, nur nie das richtige. in der regel addiert excel zie ergebnisse bei mir immer, aber zählen tut es in den wenigsten fällen =SUMME(ZÄHLENWENN(B3:B18;"a"))+ZÄHLENWENN(C3:C18;1) hierbei hatte ich 7A´s und 5 1er.(in der sume sind das dann 12 bedigungen) ich will aber nur die zahlen gezählt haben vor denen ein a steht, (das müssten 2 sein a 1 b 2 c 3 d 4 a 5 a 1 als beispiel. für eure hilfe besten dank mfg Reve

Antwort 1 von rainberg

Hallo Reve,

=SUMMENPRODUKT((A1:A6="a")*(B1:B6={1.3.5}))

Gruß
Rainer

Antwort 2 von Aliba

Hi Reve,

=SUMMENPRODUKT(($A$1:$A$20="a")*(($B$1:$B$20=1)+($B$1:$B$20=3)+($B$1:$B$20=5)))

liefert die Anzahl der Datensätze, die in A1 bis A20 ein a stehen haben und in B1 bis B20 eine 1 oder eine 3 oeder eine 5 stehen haben.

=SUMMENPRODUKT(($A$1:$A$20="a")*(($B$1:$B$20=1))

liefert die Anzahl Datensätze a in SPalte A und 1 in Spalte B

CU Aliba

Antwort 3 von Aliba

Hallo Rainer,

warst mal wieder schneller und zudem noch kürzer.
Diese Variante kannte ich noch nicht.
So lernt man täglich dazu.

CU Aliba

Antwort 4 von Revenant

also bis hierhin schonmal vielen dank, denn ich fasse es nicht. also ich bin zivi, und die haben ja nix zu tun, also sitze ich schon seit ca. 1er woche davor und habs versucht mit meinen mangelhaften kentnissen hinzukriegen. ok das geht jetzt aber noch eine bitte:

die bedingungen 1,3 und 5 entsprechen personen.
1= ein mann 2=frau
3= zwei männer 4=zwei frauen
5=mann + frau 5=frau + mann

deswegen müsste ich jetzt wenn ich alle mäner zählen will die bedingung 3 mit 2 multiplízieren.

geht das denn auch? ich frag lieber gleich bevor ich wieder eine woche da sitzte.

gruß REVE

Antwort 5 von rainberg

Hallo Reve,

dann wird´s komplizierter.
Die Anzahl der Männer würde dann so gezählt (Formel ist allerdings ungetestet)

=SUMMENPRODUKT(($A$1:$A$20="a")*(($B$1:$B$20=1))+SUMMENPRODUKT(($A$1:$A$20="a")*(($B$1:$B$20=3))*2+SUMMENPRODUKT(($A$1:$A$20="a")*(($B$1:$B$20=5))

@Aliba
was sind schon 2 min an einem so langen Tag:-))

Gruß
Rainer

Antwort 6 von Revenant

hihi, ich kann doch was. also erstmal vielen dank für eure antworten. die 2te lösung von rainer hab ich leider nicht zum laufen bekommen, aber ich habs dann doch geschafft.

=SUMMENPRODUKT((B3:B18="a")*(C3:C18={1.5}))+SUMMENPRODUKT((B3:B18="a")*(C3:C18={3})*2)

also einfach die bedingung 3 aus dem ersten teil rausgenommen und nochmal drangehängt und mit 2 multipliziert.

vielen dank euch allen.

Antwort 7 von Revenant

ah, doch eine letzte frage hab ich noch. geht das auch mit farben? also an stelle der zahhlen als bedingung? das ich sage zähle alle 1er wo ein rotes feld vorne dran ist?

mfg REVE

Antwort 8 von Aliba

Hi Reve,

per Formel geht das nur, wenn das rote Feld nicht manuell sondern per bedingter Formatierung erzeugt worden ist.
Ansonsten nur mit VBA. Das ist jedoch nicht mein Ding.

Antwort 9 von rainberg

Hallo Reve,

folgender Code zählt dir alle Einser in B1:B20, wenn die entsprechende Zelle im Bereich A1:A20 rot gefärbt ist und schreibt das Ergebnis in C1.

 Option Explicit

Sub zaehlen()
    Dim rngZelle As Range, rngBereich As Range, intZ As Integer
    Set rngBereich = Range("A1:A20")
    For Each rngZelle In rngBereich
        If rngZelle.Interior.ColorIndex = 3 And rngZelle.Offset(0, 1).Value = 1 Then
            intZ = intZ + 1
        End If
    Next
    Cells(1, 3).Value = intZ
End Sub


Gruß
Rainer

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: