Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

doppelte Einträge





Frage

Ixch habe eine Tabelle wo Werte vo A3 bis A19 und B3 bis B19 keine doppelten werte eingetragen werden dürfen. Wie kann ich das verhindern das mir Angezeigt wird das es diesen Wert schon gibt

Antwort 1 von stens79

Wenn- oder sverweis-Funktion

Antwort 2 von schnallgonz

Moin erstmal,
ich nehme mal an, dass Dir die Kurzantwort nicht weiterhilft.
Allerdings ist Deine Frage auch in Kurzform gehalten, versuch´s das nächste mal mit einem Gruß.

Eine mögliche Variante sieht so aus:

=UND(A3<>"";ZÄHLENWENN($A$3:$A$19;A3)>1)


Diese Formel schreibt Du in eine Hilfsspalte z.B. C3 rein und ziehst sie runter bis C19.

Ein bessere Lösung ist, diese Formel als bedingte Formatierung zu verwenden.
Du markierst A3:A19,
Menü "FORMAT--Bedingte Formatierung..."
dort "Formel ist gleich" wählen, daneben o.g. Formel rein,
unter Format... wählst Du dann noch, wie die Formatierung aussehen soll, wenn ein Wert doppelt erscheint, z.B. rot, fett....
Dasselbe dann für den Bereich B3:B19, falls beide Bereiche getrennt geprüft werden sollen.
Wenn A3:B19 einheitlich geprüft werden soll, markieren und:

=UND(A3<>"";ZÄHLENWENN($A$3:$B$19;A3)>1)


mfg
schnallgonz

Antwort 3 von Saarbauer

Hallo,

Versuch es mal mit der Gültigkeitsregel

"Daten""Gultigkeit ...""Einstellung""Benutzerdefiniert"
"Formel"
=ZÄHLENWENN($A$1:A1;A1)=1

und Fehlermeldung einen entsprechenden Txet eingeben, dann wird der 2. Eintrag eines Wertes nicht zugelassen

Zelle kopieren und mit "Bearbeiten""Inhalte einfügen""Gültigkeit"

Gruß

Helmut

Antwort 4 von dierkm2006

Hallo Leute
Jetzt mal ein bischen konkreter. Ich habe eine Tabelle wo ich für einen Wettkampf Startnummern vergeben muß. Da zwei Klassen zusammen gestartet werden darf ich eine Startnummer nur einmal vergeben. Ich habe die Startnummern in den Feldern A3 - A19 und N3 - N19 zu beobachten das ich ja keine doppelte Startnummer vergebe. Um es dann für mich einfacher zu machen und die Fehlerquelle gering wie möglich zu halten brauche ich eine Formel oder was ähnliches was mir weiter hilft. Bis dann und frohe Ostern

Antwort 5 von Saarbauer

Hallo,

Lösung wie in AW 3 vorgeschlagen, mit dieser Ergänzung

=ZÄHLENWENN($A$1:$A$19;A1)+ZÄHLENWENN($N$1:$N$19;A1)=1

für Zelle A1, dann auf restliche Zellen übertragen.

Im Bereich N1:N19 ist der Vergleichswert A1 durch N1 zu ersetzen (überprüfen ob automatisch erfolgt)

Gruß

Helmut

Antwort 6 von dierkm2006

Super Sache
Jetzt habe ich es geschafft. Danke nochmal für die Hilfe. Schöne Feiertage für Euch

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: