Du bist hier::--Summewenn und Zählenwenn mit mehreren Kriterien mit Excel

Summewenn und Zählenwenn mit mehreren Kriterien mit Excel

In meinem Beispiel soll die Summe der Spalte J gebildet werden, wenn in Spalte D „ZHL“ steht und in Spalte H „E“ steht.

Wie würde die Formel für Zählenwenn für die Bedingungen aussehen? Für diesen Fall ist die Matrixformel „Summenprodukt“ geeignet.
Im Gegensatz zu „normalen“ Formeln, die sich auf einzelne Zellem beziehen, beziehen sich Matrixformeln auf Bereiche.

Syntax für Summewenn mit mehreren Bedingungen:

=Summenprodukt((Bereich1=Suchkriterium1)*(Bereich2=Suchkriterium2)*…*(Bereich30))

Es können bis zu 30 Bereiche angegebne werden, die alle dieselbe Größe haben müssen. Die Bereiche dürfen sich nicht auf ganze Spalten (B:B oder B1:B65536) beziehen.
Der letzte Bereich ist der, der summiert werden soll.

Für das gegebene Beispiel würde die Lösung so:

=SUMMENPRODUKT((D1:D50="ZHL")*(H1:H50=“E“)*(J1:J50))

aussehen.

Summenprodukt lässt sich aber auch für Zählenwenn mit mehreren Bedingungen verwenden.
Die Syntax entspricht der ersten Variante. Der einzige unterschied besteht darin, dass allen Bereichen ein Suchkriterium zugeordnet wird.

Die Formel:

=SUMMENPRODUKT((D1:D50="ZHL")*(D1:D50=“E“))

zu dem Beispiel, würde die Anzahl der gefundenen „ZHL“ + „E“ Kombinationen liefern.

Der Vergleich ist nicht auf gleich (=) beschränkt. Es können auch alle anderen Operatoren verwendet werden:
ungleich (<>), kleiner (<), größer (>), kleiner – gleich (<=) und größer – gleich (>=).

Auch wenn es wahrscheinlich niemand ausschöpft, Summenprodukt unterliegt den gleichen Beschränkungen wie alle Formeln.

    Länge des Formelinhalts: 1.024 Zeichen
    – Argumente in einer Funktion: 30
    – Verschachtelte Funktionsebenen: 7

Von |2018-07-25T14:46:02+00:00Juli 12th, 2006|Kategorien: Tabellenkalkulation|1 Kommentar

Über den Autor:

Ein Kommentar

  1. utschi74 17. Mai 2009 um 17:03 Uhr

    Super Kommentar. Hat mir sofort geholfen. Besten Dank.

Hinterlassen Sie einen Kommentar