Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Formel mit Werten aus anderen Zellen ergänzen





Frage

Hallo Leute, folgende Frage: Ich möchte eine Formel mit einem Wert aus einer anderen Zelle ergänzen, bzw aufbauen, so dass die Formel eine gewisse Dynamik enthält. Beispiel: =Summe(A4:B6) In Zelle B6 möchte ich jedoch den Wert für die Formel vorgeben können. Also zum Beispiel: "A1000" Geht so etwas??? Wohlmöglich auch ohne VBA? Danke Hudel

Antwort 1 von Saarbauer

Hallo,

versuch es mal damit

=SUMME(A4:INDIREKT(B6;1))

Gruß

Helmut

Antwort 2 von Hudel

Hey,

danke! Das ging ja schnell.

Kurze Nachfrage:
Gibt´s denn auch ne Möglichkeit, wenn Ich z.B. nur den Zeilenindex, also bei obigem Beispiel die 1000 dynamisch machen will? Also A fest. Geht ja so mit der INDIREKT-Funktion nicht, so wie ich das rausgefunden habe.

DANKE

Hudel

Antwort 3 von Saarbauer

Hallo,

habe ichjetztnicht ganz verstanden, du Kannst auch eingeben

= Summe (A:A)

dann werden alle Werte in Spalte A genommen oder wie hast du es gemeint?

Gruß

Helmut

Antwort 4 von Hudel

Hallo,

Ich möchte eingeben können =summe(A10:A"b4")
in b4 möchte ich bspw. 10000 eingeben können, sodass dann a10 bis a10000 summiert wird.

Nur Nebenbei:
Ich brauche dass, weil ich bei einer Summenprodukt-Formel den Datenbankbereich dynamisch gestalten will. Die Frage hab ich nur bezogen auf die summen-formel gestellt, weil das nicht so umfangreich war!

danke


hudel

Antwort 5 von Saarbauer

Hallo,

damm musst du mit Adresse() arbeiten, wahrscheinlich in der Form =Indirekt(Adresse(......);1)

Würde dir raten es folgendermassen aufzubauen:

In eine Zelle (z.B. B5) =Adresse (..........) und in einer weiteren Zelle (z.B. C5) =Indirekt (B5,1) und wenn das funktioniert, die Formel aus B5 an die richtige Stelle in C5 kopieren, erspart ne ganze Menge Arbeit, da es so übersichtlich bleibt.

Gruß

Helmut

Antwort 6 von M.O.

Hallo hudel,

du suchst wahrscheinlich folgende Syntax:

=SUMME(A10:INDIREKT("A"&B4))

Gruß

M.O.