Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

gleiche Werte in Excel zusammenfassen





Frage

Hallo, kann mir jemand sagen wie ich in Excel alle gleichen werte zusammenfassen kann. z.B. wie folgt: Spalte A - bisher 12 30 12 25 12 12 30 30 25 Spalte A - neu 12 25 30

Antwort 1 von hubo

Es soll also jede Zahl nur einmal pro Spalte vorkommen. Die doppelten können gelöscht werden.

Danke für Eure Hilfe.

Antwort 2 von Saarbauer

Hallo,

=ZÄHLENWENN($A$1:A1;A1)

versuchs mal damit in Zelle B1 und anschliessend nach unten ziehen.

Dann mit "Autofilter""Benutzerdefiniert" "Entspricht nicht" 1 oder "Sortieren" nach Spalte B und alle Werte >1 löschen

Gruß

Helmut

Antwort 3 von hubo

Eigentlich bräuchte ich das etwas anders. Ich will nicht zählen wie oft eine Zahl in der Spalte A vorkommt, sondern jede Zahl soll nur 1x in der Spalte A vorkommen.

Gibt es da eine Möglichkeit, alle doppelten Zahlen irgendwie zu löschen?

Antwort 4 von nostalgiker6

Spricht etwas dagegen, die Zeilen zuvor zu sortieren?

Antwort 5 von hubo

nein da spricht nichts dagegen.

Im grunde soll daraus nur ein Diagramm entstehen. Für jeden Wert (egal wie oft er in der Spalte vorkommt) soll lediglich 1 Balken zu sehen sein.

Antwort 6 von philharmoni

Ich habe das mal folgendermaßen gemacht:

1. Die Daten markieren. (Also z.B. die ganze Spalte)

2. Im Menü "Daten" auf "Teilergebnisse"

3. Dann: "Unter Verwendung von: Anzahl" und "OK"

4. Damit bekommst du eine Liste wie:

Anzahl | Daten
2 | 12
4 | 10
3 | 8
usw.

5. Dann müsstest du nur noch die Spalte "Anzahl" löschen und hast, was du willst.

Antwort 7 von nostalgiker6

Wenn die Zeilen sortiert sind, in eine zusätzliche Spalte eingeben (z.B.):
[in A2] =WENN(B2=B1;1;0)
Dann alle Zeilen ausfiltern, in denen in DIESER Spalte eine 1 steht.

Antwort 8 von nostalgiker6

Also - eigentlich umgekehrt: Per Filter alle Zeilen anzeigen lassen,. in denen ine 1 steht.

Antwort 9 von nostalgiker6

Und (sorry) die Formel nicht nur in die eine Zelle schreiben, sondern herunterziehen - aber das versteht sich ja eigentlich von selbst.

Antwort 10 von nostalgiker6

Ich glaub´, ich bin besoffen (bin ich aber nicht): Zu Antwort 8 - ... in denen eine NULL steht (aber das versteht sich ja eigentlich auch von selbst).

Antwort 11 von Saarbauer

Hallo,

wenn du mit meinem Vorschlag arbeitest wird der Wert in Spalte A beim ersten vorkommen mit 1 gezählt, bei jedem witeren vorkommen erhöht sich der Zählwert. Anschliessend kannst du alle Werte bei denen der Zählwert grösser 1 ist löschen und somit hast du deine Werte.

Gruß

Helmut

Antwort 12 von wutzwutz

Seid mir nicht böse, aber das ist alles viiiiiel zu kompliziert.
DATEN->Filter->Spezielfilter->Liste an gleicher Stelle filtern->Listenbereich auswählen->Keine Duplikate
Fertig.
Schön´ Tach noch
wutzwutz

Antwort 13 von wutzwutz

Nochwas, wenn Du eine Liste z.b. folgendermaßen willst: 3|12
4|25
6|30
dann geht das am besten über
Statistik-Häufigkeit. Ratzfatz

Serwass
wutzwutz

Antwort 14 von nostalgiker6

Die Sache hat mich auch interessiert - dashalb auch von mir vielen Dank für die Anregung "Keine Duplikate"

Antwort 15 von wutzwutz

Gerne. Ich habs auch nicht gewußt vorher, und versucht die Lösung zu finden. So hab ich selbst auch was dabei gelernt.

wutzwutz