Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Berechnung der Arbeitzeit bei Eingabe der Endzeit





Frage

Hallo, Ich barauch Eure Hilfe. Hab eine Excel Tabelle erstellt mit der ich Arbeitsschritte planen möchte. Ich möchte gerne durch Eingabe des Fertigdatums gerne die Daten bekommen, an dem ein Arbeitsschritt beginnen soll. z.B. Bei einer Arbeitszeit von 8 Std am Tag von 8-16 Uhr. Enddatum 26.05.2006 15:00 Uhr Verpacken 00:45 Std Verpackungsbeginn 14:15 Lackierung 4:00 std Lackierungsbeginn 10:15 Montage 8:00 Std. Montagebeginn am 25.05.2006 10:15 Uhr usw. Da ist auch mein Problem. Bei meiner jetzigen Berechnung Rechnet er bei den 8 Std. das Datum 25.05.2006 02:15 aus. Wie bekomme ich das hin, das er nur einen Tag von 8 Stunden berücksichtigt??? Ich danke Euch für Eure Hilfe. Gruß Elhamplo

Antwort 1 von M.O.

Hallo Elhalmplo,

folgender Vorschlag: zu deiner Arbeitszeit werden je 8 Stunden einfach 16 Stunden dazugezählt.
In A2 steht die Summe aller Arbeitsschritte.

=A2+ABRUNDEN(A2*24/8;0)*16/24

Du kannst statt A2 natürlich auch die Summe oder entsprechende Funktion einbauen.
Wenn du diese Zahl dann von deiner Endzeit abziehst, sollte das richtige Ergebnis herauskommen.

Gruß

M.O.

Antwort 2 von Elhamplo

Hallo,

danke für Deine Hilfe.

Klappt gut, aber leider noch nicht die ganze Lösung. Leider wird nicht berücksichtigt das ein Arbeitstag von 7:30 bis 16:00 Uhr gehen kann. So rechnet die Formel bei einer Gesamtarbeitsstunden von 9 und ein Abgabetermin am 25.06.2006 08:00:00 ein Starttermin um 24.06.2006 07:00, was nicht geht, da ja schon am 23. begonnen werden muss.

Hast Du vielleicht noch eine Idee???

Gruß

Elhamplo

Antwort 3 von M.O.

Hallo Elhamplo,

wenn du statt ABRUNDEN die Funktion AUFRUNDEN nimmst, dann klappt die Formel bei einer Arbeitszeit zwischen 8.00 und 16.00 Uhr ganz gut (soweit ich es ausprobiert habe).

Mal sehen, ob mir was einfällt, wenn die Arbeitszeit bereits um 7:30 Uhr beginnt.

Gruß

M.O.

Antwort 4 von Elhamplo

Hallo,

Sorry, das ich mich erst jetzt melde. Hab einen kleinen Kurzurlaub gemacht und hatte auch keine PC dabei.

Danke für Deine Mühe.

Hab das mal ausprobiert. So ganz klappt das nicht bei mir. Wie ziehst Du denn das eine Datum von dem anderen Datum ab?? Einfach Enddatum - der Zahl aus Deiner Formel??

Wenn meine Gesamtstunden für eine Montage von 12 Stunden ist un die Endzeit um 16:00 sein soll, dann steht bei mir die Anfangszeit bei 20:00 Uhr.

Hast Du vielleicht noch eine Idee????

Danke!!!!!

Gruß

Elhamplo

Antwort 5 von Saarbauer

Hallo,

ich geh von folgenden Vorgaben aus:
in Spalte A Steht in zelle A2 das Enddatum mit Uhrzeit In Spalte B stehen ab Zelle B3 die Zeiten der Arbeitsschritte, Spalte C Text Arbeitsschritte.

In Zelle A3 ist dann einzutragen

=WENN(ZEIT(STUNDE(A2-B3);MINUTE(A2-B3);0)>7,5/24;A2-B3;A2-B3-16/24)

und nach unten ziehen. Die Formel ist für Arbeitsbeginn 8:00 Uhr ausgelegt, Bei veränerung des Arbeitsbeginns z.B. auf 7:30 Uhr ist der Wert 16 (Nachtruhe von 16:00 Uhr bis 8:00 Uhr = 16 h) entsprechend abzuändern (16:00 Uhr bis 7:30 Uhr = 15,5 h, also 15,5).

Gruß

Helmut

Antwort 6 von Saarbauer

Hallo,

da ich etwas rumgespielt habe mit den Zeiten, habe ich noch einen Fehler in der Formel

=WENN(ZEIT(STUNDE(A2-B3);MINUTE(A2-B3);0)>7,5/24;A2-B3;A2-B3-16/24)

ist auf 7:30 Uhr Arbeitsbeginn, müsste hier 8,00 heissen

Eine weitere Lösung ist
in Zelle B1 täglichen Arbeitsbeginn eintragen und in Zelle C1 tägliches Arbeitsende und dann mit der folgenden, etwas abgewandelten, Formel

=WENN(ZEIT(STUNDE(A2-B3);MINUTE(A2-B3);0)>$B$1;A2-B3;A2-B3-(1+$B$1-$C$1))

arbeiten



Gruß

Helmut

Antwort 7 von Elhamplo

Hallo,

danke, danke, danke...

Läuft super mit den Formeln.

Ich danke Dir für Deine Mühe!!!!!!!!!!!

Gruß

Elhamplo

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: