Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

automatische Nummerierung





Frage

Hallo zusammen, Wie kann ich denn, Excel automatisch Nummerieren lassen ? Gruß Ralf

Antwort 1 von Saarbauer

Hallo,

leider zu "detailiert" um dir richtige Auskunft zu geben, es sind für weitere Hilfe nähere Angaben erforderlich.

Gruß

Helmut

Antwort 2 von RalfH

Hallo,
sorry werde mir mehr mühe geben.

Ich habe eine Liste in Excel erstellt Beispiel:

1 Aufgabe Beschreibung Nochwas
Detailschritte
2 Aufgabe Beschreibung Nochwas
3 Aufgabe Beschreibung Nochwas

Das geht so bis 100.
Jetzt kommt es aber vor das ich die 3 Entferne muss
um einen Detailschritt zu hinterlegen. Dabei muss ich dann die gesamte Liste neu durchnummerieren. Geht das eventuell entwas komfortabler ?

Antwort 3 von Saarbauer

Hallo,

schreibe in Zelle A1 eine 1 und
dann in A2 =MAX($A$1:A1)+1
Dies soweit wie erforderlich nach unten ziehen und dann Zeilen ohne Nummerierung rauslöschen.

Gruß

Helmut.

Antwort 4 von coros

HAllo Ralf,

nachfolgend ein Makro, welches Dir die Spalte A von Zeile 1 bis Zeile 100 neu durchnummeriert, wenn eine Zeile gelöscht wird. Kopiere den Code in das VBA-Projekt des Tabellenblattes, in dem die Nummerierung erfolgen soll.

Option Explicit

Private Sub Worksheet_Change(ByVal Target As Range)
Dim i As Integer, Nr As Integer
Application.EnableEvents = False
If Target.Column = 1 Then
Nr = 1
For i = 1 To 100
Nr = Nr + 1
Cells(i, 1) = Nr
Next
End If
Application.EnableEvents = True
End Sub


Ich hoffe, Du kommst klar. Bei fragen melde Dich. Gib dann aber mal an, in welchen Spalten Deine Daten stehen, damit man sich ein kleines Bild Deiner Datei machen kann.

Solltest Du nicht wissen, wie Du den Code in Deine Datei bekommst, dann schau mal auf meiner HP in der Rubrik Anleitungen und dort dann in der Anleitungsnummer 2 nach. Dort stelle ich dazu eine bebilderte Anleitung zur Verfügung, die Dir sicherlich helfen wird.

MfG,
Oliver
Da hier der einzige Lohn für die Helfer eine Rückmeldung ist, wäre es nett, wenn Du ein
Feedback abgeben könntest, ob der Lösungsvorschlag Dein Problem gelöst hat.

Antwort 5 von RalfH

Mensch das ist doch mal ein super Board hier, Dankeschön !!!
GrußRalf

Antwort 6 von fantalight

Den Tip von Helmut find ich super!
Kann man die Nummierung in den nachfolgenden Zeilen davon abhängig machen, ob in der restlichen Zeile ein Eintrag vorhanden ist oder nicht?
Oder anders gefragt: Wie erreiche ich es, dass die Nummerierung erst dann automatisch erfolgt, wenn ich in der betreffenden Zeile die Spalte B oder auch eine andere ausfülle?

Danke und Gruß
Torsten

Antwort 7 von coros

Hallo Thorsten,

bei Spalte B würde die Formel für A2, dass erst wenn in B2 etwas eingetragen wird, die Nummer erscheint, wie folgt lauten:

=WENN(B2>0;MAX($A$1:A1)+1;"")

MfG,
Oliver
Da hier der einzige Lohn für die Helfer eine Rückmeldung ist, wäre es nett, wenn Du ein
Feedback abgeben könntest, ob der Lösungsvorschlag Dein Problem gelöst hat.

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: