Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

bei sverweis die Fehlermeldung nv unterdrücken





Frage

Hallo Excel-Profis, ich bin noch ein ziemlicher Anfänger und habe folgendes Problem: Ich habe eine Zahlenreihe A1:A100 mit unterschiedlichen Zahlenwerten (Werte zwischen1 und 1000) nun möchte ich in Zelle A4 über Sverweis überprüfen ob die Zahl die in A5 steht bestandteil der Zahlenwerte in A1:A100 ist und wenn ja das Wort "vorhanden" in die Zelle A4 schreiben. Mein Problem ist nun wenn der Wert aus A5 nicht in meiner Zahlenreihe vorhanden ist kommt die Fehlermeldung "NV" wie kann ich das unterdrücken?

Antwort 1 von rainberg

Hallo Seewolf,

mach's doch so:

=WENN(ZÄHLENWENN(A1:A100;A5);"vorhanden;"")

Gruß
Rainer

Antwort 2 von Seewolf71

Hallo Rainer,

Danke für die schnelle Antwort, mir ist leider ein kleiner Fehler unterlaufen:

Ich habe eine Zahlenreihe A1:A100 mit unterschiedlichen Zahlenwerten (Werte zwischen1 und 1000) nun möchte ich in Zelle !!!!!E1 !!!!!!!über Sverweis überprüfen ob die Zahl die in !!!!!!!1F1!!!!!! steht bestandteil der Zahlenwerte in A1:A100 ist und wenn ja das Wort "vorhanden" in die Zelle !!!!!!!!!E1!!!!!!!! schreiben. Mein Problem ist nun wenn der Wert aus !!!!!!!!!!F1 !!!!!!!!!nicht in meiner Zahlenreihe vorhanden ist kommt die Fehlermeldung "NV" wie kann ich das unterdrücken?

ich hab die Fehler mit Ausrufezeichen markiert weil ich keine Farbmarkierung gefunden habe, Sorry hab mich vorher etwas mit Zeilen und Spalten verhaspelt

Danke im vorraus

Wolfgang

Antwort 3 von Aliba

Hi Wolfgang,

bei dem Formelvorschlag von Rainer musst Du nur A5 durch F1 ersetzen.

Wenns denn unbedingt mit SVERWEIS sein muss, dann:

=WENN(ISTNV(SVERWEIS(F1;A1:A100;1;0));"nicht vorhanden";"vorhanden")

CU Aliba