Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Excel: Auswertung nach Datum





Frage

Hallo, ich habe in einer Tabelle Ca. 300 Zeilen. Im Laufe der Zeit fülle ich in Spalte AC ein Datum ein. Damit endet der Datensatz (Zeile). Nun möchte ich am Ende der Tabelle eine Auswertung haben, wieviele Datensätze ich in dem Monaten Januar, Februar....Dezember abgeschlossen habe. Wie bekomme ich das hin, ohne jedesmal per Autofilter zu sortieren und zu zählen ? Danke

Antwort 1 von Hajo_Zi

Hallo nick,

mit SUMMENPRODUKT()
=SUMMENPRODUKT((A1:A100<>"")*(MONAT(A1:A100)=1)*(JAHR( A1:A100)=2003))

Gruß Hajo

Antwort 2 von Saarbauer

Hallo,

die Formel von @Hajo_Zi ist grundsätzlich ok., jedoch berücksichtigt sie max 100 Zeilen

=SUMMENPRODUKT((A1:A100<>"")*(MONAT(A1:A100)=1)*(JAHR( A1:A100)=2003))

Gruß

Helmut

Antwort 3 von Hajo_Zi

Hallo Helmut,

da hast Du Recht, aber eine Anpassung der Zeilenzahl und der Spaltenbeschriftung habe ich nicht als Problem angesehen.

Gruß Hajo

Antwort 4 von Helmut46

Hallo zusammen
habe mir eine Eingabemaske runtergeladen und für meine Zwecke umgebastelt... soweit ich es konnte. Es schreibt mir die Daten in die Tabelle Nachkalulation.Habe es auch hinbekommen das es mir die ListBox mit der Bezeichnung "Bezeichnung "füllt ,aber das mit der Befüllung ListBox "Artikelname "bekomme ich nicht gebacken.
Vieleicht könntet ihr auch schauen wegen der befüllung der Textboxen :Behältnis,Preis und Nr.
Daten stehen in der Tabelle "Material"




Private Sub CommandButton2_Click()
Preis = ""
Nr = ""
MaterialMenge = ""
Behältnis = ""
End Sub

Private Sub Daten_übernehmen_Click()
Dim Zeile As Long
'Schleife und Abfrage zum Prüfen ob Datensatz in Tabellenblatt bereits vorhanden
For Wiederholungen_Eintrag = 2 To Range("B65536").End(xlUp).Row

If Bezeichnung.Text = Cells(Wiederholungen_Eintrag, 2) _
And Artikelname.Text = Cells(Wiederholungen_Eintrag, 1) Then

Eintrag_vorhanden = 1
Zeile_Eintrag = Wiederholungen_Eintrag
End If
Next

'Wenn Eintrag bereits vorhanden, die Daten in der entsprechenden Zeile abändern
If Eintrag_vorhanden = 1 Then
Sheets("Nachkalkulation").Cells(Zeile_Eintrag, 2) = Artikelname
Sheets("Nachkalkulation").Cells(Zeile_Eintrag, 5) = Behältnis
Sheets("Nachkalkulation").Cells(Zeile_Eintrag, 6) = Preis
Sheets("Nachkalkulation").Cells(Zeile_Eintrag, 1) = Nr
Sheets("Nachkalkulation").Cells(Zeile_Eintrag, 4) = MaterialMenge
SendKeys "{TAB}"

'ansonsten Daten in erste leere Zeile eintragen
Else
Zeile_Blatt_1 = Sheets("Nachkalkulation").Range("A65536").End(xlUp).Offset(1, 2).Row

Sheets("Nachkalkulation").Cells(Zeile_Blatt_1, 2) = Artikelname
Sheets("Nachkalkulation").Cells(Zeile_Blatt_1, 5) = Behältnis
Sheets("Nachkalkulation").Cells(Zeile_Blatt_1, 6) = Preis
Sheets("Nachkalkulation").Cells(Zeile_Blatt_1, 1) = Nr
Sheets("Nachkalkulation").Cells(Zeile_Blatt_1, 4) = MaterialMenge

SendKeys "{TAB}"
End If
'Kombinationsfelder "Artikelname" und "Bezeichnung" leeren
Bezeichnung.Clear
Artikelname.Clear
'Schleife und Abfrage zum erneuten Füllen der ComboBox "Bezeichnung"
For Wiederholungen = 2 To Sheets("Material2").Range("A65536").End(xlUp).Row
If WorksheetFunction.CountIf(Worksheets("Material2"). _
Range("B2:B" & Wiederholungen), Worksheets("Material2"). _
Cells(Wiederholungen, 2)) = 1 Then _
Bezeichnung.AddItem Worksheets("Material2").Cells(Wiederholungen, 2)
Next

End Sub

Private Sub Eingabe_beenden_Click()
Unload Me
End Sub

Private Sub Bezeichnung_Change()

Artikelname.Clear

'Schleife und If Abfrage zum Finden von passenden Artikelname zu dem ausgewähleten Bezeichnung
For Wiederholungen = 2 To Sheets("Material2").Range("B65536").End(xlUp).Row
If Bezeichnung.Text = Sheets("Material2").Cells(Wiederholungen, 2) Then
'gefundene Artikelname in Spalte IV auflisten
Cells(Range("IV65536").End(xlUp).Offset(1, 0).Row, 256) = Cells(Wiederholungen, 1)
End If
Next
'Schleife und If Abfrage zum Füllen der ComboBox "Artikelname"
For Wiederholungen = 2 To Range("IV65536").End(xlUp).Row
Artikelname.AddItem Sheets("Material2").Cells(Wiederholungen, 256)
Next

'Aufgelistete Artikelname löschen

Range("IV:IV").ClearContents

End Sub



Private Sub Preis_Change()
Preis = Format(Preis, "#,##0.00 €")
End Sub

Private Sub TextBox1_Change()

End Sub

Private Sub UserForm_Initialize()
MsgBox "Bitte zuerst den Bezeichnung und danach den Artikelname wählen, damit Datensätze angezeigt werden können."
'Schleife zum Füllen der ComboBox "Bezeichnung" ohne Duplikate
For Wiederholungen = 2 To Sheets("Material2").Range("A65536").End(xlUp).Row
If WorksheetFunction.CountIf(Worksheets("Material2"). _
Range("B2:B" & Wiederholungen), Worksheets("Material2"). _
Cells(Wiederholungen, 2)) = 1 Then _
Bezeichnung.AddItem Worksheets("Material2").Cells(Wiederholungen, 2)
Next
End Sub

Private Sub UserForm_QueryClose(Cancel As Integer, CloseMode As Integer)
'Fehlermeldung, wenn versucht wird, die UserForm über das rote
'Schließenkreuz oben rechts zu schließen
If CloseMode = 0 Then
Cancel = 1
MsgBox "Bitte verlassen Sie das Dialogfeld mit den Schaltflächen.", _
vbOKOnly + vbInformation, "Bitte Schaltfläche betätigen."
End If

End Sub


Private Sub Artikelname_Change()

'Schleife und If Abfrage zum Füllen der restlichen Textfelder
For Wiederholungen_Artikelname = 2 To Range("B65536").End(xlUp).Row

If Bezeichnung.Text = Cells(Wiederholungen_Artikelname, 2) _
And Artikelname.Text = Cells(Wiederholungen_Artikelname, 1) Then

Behältnis = Cells(Wiederholungen_Artikelname, 3)
Preis = Cells(Wiederholungen_Artikelname, 4)
Nr = Cells(Wiederholungen_Artikelname, 7)
End If
Next

End Sub


Vielen Dank im voraus für eure Hilfe
Helmut

Antwort 5 von tannex

Hallo,

Danke !
Habe die Ansätze umformatiert und die Formel mal nachvollzogen klappt super !
Nun noch eine kleine Erweiterung:
IN Spalte I stehen Gruppennummern 1-21.
in SPalte AD die Datumsangaben.
In Spalte A die laufende Datensatznummer.
Mit der vorgeschlagenen Formel zähle ich nun in AD die Anzahl der Datensätze pro Monat.
Nun möchte ich aber noch wissen wieviele Gruppen ich pro Monat habe.
Da komme ich mit Bastelleien wie HÄUFIGKEIT, ANZAHL, ZÄHLENWENN momentan nicht vorwärts.
Wer kann helfen ?

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: