Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Rang mit mehreren Kriterien





Frage

Hallo Thema Rangliste in Excel: ich möchte, dass mir Excel einen Rang zurückgibt, wobei bei Punktgleichheit (=gleicher Rang mit "Rang()") ein neues Argument zur eindeutigen Bestimmung herangezogen wird usw. (analog verschiedener Sortierreihenfolgen) Bsp: A B C D E F G Name Jahrgang Runde1 Runde2 Total Rang Ziel a 1985 84 94 178 3 3 b 1984 78 74 152 6 6 c 1973 87 82 169 4 5 d 1952 87 82 169 4 4 e 1987 71 75 146 8 8 f 1976 97 84 181 1 2 g 1941 85 96 181 1 1 h 1963 72 75 147 7 7 A = Namen B = Alter C und D = Punkte aus zwei Runden E = Total der beiden Runden F = Resultate von "=RANG(E4;$E$4:$E$11)" G = Zielrangierung (entspricht der Sortierung: 1)E:absteigend; 2)D:absteigend; 3)B:aufsteigend Ist sowas mit Formeln machbar? d.h. wie kann ich Excel sagen, dass bei Punktgleichheit (können auch mehr als 2 oder 3 Personen sein) eine neue Regel dazukommt? Ich weiss ja nicht im voraus, welche Ränge mehrfach belegt sind und dadurch von Rang() übersprungen werden... Vielen Dank für Eure Anregungen

Antwort 1 von rainberg

Hallo,

schreibe in E2 folgende Formel und kopiere sie nach unten.

=SUMME(C2:D2)+D2%%-B2%%%

Gruß
Rainer

Antwort 2 von Hollow

Aha, clever, Danke.

zwar nicht gleich in Spalte E zu verwenden, aber als Hilfsspalte sehr praktisch und entsprechend erweiterbar :D

Vielen Dank und Grüsse

Antwort 3 von rainberg

Hallo,

Zitat:
zwar nicht gleich in Spalte E zu verwenden

...wieso nicht???

Du brauchst ja nur das Zellformat zu ändern (ohne Dezimalstellen)

Gruß
Rainer

Antwort 4 von Hollow

Zitat:
...wieso nicht???


weil man richtig lesen sollte... :oops:

hab beim Probieren nur +D2%-B2%% gemacht und da kommt es dann halt zu Rundungsfehlern...

Aber so gehts natürlich in einem Wisch

Danke nochmals

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: