Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Wert Übertragung mit Datum





Frage

Hallo, ich möchte eine Auswertung von Finanzen erstellen. Dies soll Wochenweise geschehen. Also Spalte A 8:14 die Wochentage. Spalte B 8:14 das jeweilige Datum. Spalte C-H 8:14 jeweils was ausgegeben wurde. Spalte I 8:14 zeigt jeweils die Summe von dem was Pro Tag ausgegeben wurde. Jetzt soll eine Formel auf einem anderen Tabellenblatt pro Monat zeigen, was für Geld ausgegeben wurde. Sie soll dabei das Datum als Grundlage nehmen. Also z.B. 01.01.08 = 500 € ausgegeben. 14.01.08 = 80 € ausgegeben. Ausgaben Januar 2008 = 580 € Ich versuche dies gerade über eine Matrixformel, jedoch bereitet mir das Datum Probleme(Tabellenblatt 1 heißt Woche): =SUMME((Woche!B8:Woche!B15=WERT(TEIL(Woche!B8:Woche!B15;4;2)="?01?"))*(Woche!I8:Woche!I15)) Hat jemand eine Idee, wie ich Excel nach dem Januar (also *01*, zukünftig Februar = *02* usw.) suchen lassen kann? Wenn ich nur Januar schreibe geht es, liegt also an dieser ärgerlichen Datumsvorformatierung. Vielen Dank vorab für die Hilfe!

Antwort 1 von M.O.

Hallo,

wenns auch was mit Hilfsspalte (die du ja auch ausblenden kannst) sein darf:
Lege dir eine Hilfsspalte mit folgender Formel: =MONAT(B8)
Die Formel ziehst du entsprechend nach unten. Damit werden dir dann die Monate als Zahl ausgewiesen und du kannst damit weiterrechnen,
z.B. mit SUMMEWENN.

Gruß

M.O.

Antwort 2 von bitfix

Mit der Textfunktion 'TEIL' geht das nicht! TEIL ist eine Stringfunktion, aber das Datum hat ein ganz anderes Format.

Ich schlage eine Hilfstabelle vor:
Hinter ihrer Summenspalte 'I' erzeugen Sie eine Spalte 'J' mit den Monatswerten aus dem Datum in Spalte 'B' :
=MONAT(B8)
= MONAT(B9)
.......
=MONAT(B15)


Diese Spalte enthält dann für z.B. Februar die '2' als Zahlenwert.
Jetzt folgt die Januar-Spalte 'K8:K15' mit den Formeln:
K8: =WENN(J8=1;I8;0)
K9: =WENN(J9=1;I9;0)
...
K15: =WENN(J15=1;I15;0)

Es wird aus der Tagessumme nur dann ein wert genommen, wenn der Monat stimmt. Damit erhält man in dieser Spalte ganz elegant die Monatssumme.
Danach die Februar Spalte L8:L15 mit
L8: =WENN(J8=2;I8;0)
L9: =WENN(J9=2;I9;0)
...
L15:=WENN(J15=2;I15;0)

nun die Märzspalte als M8:M15 u.s.w
In K16;L16;M;N..... lassen sie die Spalten-Summe berechnen: z.B. in K16: =SUMME(K8:K15) d.h. in K16 die Formel eintragen

Also für alle 12 Monate einfach die entsprechenden Spalten einrichten. Die Summen sind dann an festen Plätzen abrufbar.
Die Hilfsspalten können auch ausgeblendet werden um den Benutzer nicht zu irritieren.

Ich denke so geht es ganz gut....
Mit etwas VBA-Basic kann das natürlich auch über ein Makro gemacht werden.
Good luck

Antwort 3 von MichaelH

Hallo,
vielen Dank für die Antworten!
Mit der zusatztspalte Monat funktioniert es wunderbar.
Danke für den kleinen Tip!
Für Interessierte noch einmal meine entgültige Formel(Buchstaben haben sich verschoben), die 3 ist hier gleich die Ausgabe für den Monat März:
Matrixformel
=SUMME((Woche!J7:Woche!J370=WERT("3"))*(Woche!I7:Woche!I370))

Antwort 4 von Saarbauer

Hallo,

hiermit kannst das ganze automatisieren in die Summenzelle für Januar

=SUMMEPRODUKT((Woche!J7:Woche!J370>DATUM(2008;A1;0))*(Woche!J7:Woche!J370<DATUM(2008;A1+1;1))*(Woche!I7:Woche!I370))

eingeben und nach unten ziehen.

Funktioniert ohne Hilfsspalte

Gruß

Helmut

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: