Supportnet Computer
Planet of Tech

Supportnet / Forum / Anwendungen(Java,C++...)

Tomcat 4.1.27 mit JK2 in IIS 5 integrieren





Frage

Hall zusammen, ich versuche seit einiger Zeit den Tomcat mit seinen Servlet-Fähigkeiten in den IIS zu integrieren (bitte schlagt mir nicht vor, ich soll Apache nehmen) und schaffe es einfach nicht die Tomcat-Beispiele zum Laufen zu bekommen. Ich habe versucht nach folgender Anleitung vorzugehen : http://www.onjava.com/pub/a/onjava/2002/12/18/tomcat.html Ich habe also die Registry angepasst, den Filter im IIS angelegt und auch die Server.xml, sowie die properties Dateien modifiziert bzw. angelegt. Beim Starten des Tomcats erhalte ich die Fehlermeldung, dass der Port 8009 bereits vergeben sei. Beim Versuch JK2 zu verwenden (was auch immer das ist) erhalte ich beim Starten des Tomcats folgende Meldungen : 28.10.2003 09:10:33 org.apache.coyote.http11.Http11Protocol init INFO: Initializing Coyote HTTP/1.1 on port 8080 Starting service Tomcat-Standalone Apache Tomcat/4.1.27 28.10.2003 09:10:40 org.apache.struts.util.PropertyMessageResources <ini INFO: Initializing, config='org.apache.struts.util.LocalStrings', return 28.10.2003 09:10:40 org.apache.struts.util.PropertyMessageResources <ini INFO: Initializing, config='org.apache.struts.action.ActionResources', r 28.10.2003 09:10:43 org.apache.struts.util.PropertyMessageResources <ini INFO: Initializing, config='org.apache.webapp.admin.ApplicationResources 28.10.2003 09:10:48 org.apache.coyote.http11.Http11Protocol start INFO: Starting Coyote HTTP/1.1 on port 8080 28.10.2003 09:10:48 org.apache.jk.common.ChannelSocket init INFO: JK2: ajp13 listening on /0.0.0.0:8009 28.10.2003 09:13:02 org.apache.jk.server.JkMain start INFO: Jk running ID=0 time=20/70 config=C:\Tomcat\conf\jk2.properties Ich denke die Zeile: JK2: ajp13 listening on /0.0.0.0:8009 ist das Problem. In der Server.xml gibt es zwei Listening services für port 8009 : <!-- Define a Coyote/JK2 AJP 1.3 Connector on port 8009 --> <Connector className="org.apache.coyote.tomcat4.CoyoteConnector" port="8009" minProcessors="5" maxProcessors="75" enableLookups="true" redirectPort="8443" acceptCount="10" debug="0" connectionTimeout="20000" useURIValidationHack="false" protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler"/> <!-- Define an AJP 1.3 Connector on port 8009 --> <!-- <Connector className="org.apache.ajp.tomcat4.Ajp13Connector" port="8009" minProcessors="5" maxProcessors="75" acceptCount="10" debug="0"/> --> Kann mir jemand bitte verraten wie ich das Problem in den Griff bekomme ? Vielen Dank im voraus.

Antwort von



Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: