Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Excel-Formel Z WENN)





Frage

Hallo Gemeinde, möchte eine Excel-Formel erstellen, binaber nicht so der absolute Freak. Daher bitte ich um Eure Hilfe: Wenn in A1 "1" steht, soll in A2 "213,04" ausgegeben werden. Wenn in A1 "1,1" steht, soll in A2 "276,95" ausgegeben werden. usw. Mit A2 soll dann jeweils weitergerechnet werden (andere Formel). Wie müsste der Bezug A1 zu A2 ausehen? Dank im voraus. sharino

Antwort 1 von want2cu

Hallo sharino,

wenn es sich nicht nur um eine einfache Bedingung handelt, sondern diverse Möglichkeiten bestehen (du schreibst ja: usw..), dann würde ich das mit SVERWEIS lösen.

A1 ist das Eingabefeld,
in A2 folgende Formel:
=SVERWEIS(A1;B1:C100;2;falsch)

In den Bereich B2:C100 (als Beispiel) trägst du dann die entsprechenden Wertepaare ein, also in B1 die 1, in C1 die 213,04 usw.

Damit müßte es eigentlich klappen. Wenn du nicht klar kommst, melde dich noch mal.

CU
want2cu

Antwort 2 von Aliba

Hi,

folgende Formel in A2:

=WENN(A1=1;231,04;WENN(A1=1,1;276,95;WENN(usw....

Bei diesem usw... gibt es jetzt folgendes zu bedenken: Wieviele usw.. gibts denn noch?
Steht der Wert von A2 in irgendeinem rechnerischen Zusammenhang mit dem Wert in A1? Dann könnet man den Wert auch ohne WENN - Formel berechnen lasssen.
Sollte es sehr viele von den usw..s geben, bietet sich eher an, eine Wertetabelle zu erstellen un über SVERWEIS oder INDEX auf die Werte zuzugreifen.

CU Aliba

Antwort 3 von sharino

Hallo,

Danke erstmal.
Der Ansatz von Aliba passt genau. Es sind nur 5 Werte, die könnte ich über die Formel WENN eingeben. Klappt auch prima.

Danke auch nochmal an want2cu.

sharino

Antwort 4 von Errol Flynn

Noch'n kleiner Zusatz von mir: Die WENN-Funktion kann man bis zu 7 mal verschachteln, ab dann muss der SVERWEIS herhalten.

Grüße,
Errol

Antwort 5 von Aliba

Hi Errol,

in so einem Fall, wenn es um Werte geht, die geliefert werden , kann man auch WENNen bis zum Umfallen und soweit die Formel die Zeichenanzahl zulässt.
Du verschachtelst Deine Formel bis zu 7mal, wenn keine der Bedingungen zutrifft lässt Du als Sonstwert 0 ausgeben, dann kannst Du
die nächste 7mal verschachtelte WENN-Funktion, ebenfalls mit Sonst 0 über + zu der ersten addieren usw......
Also z.B:

=WENN(...;xxx;WEnn(...;yyy;WENN(...;zzz;WENN.......;0))))))+WENN(...usw.

CU Aliba

Antwort 6 von Aliba

Hi, nochmal ich,

in diesem Fall fällt mir auch noch eine andere Lösung über die Wahrheitswerte WAHR bzw. FALSCH ein, die ja von Excel als 1 bzw 0
interpretiert werden. Hier wäre dann auch diese Lösung denkbar:
=(A1=1)*216,04+(A1=1,1)*253,2+(A1=1,2)*312,5+(A1=1,3)*.........
Würde jetzt in A1 z.B. 1,2 stehen würde Excel rechnen:

FALSCH*216,04+FALSCH*253,20+WAHR*312,5+FALSCH...

also: 0*216,04+0*253,20+1*312,50+0*....

Für einen solchen Fall (auch dann mit mehr Möglichkeiten) keine allzu schlechte Alternative (die ganzen WENNen) fallen da weg.

CU Aliba

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: