Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Bei Zellwert 0 eine Zahl ausblenden





Frage

Hallo, Ich arbeite mit Win xp und Excel für xp. Bei meinen berechnungen habe ich folgendes Problem: Ich möchte Zelle a1 und a2 in a3 addieren. a1ist eine ganze Zahl und immer vorhanden, a2 ist auch eine ganze Zahl und nicht immer vorhanden. wenn a2=0 ist möchte ich in Zelle a3 keine Anzeige der Zahl, aber zu rechen zwecken muss ich mit der Zahl die ausgeblendet ist noch arbeiten können, vieleicht hat ja jemand einen Tip wie das Problem zu lösen ist. Für Anfragen bitte kurze E-Mail an mich. MfG Dieter

Antwort 1 von nighty

hi don :)

vielleicht so :)

=WENN(B2>0;A2+B2;"")

gruss nighty

Antwort 2 von don-amigo

danke für die schnelle Antwort, bei deiner Formel bleibt keine Zahl übrig wenn der Wert 0 ist ( A1 Muß ja immer übrig bleiben soll aber nur nicht angezeigt werden) mit dem ich in der nächsten Zellen weiter rechnen kann.

A1 1000
A2 + 20
A3 =1020 bis jetzt kein Problem

A1 1000
A2 + 0
A3 =(1000) Zahl ausgeblendet nicht zusehen
A4 + 20
A5 =1020


vieleicht hilft dir die Darstellung etwas


Gruß Dieter

Antwort 3 von czy

hallo dieter!
bei der formel von nighty wird die rechenoperation nicht ausgeführt wenn a2=0, wenn ich dich richtig verstanden habe soll der wert zwar berechnet aber nicht sichtbar sein.
das funktionniert mit bedingter formatierung für zeile 3:
format/bedingte formatierung
wenn "zellwert ist" / "gleich" / =a§1
format...
zeichenfarbe ist weiß
so wird der wert berechnet (kannst du erkennen wenn du die zellen markierst) ist aber nicht sichtbar
bitte rückmeldung ob ok
lg
gabi

Antwort 4 von czy

uups vertippst

...natürlich =a$1...

lg
gabi


Antwort 5 von pelle

Hallo Dieter,

arbeite doch mit der Bedingten Formatierung:

Zelle A3:

=Summe(A1:A2)

Bedingte Formatierung:

Formel ist => =ISTLEER(A2)

und stell die Schriftfarbe auf die Zellenfarbe ein!

Damit siehst du den Wert nicht, bleibt aber für Rechenoperationen erhalten!

gruss
pelle

Antwort 6 von don-amigo

Hallo Gabi,
der Weg den du beschreibst ist richtig ,aber mit der bedingten formatierung bekomme ich noch nicht in den Griff.

Gruß Dieter

Antwort 7 von Don-amigo

Danke an alle.
Mein Problem ist gelöst.
Ihr habt mir sehr geholfen. Auf die Idee mit der Zeichenfarbe währe ich nicht gekommen.
Danke nochmal


Gruß Dieter

Antwort 8 von pelle

Hallo Dieter,

:-) gut "kloppe" ich die Beispieldatei in die Tonne!

Hauptsache, dein Problem ist gelöst!

Danke für die Rückmeldung!

gruss
pelle

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: