Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Excel Frage zu Formel





Frage

Hallo, habe folgende Frage zu Excel: In einer Tabelle (Beispiel von links nach rechts - Auftragnummer, Name, Betrag, Artikel, usw) habe ich folgende Formel erstellt: =SUMMEWENN(B:B;X1;C:C), wobei in X1 der Name des Verkäufers steht. Hierbei summiert Excel wenn der Name übereinstimmt die jeweiligen Werte. Nun möchte ich aber ein zweites Auswahlkriterium in die Formel hinzufügen, das auch in einer Spalte steht. Also mal im Text: Wenn der Name in Spalte B "Meyer" ist und in Spalte F ein "L" steht, dann soll die summe aus "B" addiert werden. Ich kriegs leider nicht hin, wer kann mir helfen? Gruß xy919

Antwort 1 von Aliba

Hi xy919,

=SUMMENPRODUKT((B1:B1000="Meyer")*(F1:F1000="L")*C1:C1000)

Natürlich kann anstelle von Meyer und L hierbei auch ein Bezug auf die Zelle gemacht werden, in der Meyer, bzw. L steht.

CU Aliba

Antwort 2 von xy919

Hallo CU Aliba,
klasse, das paßt prima. Habs gerade ausprobiert.

Vielen Dank für die schnelle Hilfe.

Gruß aus Hessen

xy919

Antwort 3 von xy919

Hallo Aliba,
da das alles hervorragend klappt mit der von dir gestern u. a. Formel

=SUMMENPRODUKT((B1:B1000="Meyer")*(F1:F1000="L")*C1:C1000),

hab ich mir jetzt noch überlegt ich würde die Sache gerne nach Datum eingrenzen.
Das Datum liegt in der Spalte X
(Beispiel: 08.07.04) vor.
Nun möchte ich gerne anstelle von L eine Eingrenzung nach Datum "01.07.04 - 31.07.04"

Nur: Wie sag ichs meinem Kinde, also in dem Falle Excel ?

Danke für deine Mühe.

Gruß
xy919

Antwort 4 von StefanF

Du mußt einfach das "F" mit dem "X" ersetzen, und als Suchkriterium "*.07.*" eingeben. Durch die beiden Punkte vor und nach der "07" wird sichergestellt, daß die "07" nicht als Tag oder Jahr genommen wird. Klargekommen?


=SUMMENPRODUKT((B1:B1000="Meyer")*(X1:X1000="*.07.*")*C1:C1000)


Antwort 5 von want2cu

Hallo,

hier eine Musterformel, bei der in Spalte A ein Datum steht:

=SUMMENPRODUKT((MONAT($A$3:$A$31)=$E19)*(JAHR($A$3:$A$31)=I$18)*$B$3:$B$31)

In E19 steht der Monat als Dezimalzahl.

Die Formel müßte noch an deine Gegebenheiten angepasst werden.

CU
want2cu


Antwort 6 von want2cu

Hallo Stefan,

ich habe mal deinen Lösungsvorschöag probiert. Er klappt aber bei mir nicht.
Es hapert m.E. daran, dass es sich um ein Datum handelt, bei dem du nicht so wie von dir vorgeschlagen suchen kannst.
Das dürfte nur mit der Funktion MONAT (oder einer vergleichbaren LÖsung) funzen.

CU
want2cu

Antwort 7 von xy919

Hallo

- StefanF,
so hatte ich auch gedacht, leider hauts damit nicht hin, Ergebnis ist immer 0.

- want2cu
hm, der Weg scheint mir richtig, aber da könntest du mir mal helfen. Hier meine Formel wie sie aktuell ist:
=SUMMENPRODUKT((E3:E1000=A6)*(O3:O1000="PS")*F3:F1000)

Nur will ich als Kriterium(ich glaube da heist Argument) nicht "PS" sondern den Monat von "01.07.04 - 31.07.04"
Das mit den Spalten anpassen, das krieg ich dann schon selbst hin.

Danke.

Gruß
xy919

Antwort 8 von want2cu

Hallo xy19,

=SUMMENPRODUKT((E3:E1000=A6)*(MONAT(O3:O1000)=A1)*F3:F1000)

In A1 habe ich jetzt mal einfach den Monat als Variable reingepackt. Es handelt sich um einen einfache Dezimalzahl.
Über die Funktion MOnat wird der komplette Monat erfasst, man braucht also keine Zeitspanne mit "von-bis".

Probier es mal aus und gib ein Feedback. ob es jetzt funzt.

CU
want2cu

Antwort 9 von xy919

Hallo want2cu,

jau, das funzt prima.

Mit der Erklärung aus deiner letzten Antwort verstehe ich das jetzt auch ganz gut.

Tausend Dank.

Gruß
xy919



Antwort 10 von want2cu

Hi xy919,

schön, dasse sgeklappt hat und
Danke für die nette Rückmeldung.

CU
want2cu

Antwort 11 von xy919

Hallo Part II,
basierend auf obiger Frage + Lösung hab´ ich jetzt eine zusätzliche Frage:

In meiner Tabelle (siehe oben) habe ich die Umsätze der Verkäufer eingetragen und dank der mithilfe von want2cu kann ich daraus die Umsätze der einzelnen Verkäufer (sofern es denn welche sind ...) rausziehen.
Nun möchte ich noch aus der gleiche Liste gerne wissen welches der höchste Umsatz ist, den die einzelnen "Strategen" erzielt haben.
Geht das überhaupt, da ich mit der Max-Funktion das irgendwie nicht hinbekomme. Ich bekomme immer nur den höchsten wert aus der ganzen Liste?

Nochmal für die später hinzugekommenen:
Liste besteht aus folgenden Spalten
A - Name, B - Umsatz ...
wenn nun Verkäufer Meyer in A steht will ich dessen höchsten Umsatz aus der Liste.

Danke schonmal für eure konstruktive Hilfe - was wäre ich ohne das Supportnet ((ahnungslos wahrscheinlich)).

Gruß
xy919

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: