Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Doppelter eintrag ändern





Frage

Hallo @all, vielleicht kann mir ja mal helfen bei einem prob. Also ich habe eine Exceltabelle die eine TXT datei erzeugt um ca. 400 User per csvde in die AD zu impotieren. Es gibt viele möglichkeiten dies so einfach wie möglich zu machen, aber ich habe mich für diesen weg entschieden. Da die Administration für einen Leher später einfacher ist und das Sekreteriat die Liste bearbeitet. Nun zum eigentlichen und zum aufbau der Tabelle. 0|----A--------|-----B---------------- 1|-Vorname|---Nachname----- 0|--------------|----------------------- 2|Muster-----|Mustermann----- 3|Mustertest|Mustertestmann Daraus verbinde ich den Vornamen und den Nachnamen und kürze sie auch gleich. =WENN(A2="";"";VERKETTEN(KLEIN(LINKS(A2;1));KLEIN(LINKS(B2;2));"01")) Da es ja jetzt zweit user sind die dann den gleichen Namen haben geht es ja nicht. Also mache ich dahinter noch eine Zahl z.B. 01, 02, 03 usw. (Falls umlaute vorhanden sind dann werden diese auch bearbeitet und geändert, dies geht auch alles soweit.) Hier in diesem beispiel nun habe ich zweimal mmu01, nun müste ich doch ersteinmal herrausfinden welche namen gleich sind. Dies mache ich im moment noch so: =WENN(C2="";"";ZÄHLENWENN(C:C;C2)) Nun zeigt er mit natürlich 2 an da es ja auch zwei gleich einträge sind. Jetzt weiss ich aber nicht wie ich den einen wert hoch setzten kann z.B. den einen in 1 und den anderen in 2. Es gibt auch in der Tabelle die ich habe, 4 einträge die gleich sind, dies soll aber automatisch geändert werden. Da ich schon so einiges probiert habe aber nicht so richtig auf die Lösung komme frage ich hier bei euch nach. Hoffe ich habe es klar und deutlich erklärt und hoffe auf einpaar schöne positive Antworten. mfg Markus

Antwort 1 von Arnim

Hallo Markus,
wenn Du mit zwei Hilfsspalten leben könntest, die Du ausblenden kannst oder irgendwo ganz rechts einfügen kannst, dient Dir vielleicht dieser Vorschlag:
In C2:
=KLEIN(LINKS(A2;1))&KLEIN(LINKS(B2;2))
in D2:
=WENN(A2="";"";ZÄHLENWENN(C$2:C2;C2))
in E2:
=WENN(A2="";"";C2&"0"&D2)
und alle Formeln runterkopieren.
Spalten C und D ausblenden ( oder irgendwo unsichtbar plazieren, oder besser "platzieren").

Gruß Arnim

Antwort 2 von markusr_

@Arnim

hallo Arnim, die Antwort kam genau vom richtigen so weit ich mich errinnere.

Also wenn blödheit quitschen würde dann müste ich mit einem Ölkanister durch die gegend laufen.

Denn die Antwort ist ja so einfach das ich eigentlich selber darauf kommen sollte (Müsste).

Aber egal, jetzt geht es ja und in zukunft besser nachdenken bzw. schaun.


Vielen dank nochmals, bis dann
Markus



Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: