4.6k Aufrufe
Gefragt in SW-Sonstige von phlip Mitglied (231 Punkte)
Hallo,

Ausgangssituation:
Ich habe einen TrueCrypt Container unter Windows XP genutzt und diesen nun auf einen neuen Rechner mit Windows 7 Professional (32-bit) übertragen. Ich habe Administratorrechte. Ich nutze TrueCrypt in der Version 7.0.

Problem:
Wenn ich den Container mounte, erhalte ich eine Meldung, dass ich alle Dateien nur als "read-only" angezeigt bekommen kann.

Lösungsansatz:
Auf einem anderen Rechner mit Windows 7 Enterprise (32-bit) hatte ich kürzlich das gleiche Problem. Dort habe ich TrueCrypt vor dem Start mit der rechten Maustaste angeklickt und "Als Administrator ausführen" ausgewählt. Dann habe ich das Laufwerk gemounted, das virtuelle Laufwerk mit der rechten Maustaste angeklickt und über Eigenschaften --> Sicherheit meinem User Account vollen Zugriff gewährt. Bei jedem Start von TrueCrypt wurde ich dann automatisch gefragt, ob ich es als Admin ausführen möchte und mir wurden mir alle Dateien mit Vollzugriff angezeigt.

Bei dem jetzigen Rechner habe ich das auch probiert. Ich kann zwar meinem User Account volle Zugriffsrechte erteilen, aber ich werde nicht automatisch gefragt, ob ich TrueCrypt als Admin ausführen möchte. Die Dateien werden mir nur als read-only angezeigt.

Hat jemand eine Idee, wie ich wieder vollen Zugriff bekomme? Eine erste Google-Suche hat mir keine Ergebnisse geliefert, mit denen ich etwas hätte anfangen können. Um an der Registry herumzubasteln, habe ich zu wenig Erfahrung. Und da es auf dem oben beschriebenen anderen Rechner kürzlich funktionierte, sollte das auch nicht notwendig sein.

Danke und viele Grüße
Phlip

6 Antworten

0 Punkte
Beantwortet von
Container auf dem neuen PC entschlüsseln. Per TrueCrypt v7 auf dem neuen PC einen neuen Container erstellen. Dateien reinkopieren.
0 Punkte
Beantwortet von phlip Mitglied (231 Punkte)
Das habe ich jetzt ausprobiert. Das Problem besteht nach wie vor. Ich vermute, dass es über die Nutzerverwaltung zu lösen sein müsste, weil das auch auf dem anderen Rechner funktioniert hat. Nur weiß ich nicht, was ich dazu noch einstellen muss.

Habt Ihr weitere Ideen?

Gruß, Phlip
0 Punkte
Beantwortet von
du kannst doch in den optionen des jeweiligen containers schreib- und leserechte einstellen. funktioniert das nicht?

zur not im admin modus ändern.
0 Punkte
Beantwortet von phlip Mitglied (231 Punkte)
Auch das habe ich probiert. Leider erfolglos.
0 Punkte
Beantwortet von phlip Mitglied (231 Punkte)
Mir ist noch etwas eingefallen: Ich glaube, auf dem anderen Rechner konnte ich das Problem irgendwie lösen, indem ich etwas mit "Besitz übernehmen" angeklickt habe. Aber ich weiß nicht mehr wie. Vielleicht bringt das den einen oder anderen hier noch auf eine Idee ...
0 Punkte
Beantwortet von phlip Mitglied (231 Punkte)
Ich habe eine akzeptable Lösung gefunden:

Wenn TrueCrypt nicht gestartet ist, mit der rechten Maustaste auf das Programmsymbol klicken und "Eigenschaften" auswählen. Dort auf der Registerkarte "Kompatibilität" ganz unten unter dem Punkt "Berechtigungsstufe" den Haken bei "Programm als Administrator ausführen" setzen.

Windows 7 fragt nun zwar bei jedem Start von TrueCrypt, ob man damit einverstanden ist, dass das Programm Änderungen am System ausführen kann, was mit "Ja" beantwortet werden muss, aber zumindest muss man nicht mehr jedes Mal im Menü auswählen, dass man das Programm als Admin nutzen möchte.

Vielleicht hilft das ja einigen von Euch.

Gruß, Phlip
...