83 Aufrufe
Gefragt in Tabellenkalkulation von rastermen Mitglied (108 Punkte)

Hallo zusammen,

möchte mich noch mal an Euch wenden.

In Spalte A stehen unterschiedliche  Datums.

In Spalte I stehen Verkaufspreise.

In Spalte J stehen unterschiedliche Buchstaben wie "G" od. "T" untereinander.

In Zelle "L2" steht das zu suchende Datum.

In Zelle "N2" steht der zu suchende Buchstabe

3 Beispielzeilen:

A2-  15.09.18    I2-   350€        J2-    "G"         L2- 15.9.18     in N2 steht der zu suchende Buchstabe "G"

A3-  15.09.18    I3-   350€        J3-    "G"         L3- 15.9.18     in N2 steht der zu suchende Buchstabe  "G"

A4-  15.09.18    I4-   250€        J4-    "T"         L4- 15.9.18     in N2 steht der zu suchende Buchstabe 

Habe in O2 die Formel =SUMMEWENN(J2:J10000;N2;I2:I10000) eingegeben. Das Ergebnis hier 700€

Nun fehlt mir noch die Anpassung zu der Datumsabfrage.

Vielen Dank

Gruß

Rudolf

anbei zur Ansicht:

https://www44.zippyshare.com/v/ytswTwq8/file.html

8 Antworten

0 Punkte
Beantwortet von rastermen Mitglied (108 Punkte)
Hallo zusammen,

ich sitze hier schon mehrere Stunden an dieser Aufgabe, und jetzt hat sich wieder der Knoten gelöst.

=SUMMENPRODUKT(($A$2:$A$100000=L2)*($J$2:$J$10000=N2)*$I$2:$I$10000)

Danke an alle

Gruß

Rudolf
0 Punkte
Beantwortet von rastermen Mitglied (108 Punkte)
Hallo zusammen,

ich komme mit der Formel  nicht zurecht da sie "#WERT!" ausgibt wenn ich die Formel über die Felder ohne Datum angebe.Datum werden über eine andere Mappe übernommen.

Habe die verkleinerte Datei mit den Fragen hier nochmals eingestellt.

http://www.filedropper.com/datum2

Hoffentlich alles verständlich- sonst bitte Nachfragen.

Gruß

Rudolf
0 Punkte
Beantwortet von rastermen Mitglied (108 Punkte)
Hallo und guten Abend,

habe gerade festgestellt das die Host Adresse bei mir nicht funktioniert.

Gebe dazu eine neue an

https://filehorst.de/d/ccGcpvCh

Guten Abend und Gruß

Rudolf
0 Punkte
Beantwortet von paul1 Experte (4.9k Punkte)
Hallo Rasterman,

probier Folgendes:

in O2:

=WENN(ISTNV(SUMMENPRODUKT(($A$2:$A$10000=L2)*($J$2:$J$10000=N2)*($I$2:$I$10000)));"";SUMMENPRODUKT(($A$2:$A$10000=L2)*($J$2:$J$10000=N2)*($I$2:$I$10000)))

on Q2:

=WENN(ISTNV(SUMMENPRODUKT(($A$2:$A$10000=L2)*($J$2:$J$10000=N2)*($I$2:$I$10000)));"";SUMMENPRODUKT(($A$2:$A$10000=L2)*($J$2:$J$10000=P2)*($I$2:$I$10000)))

hoffe es richtig verstanden zu haben

Gruß Paul1
0 Punkte
Beantwortet von paul1 Experte (4.9k Punkte)
Nachtrag:

oder besser in O2:

=WENN(ISTFEHLER(SUMMENPRODUKT(($A$2:$A$10000=L2)*($J$2:$J$10000=N2)*($I$2:$I$10000)));"";SUMMENPRODUKT(($A$2:$A$10000=L2)*($J$2:$J$10000=N2)*($I$2:$I$10000)))

in Q2:

=WENN(ISTFEHLER(SUMMENPRODUKT(($A$2:$A$10000=L2)*($J$2:$J$10000=N2)*($I$2:$I$10000)));"";SUMMENPRODUKT(($A$2:$A$10000=L2)*($J$2:$J$10000=P2)*($I$2:$I$10000)))

Gruß Paul1
0 Punkte
Beantwortet von paul1 Experte (4.9k Punkte)
Korrektur in Q2:

=WENN(ISTFEHLER(SUMMENPRODUKT(($A$2:$A$10000=L2)*($J$2:$J$10000=P2)*($I$2:$I$10000)));"";SUMMENPRODUKT(($A$2:$A$10000=L2)*($J$2:$J$10000=P2)*($I$2:$I$10000)))

Gruß Paul1
+1 Punkt
Beantwortet von m-o Profi (12.6k Punkte)
Hallo Rudolf,

wieso so kompliziert mit Summenprodukt? Ab Excel 2010 kannst du das einfach mit SUMMEWENNS lösen:

Formel in Zelle O2: =SUMMEWENNS(I:I;A:A;L2;J:J;N2)

Formel in Zelle Q2: =SUMMEWENNS(I:I;A:A;L2;J:J;P2)

Gruß

M.O.
0 Punkte
Beantwortet von rastermen Mitglied (108 Punkte)

Guten Tag Paul1 und M.O.,

jetzt bin ich HAPPY - es funktioniert wie ich es mir vorgestellt habe.

Habe jetzt das Hintergrundwissen mit der Formel SUMMEWENNS erweitern können.

Danke an Euch - Paul1 und M.O.-  und alle zusammen für die Hilfe.

Gruß

Rudolf

54.4k Fragen

233k Antworten

6k Nutzer

...