58.9k Aufrufe
Gefragt in Tabellenkalkulation von
Hallo,
ich brauche für eine Abfrage Hilfe:

in "A1" steht eine Variable Zahl ,

in "B1" steht fest die Zahl 0, in "C1" die Zahl 999, in "D1" steht 30

in "B2" steht die Zahl 1000, in "C2" die Zahl 2999,in "D2" steht 45

in "B3"steht die Zahl 3000, in "C3"die Zahl 5999 , in "D3" steht 60

in " B4" steht die Zahl 6000, in " C4"die Zahl 50000, in "D4" steht

130

nun meine Frage:

Möchte eine "WENN" Abfrage (wenn möglich) die mir folgende Werte zurückgibt:
Wenn "A1" zwischen 0 bis 999 dann 30;
Wenn "A1" zwischen 1000 bis 2999 dann 45
usw.

Vieleicht oder sicher ganz einfach - aber ich komme nicht auf die Lösung !!
Ganz herzlichen Dank im Vorraus

Rudolfo

10 Antworten

0 Punkte
Beantwortet von hajo_zi Experte (9.1k Punkte)
Hallo Rudolfo

=Wenn(Und(A1>=0;A1<=999);30;Wenn(und(...))

Gruß Hajo
0 Punkte
Beantwortet von locke Experte (1.2k Punkte)
Hallo,

=WENN(A1<B2;D1;WENN(A1<B3;D2;WENN(A1<B4;D3;WENN(A1<=C4;D4;0))))

Gruß
Locke
0 Punkte
Beantwortet von locke Experte (1.2k Punkte)
Ah, nochwas, größer 50000 darf ja nur nulll bei rauskommen, oder?

Gruß
Locke
0 Punkte
Beantwortet von rainberg Profi (14.9k Punkte)
Hallo Rudolfo,

WENN ist hierbei nicht von Nöten.

=SUMMENPRODUKT((B1:B4<=A1)*(C1:C4>=A1)*D1:D4)

Gruß
Rainer
0 Punkte
Beantwortet von
Hallo Hajo,

ganz toll - die schnelle Antwort;
perfekte Lösung - alles klappt.

Danke Rudolfo

und auch an die die sich den Kopf zerbrochen haben.
0 Punkte
Beantwortet von
Hallo Rainer ,
auch deine Antwort habe ich ausprobiert ,da ich damit auch selber für mich weiterkomme.
Klasse - Danke
Rudolfo
0 Punkte
Beantwortet von
Hallo Locke,
diese Anfrage : über 50000 zu beantworten:
diese brauche ich für ein LT Transport Unternehmen- und für einen Einzelvertrag nicht zu schaffen - falls diese Summe erreicht würde kann oder könnte ich die Summe ja erhöhen.
Danke auch für Deine Hilfe
Gruß Rudolfo
0 Punkte
Beantwortet von
Hallo an Alle,

habe noch eine kleine Zusatzfrage:

Habe die Formel : Summenprodukt verwendet,

nun habe ich aber etwas vergessen:

In "A1 " soll die eingegebene Zahl z.B: 750 stehen bleiben,

aber wenn ich in der Zelle "C34" (Zusatzanfrage ) eine Zahl größer 0 eingebe sollte es mir dort wo das Ergebnis 30 steht dafür eine 0 eintragen. Allso -- WENN C34>0;""; ansonsten Formel "SUMMENPRODUKT

Verständlich ausgedrückt ???


Danke
Rudolfo
0 Punkte
Beantwortet von
Hallo,
die Zusatzfrage habe ich mehreren Versuchen doch noch selber lösen können.

Gruß
Rudolfo
0 Punkte
Beantwortet von

Hallo zusammen, 

Ich mache eine Liste zum Heizkörper dimensionieren und steh gerade etwas auf der Leitung. 

folgendes : 

5K
[Watt] [l/h] [DN]
TS1 5000 860 1/2" wenn  860 l/h  dann ist es  zwischen 0 und 223 l/h und dann müstte es  müsste es 1/2" sein.
TS2 250 43
TS3 30000 5159 ? wenn  5159 l/h dann ist es  zwischen 0 und 223 l/h und dann müstte es  müsste es 2" sein. 
TS4 123000 21152 ?
TS5 8206 1411 ?
TS6 0
TS7 0
TS8 0
TS9 0
TS10 0
TS11 0
TS12 0
TS13 0
TS14 0
TS15 0
TS16 0
TS17 0
TS18 0
TS19 0
TS20 0
166456 28625
Watt  Watt  [l/h] DN [Zoll]
0 5.180 0 223 15 1/2"
5.181 11.620 223 500 20 3/4"
11.621 21.580 500 929 25 1"
21.581 45.340 929 1952 32 5/4"
45.341 68.000 1.952 2928 40 6/4"
68.001 160.160 2.928 6890 50 2"
160.160 270.260 6.890 11638 65 76,1 x 2,9
270.261 412.620 11.638 17768 80 88,9 x 3,6
412.621 821.400 17.768 35371 100 114,3 x 3,6
821.400 1.415.600 139,7 x 4,0
1.415.601 2.189.460 168,3 x 4,5
2.189.461 3.542.880 219,1 x 5,5

...