14.4k Aufrufe
Gefragt in Linux von
Hey,
wie kann ich Ubuntu im Wiederherstellungsmodus starten? Ich muss irgendwie an die Konsole, um die hier: http://glasen-hardt.de/?page_id=701 unter >>Grub2-Konfiguration anpassen << beschriebenen Konfigurationen vorzunehmen. Habe schon von CD im live Modus gestartet, kann auch unter nano i915.modeset=1 setzen und speichern aber das anschliessende Update: funktioniert nicht, sudo update-grub, die Konsole fragt dann ob die entsprechende device ge-mounted wurde, kein Plan, steige gerade erst in Linux ein. Wie komme ich also in den Wiederherstellungsmodus? (Ich kann das System nicht vollstaendig hochfahren, weil der Bildschirm halt noch konfiguriert werden muss), es muss also schon irgendwie waehrend des Bootens machbar sein.
Danke & Gruesse

7 Antworten

0 Punkte
Beantwortet von hans889 Experte (3.7k Punkte)
Hallo wonky,

alles über den recovery-Modus findest du hier:

-> KLICK
0 Punkte
Beantwortet von
wenn du bis zum grub kommst ( ohne livecd ), dann hast du 2 einträge, einmal den normalen und den 2. ( singleuser mode )

damit kommst du in den Init -1 modus, ohne X server und kannst deine einstellungen anpassen
0 Punkte
Beantwortet von tuxfreund Mitglied (373 Punkte)
Hei,
Habe Deinen vorherigen Thread mitgelesen. Du musst die CD rausnehmen. Du sollst ja das frisch installierte System starten. Dann kommt die Grub-Auswahl. Dort findet sich auch "......Wiederherstellungsmodus". Hast aber nur paar Sekunden Zeit zum lesen, also halte schon mal den Finger über die Pfeil-nach-unten-Taste. Dann weitermachen wie in der Anleitung, die Du schon hast. ...Root shell öffnen...
0 Punkte
Beantwortet von
Vielen Dank, f"ur eure Antworten, hat jetzt funktioniert .Nur leider l"ost das mein Graphikproblem nicht, nach dem Hochfahren wird erst der Desktop angezeigt, dann kommt periodisch schwarzer Bildschirm und schliesslich eine Meldung, dass Ubuntu mit minimaler Grafikunterstuezung l"auft oder so, da kann man dann neu konfigurieren, auf die Kommandozeile, Problem beheben usw. Irgendwie scheint das also nicht auszureichen. Wollte daher jetzt die zweite hier http://glasen-hardt.de/?page_id=701 angebotene Methode probieren
Man muss dazu nur die Datei “/etc/X11/xorg.conf” anlegen bzw. editieren und folgende Zeilen einfügen :

Section "Monitor"
Identifier "VGA"
Option "Ignore" "true"
EndSection


Das Problem ist nur: Ich kann mich zwar "uber die root shell anmelden und nach etc/X11/ wechseln, wenn ich dann aber versuche mit "touch xorg.conf" versuche die Datei zu erstellen, kommt: "permission denied". Wie kann ich die Datei mit dem entsprechenden Inhalt den erstellen? Sorry, sind bestimmt bl"ode Fragen, aber ich fange, wie gesagt gerade erst mit Linux an.
Danke f"ur eure Hilfe
0 Punkte
Beantwortet von andreas1956 Experte (2.8k Punkte)
Hallo,

vielleicht mit sudo touch xorg.conf.
0 Punkte
Beantwortet von
Danke hat funktioniert, auch wenn mein Graphikproblem damit leider noch nicht behoben ist, klappt das nicht.
0 Punkte
Beantwortet von
aus erfahrung kann ich dir (leider) sagen, wenn ubuntu deine grafikkarte/monitor kombination nicht richtig konfiguriert, dann hast du als anfänger fast keine chance das hinzubiegen. selbst profis kommen ins schleudern, seit der xorg unterbau das alles automatisch machen (will)

mit einem ignore true ist es auf jeden fall nicht getan. du müsstest die kompletten monitor daten festlegen und eintragen ( zB mit xrandr )

hier ein beispiel

forum.ubuntuusers.de/topic/ubuntu-9-10-keine-xorg-conf-mehr-1680-x-1050-/
...