15.2k Aufrufe
Gefragt in Textverarbeitung von jorja Mitglied (377 Punkte)
Guten Morgen!

Habe W7 und eben Office 2010 in Verwendung genommen.

Ich möchte Word Dateien öffnen, aber es wird ein falsches Programm dazu verwendet (ECM make cert).
Jede Datei, die ich damit aufmachen will, wird plötzlich auf 1 KB reduziert und ist sozusagen nicht mehr vorhanden!
Wenn ich "öffnen mit" verwende, um ein anderes Programm zum Öffnen auszuwählen, wird mir Word nicht angeboten.
Beim Durchsuchen der vorzuschlagenden Programme scheint word nicht auf.

Ich kann kein einziges DOC oder DAT.. öffnen!
Beim neu Erstellen von Word DAteien heißen die .DOCX.

Was ist da los und wie kann ich meine Dateien wieder herstellen und öffnen?


Danke für Eure Hilfe!

J

8 Antworten

0 Punkte
Beantwortet von kjg17 Profi (34.4k Punkte)
Moin Jorja,

.docx ist das Standardformat seit Word 2007 so wie die .doc der früheren Versionen, also in dem Punkt nicht weiter aufregen.

Zunächst würde ich mal unter Systemsteuerung / Programme / Programm deinstallieren den Eintrag für Office 2010 markieren und dann oberhalb der Auswahlliste auf 'Ändern' klicken. Damit startest du das Office-Setup unter welchem du dann die Option 'Reparieren' auswählst und auf 'Weiter' klickst. Normalerweise sollte diese Funktion die falsche Zuordnung der Dateitypen erkennen und korrigieren.

Versuche erst einmal das und berichte dann.

Gruß
Kalle
0 Punkte
Beantwortet von simser Experte (3.7k Punkte)
1. Standardprogramm festlegen:

rechte Maustaste auf docx-Datei > Öffnen mit ... > Standardprogramm wählen > Haken setzen


2. doc-Dateien anlegen

Wozu möchtest du noch doc-Dateien anlegen?
Der Dateityp "doc" ist ein veralteter Word-Standard.
Der neue Standard "docx" ist spätestens seit OpenOffice 3.2 von jedem problemlos les- und bearbeitbar.
0 Punkte
Beantwortet von kjg17 Profi (34.4k Punkte)
Moin Simser,

zu 1.: Hier hatte Jorja geschrieben dass es ihr auf diesem Weg nicht gelungen ist, vermutlich aber nur, weil sie die Option 'Durchsuchen' nicht verwendet hat um sich zur Winword.exe durchzuhangeln. Nach dem erstmaligem Öffnen einer *.doc aus Word heraus müsste allerdings auch Word bei 'Öffnen mit' als auswählbares Standard-Programm angezeigt werden. Da aber u.U. auch noch weitere Word-Dateitypen von dem Problem betroffen sein könnten, habe ich zunächst den Versuch über die Reparatur vorgeschlagen.

zu 2. Für den einen oder anderen User ist es ggf. einfach nur praktischer weiter mit dem .doc-Format zu arbeiten, wenn diese Dateien auch mit älteren Office-Versionen ausgetauscht werden und dort auch bearbeitet werden sollen. Insofern kann ich deiner Aussage nicht uneingeschränkt zustimmen, das kommt einfach auf die konkrete Situation an.

Gruß
Kalle
0 Punkte
Beantwortet von simser Experte (3.7k Punkte)
Richtig, Kalle.

Zu Punkt 1 war ich auch noch etwas unkonzentriert, da noch ohne Kaffeegenuss. Diesbezüglich habe ich mittlerweile für Abhilfe gesorgt.

Zu Punkt 2 war ich der Hoffnung und bin es weiterhin, der Dame etwas Zukunftsorientierung zu vermitteln, was man - zugegeben - allerdings hätte diplomatischer leisten können.

Ältere Word-Versionen kann man mit dem Compatibility Pack docx-fähig machen.
0 Punkte
Beantwortet von jorja Mitglied (377 Punkte)
Guten Morgen!

Vielen Dank für Eure Hinweise!

Also wegen der Dateiformate, die habe nicht ich erstellt, sondern die sind so schon im XP vorher "geworden" und ich habe sie jetzt nur weiter übernommen.
Zum Beispiel: im konkreten Fall handelt es sich um ein Word-Dokument, das eine Corel-Grafik im Briefkopf hat, zusätzlich weitere Grafiken und eine eingefügte Excel-Tabelle und ist als Kuvert-mit-Brief - Garnitur mit einer Adressen-Quelle verknüpft.

Diese Datei hat XP (oder wer auch immer) in eine DAT Datei umgewandelt, die immer gut funktioniert hat.
Jetzt habe ich wie gesagt das Office 2010 installiert, und nichts funktioniert mehr.

Ich kann gerade noch neue Word-Dateien erstellen, aber keine bestehenden mehr ausführen.
Mein Versuch, mit einer anderen Anwendung (in einem Ordner namens Office 14) zu öffnen, hat das Fiasko jetzt hervorgerufen.

Das Problem ist offensichtlich, daß das Programm "Word" als solches nicht in der Liste "öffnen mit" zu finden ist, und ich bei "Durchsuchen" nicht den richtigen Ordner im Office 2010 finde, wo sich das benötigte Programm befindet.

@Simser wegen Diplomatie: kein Problem, vermutlich sind Fragen wie meine sowas wie "Radlfahren" für Euereins ;-) .
Hoffe, der Kaffee hat gut geschmeckt!

@ Kalle:
Servus!
Die Reparatur und ein neues "Setup" haben leider nichts verändert.
Ich habe unter Word 5 oder 6 verschiedene Formate.
Nur mit Office 2010 neu erstellte Dateien tragen die Endung docx und weisen das Word-Symbol vorne auf.


Wie finde ich jetzt erstmal die richtige Anwendung?


Gruß, J
0 Punkte
Beantwortet von kjg17 Profi (34.4k Punkte)
Hallo Jorja,

im Ordner Office14 warst du von der Sache her schon richtig, so nennt sich der für Office 2010, aber es ist die Frage, ob du auch im richtigen Programmverzeichnis warst. In einem 64-bit Win7 liegt ein 32-bit Office 2010 im Ordner "Programme (x86)" und dort findest du dann auch unter Microsoft Office / Office14 die Winword.exe zum Verknüpfen mit der .doc über den Öffnen-mit-Dialog.

Gruß
Kalle
0 Punkte
Beantwortet von jorja Mitglied (377 Punkte)
Schönen Abend Kalle!

Habe die EXE Datei gefunden.
Jeder Versuch, sie über den Dialog zu verknüpfen, ist fehlgeschlagen,
das Fenster schließt sich einfach, nachdem ich die Datei im Ordner markiert habe und auf "öffnen" klicke.
Die "Öffnen-mit" Funktion scheint sich regelrecht zu weigern.

Jetzt habe ich von der CD her schon mehrere Reparaturen und setups durchgeführt, aber die Datei läßt sich einfach nicht verwenden.

Hast Du noch / hat noch wer Ideen zu dem Problem?


Danke Dir jedenfalls wieder für Deine Mühe!

Gruß, J
0 Punkte
Beantwortet von kjg17 Profi (34.4k Punkte)
Hallo Jorja,

das ist aber ein recht merkwürdiges Verhalten, womit hast du dein Win 7 nur so verärgert?

Einen Vorschlag hab ich noch, die Änderung direkt in der Registry vorzunehmen.

Suche in der Registry unter HKEY_CLASSES_ROOT den Eintrag ".doc", markiere ihn mit der Maus, rufe über Rechtsklick das Kontextmenü auf und klicke dort auf "Exportieren". Als Speicherort kannst du den Desktop wählen und die Datei z.B. Doc-alt nennen, sie taucht dann als "Doc-alt.reg" auf deinem Desktop auf und ist eine Sicherheitskopie des momentanen Registry-Eintrags.

Öffne den "Editor" (unter Programme / Zubehör) und kopiere dort folgendes hinein:
Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\.doc]
@="Word.Document.8"
"Content Type"="application/msword"
[HKEY_CLASSES_ROOT\.doc\PersistentHandler]
@="{98DE59A0-D175-11CD-A7BD-00006B827D94}"
[HKEY_CLASSES_ROOT\.doc\ShellEx]
[HKEY_CLASSES_ROOT\.doc\ShellEx\{8895b1c6-b41f-4c1c-a562-0d564250836f}]
@="{84F66100-FF7C-4fb4-B0C0-02CD7FB668FE}"
[HKEY_CLASSES_ROOT\.doc\Word.Document.8]
[HKEY_CLASSES_ROOT\.doc\Word.Document.8\ShellNew]

Anschließend speicherst du diese Datei z.B. als "Doc-neu.reg" auf dem Desktop ab. Führe dann einen Doppelklick auf diese Datei aus und bestätige die Rückfragen zur Durchführung der Änderungen an der Registry. Ob sich diese Änderung sofort auswirkt oder erst nach einem Neustart des Rechners weiß ich jetzt nicht, aber ein Erfolg sollte dann schon am Word-Icon der diversen *.doc zu sehen sein und ein Doppelklick sollte auch MS Word starten.

Wenn alles geklappt hat kannst du die beiden Reg-Dateien vom Desktop löschen. Sollte sich wider Erwarten nichts geändert haben liegen die Probleme ggf. an anderer Stelle. Den alten Registry-Eintrag könntest du bei Bedarf per Doppelklick auf die Sicherung "Doc-alt.reg" wiederherstellen lassen.

Gruß
Kalle
...