7.5k Aufrufe
Gefragt in WindowsXP von nostalgiker6 Experte (7.1k Punkte)
Guten Tag,

wieder einmal ein Problem, das mich verblüfft:
Ich habe mir eine 32GB-SD-Karte zugelegt, um MP3s (gut 20GB) für mein Archos-8-HT bereitzustellen, der - an den Receiver angeschlossen - als Player dienen soll.

1. Zunächst also die vorbereiteten Ordner auf die Karte kopiert - das dauert eine Weile.
2. Im Archos (nach Umstecken der Karte natürlich) die gesamte Ordnerstruktur, aber nur wenige Dateien gefunden: Die Ursache beim A. vermutet. Auch bei Betrachtung am PC (Card-Reader) fehlen die Dateien - der Speicherplatz war aber (wenn ich mich recht erinnere) noch belegt!
3. Karte neu formatiert (FAT32, ohne Fehlermeldung). Wieder Ordner auf die Karte kopiert - aber in kleineren 'Portionen', nicht alle in einem Rutsch, und nur bis gut 4GB drauf waren. Irgendwann überprüft, on noch alle kopierten Dateien da sind.
4. Karte sicher entfernt und wieder eingesteckt
5. Einige der zuletzt aufgespielten Dateien waren verschwunden. (Der Speicherplatz scheit aber freigegeben zu sein.)

Leider habe ich mein Vorgehen nicht protokolliert - ich kann nur versuchen, den Ablauf so gut wie möglich (etwas gestrafft) aus der Erinnerung wiederzugeben.

Die Ordner sind meist zweistufig gegliedert: I:\PERIODE \Komponist\.
Gelegentlich gibt einen weiteren Unterordner (z.B. \Symphonien\). Die Dateienamen sind ziemlich lang (bis zu etwa 100 Zeichen, mit Pfad vielleicht 150 oder etwas mehr).
In dieser Ecke vermute ich das Problem - aber In längerer Netz-Recherche konnte ich weder hinsichtlich der Namenslänge (noch der Datei-Anzahl) für FAT32 eine relevante Begrenzung finden.

Weiss jemand Rat? (BS ist XP-Pro, PC ist Eigenbau mit 2GB RAM, P5 3GHz)

31 Antworten

0 Punkte
Beantwortet von andreas1956 Experte (2.8k Punkte)
Hallo,
eventuell erst auf der Karte per Hand die Ordner anlegen und dann nur noch die Titel von PC- auf Karte kopieren. Ich hatte ein ähnliches Problem mit einer externen Festplatte.
0 Punkte
Beantwortet von
hallo, kannst du denn wirklich den schwund speichermäßig feststellen?
gehe mal mit dem testdisk drüber.
die sind lustig beim archos, ich wollte mal nach dem handbuch bei den suchen, fand ich nur was zum 9, also nicht was du hast 8.
falls du das handbuch hast, schaue wie man da die zeichenzahl in der dateibezeichnung behandelt nach.
hast du eine andere sdcard, probiere damit.
also die ordnerstrukur aufbauen und was abspeichern.
beispielsweise auf dem archos-8 und nachher am pc schauen und umgekehrt.

mfg
0 Punkte
Beantwortet von nostalgiker6 Experte (7.1k Punkte)
Hallo und Dank für die Antworten.

Vorab zu #2: Das Problem liegt offensichtlic NICHT am Archos (das war nur die erste Zuschreibung - das Phänomen tritt am PC auf, nur dass ich das anfänglich nicht bemerkte - ich sah keinen Grund, die eben beschriebene Karte am PC nochmal durchzusehen).

Der "Schwund" scheint 'speichermässig' doch NICHT erkennbar zu sein:
Ich habe Andreas' Anregung aufgegriffen und zunächst die leeren Ordner angelegt (nicht manuell, sondern mit xcopy ... /s /t - aber das sollte doch keinen Unterschied machen).

Dann mit Hilfe von Beyond Compare Dateien kopiert. (Das geht damit noch etwas komfortabler als der Free Commander, weil auf Click immer Von- und Nach-Ordner zugleich aufgeklappt werden). Das habe ich eine ganze Weile getrieben und dabei immer beobachtet, wie auf der Karte der Belegte Speicher zu- und der freie abnahm. Derzeit sind gut 10GB belegt. Aber als ich nun doch mal nachgesehen habe - da waren die zuerst kopierten Dateien schon wieder verschwunden!!! Die 10GB sind auch nach sicherm Entfernen und Wiedereinstekcne der Karte noch belegt - nur dass jetzt auch die vorher noch vorhandenen Unterordner des von mir bearbeiteten "Hauptordners" verschwunden sind.
0 Punkte
Beantwortet von halfstone Profi (17.8k Punkte)
Hi nostalgiker6,

kann es sein, dass dein Kartenleser nicht mit so großen Karten umgehen kann?

Passiert das mit kleineren Karten auch?

Gruß Fabian
0 Punkte
Beantwortet von nostalgiker6 Experte (7.1k Punkte)
Nein - mit kleinen Karten passiert das nicht.
Ich meine aber, wenn es am Leser läge, dann dürfte er doch auch die Grösse der Karte nicht korrekt anzeigen. Zudem finde ich HIER den Hinweis, dass Karten bis 32GB unterstütz werden.
0 Punkte
Beantwortet von power-poler Experte (3.7k Punkte)
Mach doch Partitionen drauf.
Versuch doch mal eine 5GB Partition, eine 10, eine Rest.
Kopier mal deine Dateien, ob sie erhalten bleiben. Erst auf die Kleine, dan auf die Größeren.
0 Punkte
Beantwortet von nostalgiker6 Experte (7.1k Punkte)
Danke für die Idee.
Ich hatte zwar von Anfang an Zweifel, dass der Archos die Partitions erkennt, aber ich habs (mit einer 2-GB-Karte) probiert: Schon der AESEUS-PM weist allerdings darauf hin, dass WIN nur die erste P. erkennt. Recht hat er! Und beim Archos ist es ebenso.
0 Punkte
Beantwortet von nostalgiker6 Experte (7.1k Punkte)
Allerdings sehe ich eben (beim zurücksetzen der Karte auf 1 Partition), dass ich mit dem APM auch foprmatieren und dabei Clustergrösse festlegen kann.
Ich habe leider keine Ahnung von den inneren Zusammenhängen - aber vielleicht weiss jemand von euch, ob eine andere (welche?) Clustergrösse mir weiterhelfen könnte.
(Meine Vermutung geht ja dahin [siehe #1], dass Teile der FAT einfach immer wieder überschrieben werden (... oder so ähnlich - ich habe eben keine Ahnung).
0 Punkte
Beantwortet von nostalgiker6 Experte (7.1k Punkte)
Guten Abend! Inzwischen ist einiges passiert:

Ein Bekannter gab mir den Tipp, es könne an XP liegen. Habe es also bei einem Freund unter VISTA probiert:

1. Die Karte neu formatiert. Zwei Hoffnungsschimmer:
2. Wurden mir verschiedene Clustergrössen angeboten, nicht nur "Standard" - ich wählte (wie vorgeschlagen) 16KB
3. Dauerte das Formatieren nicht wie unter XP 20 oder 30 Sekunden, sondern länger als eine Stunde. (Schnellformatierung war unter XP definitiv NICHT angekreuzt)
4. Kopieren gestartet: Nach etwa. 2,5 Stunden ca. 22 GB belegt (das wäre alles) - aber wieder von den meisten Ordnern nur die leeren 'Hüllen' drauf!
5. Nach Bereinigung mit AESEUS-PM (der auch CheckDisk aufruft) sind die leeren Ordner verschwunden, und es sind nur noch knapp 2GB belegt.

Ich bin also leider so klug als wie zuvor! Wenn nicht noch auf Wunderbare Weise ein helfender Tipp kommt, dann maile ich dem Verkäufer morgen, dass ich die Karte zurück geben will.
0 Punkte
Beantwortet von nostalgiker6 Experte (7.1k Punkte)
Neuer - letzter - Versuch mit einem anderen Kartenleser (aber wieder unter XP - ohne Neuformatierung).

Noch einmal zahlreiche Ordner (hauptsächlich einer mit - incl. Unterordnern - 14GB) kopiert. Dauer ca. 2 Stunden. Wieder scheint einiges mehr drauf zu sein. Ca. 17GB belegt. Aber auch viele leere Ordner. Sicheres Entfernen oder Bereinigen mit AESEUS nicht möglich ("wird ... benutzt"). Einige Prozesse gekillt - dann AESEUS-Bereinigung. Danach leere Ordner wieder verschwunden, nur noch knapp 2GB belegt.

S C H E I S S E ! ! !
...