1.5k Aufrufe
Gefragt in WindowsXP von micky01 Mitglied (156 Punkte)
hallo,
ich will unter xp eine software installieren. bei der installtion von n .net 3.0 wird eine betaversion idendifiziert und die installtion abgebrochen.
.net 3.0 ist insgesamt lt. Softwaranzeige nicht mehr vorhanden.
muss oder kann ich alle anderen versionen löschen. wie wäre da vorzugehen?

danke vorab!

7 Antworten

0 Punkte
Beantwortet von georg Experte (1.8k Punkte)
Suche dir im Netzt Net. Framework 4 und installiere dieses auf dein XP System.

In Zukunft wirst du mit Programminstallationen die Framework brauchen keine Schwierigkeiten mehr haben.

Die alten Versionen kannst du behalten.

Ein deinstallieren ist nicht norwendig...schadet aber auch nicht.


Hinweis!

Auf Windoes XP kann man nur bis zur Version Framework4 installieren.

Version 4.5 installiert sich und funktioniert erst ab Windows 7.
0 Punkte
Beantwortet von micky01 Mitglied (156 Punkte)
hallo georg,

ich die info: .net 4.0 ist installiert und 2.o. und 3.5. nach entfernen von 3.0 sind div. funtkionen von excel nicht mehr in der menüleiste.
wie gehe ich jetzt weiter vor?

danke!
0 Punkte
Beantwortet von
@Georg:
Ein deinstallieren ist nicht norwendig...schadet aber auch nicht.


Falsch. Höhere Versionen beinhalten nicht automatisch die niedrigeren Versionen. Und Programme benötigen immer eine bestimmte Laufzeitumgebung, d.h. eine bestimmte Version - wie man an Excel sieht.

@micky: Lade Dir net framework 3.0 herunter und installiere es wieder; mach einen Neustart und schau, ob Excel wieder alle Funktionen hat. Wenn nein, Excel auch nochmal installieren.

stepbystep
0 Punkte
Beantwortet von micky01 Mitglied (156 Punkte)
jallo georg,

.net 3.0 geht nicht zu installieren; Hinweis: es sind neuere Versionen(z.B. 3.5 oder 4.0) vorhanden. kann ich 3.0 nicht zwingend neu installieren? was handel ich mir ein, wenn ich alle lösche und mit 1.0 beginne?
0 Punkte
Beantwortet von
jallo georg,
?

Die 4.0 kannst Du auf jeden Fall deinstallieren. Bei der 3.5 musst Du schauen: Kann sein, dass dann irgendein Programm, das die Umgebung braucht, nicht mehr funktioniert.

Ich würde beide deinstallieren, dann einen Neustart machen und danach die 3.0 und die 3.5 (in der Reihenfolge) wieder installieren.

stepbystep
0 Punkte
Beantwortet von
Hi,
wie du in Antwort 4 selbst festgestellt hast, lassen sich Vorgänger-Version nicht mehr installieren, wenn ein höhere Version installiert ist. Daher alle entfernen und der reihenach neu installieren. Zum Löschen solltest du das NET Clean Tool verwenden, um auch die Registrie von den letzten Resten zu reinigen. Sonst gibt es evtl. wieder Probleme beim Installieren.
0 Punkte
Beantwortet von micky01 Mitglied (156 Punkte)
hallo,
ich habe mit dem Programm revouninstall Framework 3.0 bis 4.0 gelöscht; die anderen empfohlenen Programme bekamen einen Error beim Ausführen.
Revo zeigt jetzt nur noch Framework 2.0 an. Es sind allerdings weiterhin alle Framework-Ordner von 3.0 bis 3.0 vorhanden. Ebenso alle Angaben in der Registry zu .NET Framework 3.0 bis 4.0 und auch von .NET Framework Setup.
Die Installation von Framwork3.0 läuft weiterhin auf Fehler.
kann ich evtl. alle Ordner und Registry Einträge von 3.0 bis 4.0 von Hand löschen oder handele ich mir dann neue Probleme ein?
...