981 Aufrufe
Gefragt in Tabellenkalkulation von
Hallo zusammen.

Ich bräuchte mal wieder eine Excelformel für folgendes Problem.

Ich habe diverse Maschine mit unterschiedlichsten Laufzeiten...
Die Produktivität unter Berücksichtung der tatsächlich investieren Zeit ist natürlich bei jeder Maschine unterschiedlich...

Folgende Einzelergebnisse habe ich für die komplette Abteilung:

Maschine 1: 59 % Produktivität geht zu 3,9% in den Gesamt-Mittelwert ein.
Maschine 2: 59% - zu 1,4 %
Maschine 5: 75 % - zu 8,6 %
Maschine 7: 70% - zu 13,1%
Maschine 8: 59% - zu 6,9%
Maschine 12: 65% zu 9,4%
Maschine 13: 47% zu 6,3%
Maschine 14: 66% zu 8%
Maschine 18: 65% zu 3%
Maschine 19: 69% zu 4,4%
Maschine 20: 73% zu 3,2%
Maschine 21: 55% zu 4,4%
Maschine 22: 57% zu 3,6 %
Maschine L1: 62% zu 5,5%
Maschine L2: 74% zu 8,8 %
Maschine L3: 69% zu 1,5 %
Maschine L4: 67% zu 8 %

Die zweite Prozentzahl aufsummiert ergibt 100% für die ganze Abteilung.
Nun bräuchte ich den gewichteten Mittelwert entsprechend der u. a. Gewichtungen.... ich steht da irgendwie auf dem Schlauch.

Danke vorab.
Holger

2 Antworten

0 Punkte
Beantwortet von saarbauer Profi (15.6k Punkte)
Hallo,

was du genau haben willst, hoffe ich verstanden zu haben.

Du musst die ersten Prozente mit den Zweiten Multiplizieren und aus dem Ergebnis den Mittelwert errechnen

Folgende Lösungen

{=MITTELWERT((G10:G26)*(H10:H26))}

oder mit Hilfsspalte I (in I10 = G10 * H10)

=MITTELWERT(I10:I26)

Die Spalzen und Zeilenangaben sind anzupassen
Die geschweifte Klammer wird nach der Formeleingabe mit STRG + Unschalt + Enter erzeugt

Deine oben genannten Zahlen ergeben einen Mittelwert von 3,84%

Gruß

Helmut
0 Punkte
Beantwortet von kjg17 Profi (34.4k Punkte)
Hallo Holger,

im gewichteten Mittel beträgt die Produktivität der Maschinen dieser Abteilung 65,28% und wäre wie folgt zu errechnen, wenn beispielsweise die Produktivität der Maschinen im Bereich B2:B18 und deren Anteil an der Gesamtleistung der Abteilung im Bereich C2:C19 eingetragen ist:

=SUMMENPRODUKT(B2:B18;C2:C18)/100%

Ein vorherige Ermittelung der prozentualen Anteile der Maschinen an der Gesamtleistung der Abteilung ist eigentlich nicht erforderlich. Du kannst auch die der Berechnung dieser Anteile zugrunde liegenden Angaben, z.B. Stückzahlen oder Wertabgaben, direkt in Spalte C eintragen, die Formel müsste in dem Fall dann so lauten:

=SUMMENPRODUKT(B2:B18;C2:C18)/SUMME(C2:C18)

Gruß
Kalle
...