2.2k Aufrufe
Gefragt in Windows98 von baumnymphe Einsteiger_in (7 Punkte)
Liebe Forenmitglieder,

seit ich meine Radeon 9700 Pro (Catalyst 6.2: mit dem konnte ich unter Win98SE bei NWN sogar die Option "shiny water" problemlos aktivieren, allerdings nicht unter WinXP) wg. Bildfehlern gegen eine Geforce 6800 Ultra getauscht habe, macht Windows 98SE nach der vollständigen Neuinstallation in 10 % der Fälle beim Herunterfahren/Neustarten Probleme, sobald die Treiber meiner Audigy 2 ZS PP von der Original-CD installiert sind. Diese Probleme äußern sich darin, daß
- ein Neustart zu früh erfolgt und die 2 Sek-Pause (oder bei mir 4 Sek) des IDE-HDD-Cache-Updates ignoriert wird
- gelegentlich der Rechner selbst dann einen Neustart macht, wenn ich vorher Herunterfahren ausgewählt habe
- ein Teil der Creative-Software, die beim Systemstart geladen wird, direkt nach dem Booten nicht mehr reagiert.
Im Anschluß an ein fehlerhaftes Herunterfahren/Neustarten läuft immer ein Scandisk über die Platte, der manchmal folgende Fehler findet:

Verzeichnisstruktur
Verzeichniseintrag C:\WINDOWS\SYSTEM\BMXSTA~1.RFX hatte eine falsche Größe.
ScanDisk hat den Verzeichniseintrag korrigiert.

Verzeichniseintrag C:\WINDOWS\SYSTEM\BMXSTA~2.RFX hatte eine falsche Größe.
ScanDisk hat den Verzeichniseintrag korrigiert.

Verzeichniseintrag C:\WINDOWS\SYSTEM\BMXCTR~1.RFX hatte eine falsche Größe.
ScanDisk hat den Verzeichniseintrag korrigiert.

Verzeichniseintrag C:\WINDOWS\SYSTEM\BMXBKP~1.RFX hatte eine falsche Größe.
ScanDisk hat den Verzeichniseintrag korrigiert.

Dateizuordnungstabelle

Verzeichniseintrag C:\WINDOWS\SYSTEM\BMXSTA~2.RFX enthielt eine ungültige FAT-Kette.
ScanDisk hat die FAT-Kette zur Korrektur abgeschnitten.

Verzeichniseintrag C:\WINDOWS\SYSTEM\BMXCTR~1.RFX enthielt eine ungültige FAT-Kette.
ScanDisk hat die FAT-Kette zur Korrektur abgeschnitten.

Verzeichniseintrag C:\WINDOWS\SYSTEM\BMXBKP~1.RFX enthielt eine ungültige FAT-Kette.
ScanDisk hat die FAT-Kette zur Korrektur abgeschnitten.

Dateisystem

22 verlorene Zuordnungseinheiten wurden in 3 Ketten gefunden.
ScanDisk hat die verlorenen Zuordnungseinheiten als freien
Speicherplatz zurückgewonnen.

Danach ist die Lautsprecherkonfiguration von 7.1/6.1 auf 2.1 zurückgesetzt und die Lautstärkeregler sind mal mehr und mal weniger stark verstellt. Die einschlägigen Ratgeber von MS und anderen Seiten zur Problemlösung habe ich schon erfolglos durchgetestet:

Registry:
- DVP, NAVEX, VWAVSYN in Registry löschen
- FastReboot=0 (schnelles Herunterfahren ist per MS-Patch deaktiviert worden)
- PowerDownAfterShutdown=0 oder 1
- ACPIOption=1

Systemeinstellungen:
- Beenden-Sound hinzugefügt/entfernt
- in Energieverwaltung alles deaktiviert
- Temp-Ordner leeren
- System.ini: wave=speaker.drv existiert bei mir nicht
- DOS-Speicherwerte in config.sys modifiziert
- Computer erlauben USB-Gerät auszuschalten, um Energie zu sparen
- Festplattencache in den Leistungsmerkmalen deaktiviert
- Auslagerungsdatei verschieben
- alle Autoruns (Registry, Startmenü, msconfig) deaktiviert
- IRQ-Steuerung deaktiviert

BIOS:
- AC97-Modem/-Audio=DISABLED (Jumper auf Mainboard=DISABLED)
- Keyboard/Mouse Function Power up=DISABLED
- Plug&Play OS=YES/NO
- CPU Latency Timer=ENABLED/DISABLED
- Command per Cycle=ENABLED/DISABLED

Die Updates von Microsoft lösen das Problem mit dem Herunterfahren nur solange zuverläßig, bis die Soundkarte installiert wird. Das Deaktivieren der Soundkarte im Gerätemanager scheint das Problem zu lösen, kann aber nicht Sinn des Krachmachers sein.

Weiß jemand noch einen Rat?
Vielen Dank schon mal für Eure Aufmerksamkeit.

Hier nun die Hard- und Software (Reihenfolge entspricht dem Vorgehen bei der Installation):
Windows 98SE mit
- Q273017 IDE HDD Cache Update (auf 4 Sekunden gestellt)
- Q239887 Shutdown Supplement
- Zip-Unterstützung aus Plus98!
- TweakUI
- Q329414 Security Update MDAC 2.1
- Q245729 File Access URL Update
- Q238453 IGMP Paket Update
- Q259728 DOS-Gerätenamen Update
- Q242978 1394 Storage Supplement
- Q259728 IP-Fragmente Update
- Q260344 FDISK
- Internet Explorer 5.01 SP2 (IE6 läuft nicht gut und hilft auch nicht weiter)
- Q293818 Update April 2001
- Q308567 Media Player 6.4 Update
- Q313829 Sicherheitsupdate 7. März 2002
- Q314147 SNMP Service Update
- Q320920 Media Player 6.4 Update
- Q323255 HTML Hilfe Update
- Q329048 File Decompression Function
- Q816093 Microsoft Virtual Machine VM3810_Ver1
- Q823559 Sicherheitsupdate
- KB891781 Sicherheitsupdate
- KB891711 Sicherheitsupdate
- KB917344 JScript 5.6 Sicherheitsupdate
- roots update
- DirectX 9c August 2006
- KB904706 Sicherheitsupdate Dx9c
- Q274370 durch Intel Application Accelerator (s. unten)
- Q318307 durch MS IntelliPoint 4.12 (s. unten)
- Q269601 durch Audigy 2 ZS Treiber (s. unten)
Bis hierher entspricht die Liste weitestgehend dem, was ein Internetupdate im Jahr 2008 noch auf dem System mit der Radeonkarte installiert hat, jedenfalls soweit wie ich es mir aus den 3 Verlaufslisten zusammenreimen konnte.

Nun die Hardware mit den Treibern, die nach den Updates installiert wurden:
- Mainboard: Asus Tusl2-C Rev. 1.04, BIOS 1014.001 BETA (letztes), Intel Inf-Utility 6.3 und Application Accelerator 2.3.0.2160
- Prozessor: Intel PIII-S 1400 MHz mit 512kB Cache, nicht übertaktet
- RAM: 2x256 MB von Crucial
- HDD-Primary Master: Maxtor 6 Y080L0 (80GB)
- HDD-Primary Slave: Maxtor 4 R060J0 (60 GB)
- DVD-Secondary Master: Aopen 1648/AAP, Firmware 1.05
- Brenner-Secondary Slave: TSST SH-S182M, Firmware SB06
- Netzwerk (PCI4): 3Com 3CSOHO100-TX, Treiber von Originaldiskette
- Grafik (AGP): Aopen Aeolus Geforce 6800 Ultra, Treiber 81.85 (vorletzter, da Version 81.98 Probleme mit Everest macht)
- 3D-Beschleuniger (PCI2+3): 2x Monster 3DII Voodoo2 (12MB) SLI, Treiber 3dfx Dx7 3.03.00 Beta 1.0 (alle anderen machten Probleme bei Tomb Raider V oder Need For Speed III)
- PS/2-Tastatur-Software: IntelliType Pro 2.22
- PS/2-Maus-Software: IntelliPoint 4.12
- USB-Lenkrad-Software: SideWinder 4
- USB-Joystick-Software: SideWinder 3.02
- Parallel-Port Scanner: Umax Astra 1220P 3.55
- Parallel-Port Drucker: HP Deskjet 695C 11.0.1
- Sound (PCI6): Audigy 2 ZS Platinum Pro, Triber von Original-CD + Update 031031 + THX-Konsole 1.00.16 + EAX-Konsole 2.02.05 + Update 1.84.50

Folgende MS-Updates habe ich dann in den letzten Wochen noch zusätzlich erfolglos getestet:

- Q239696 scsiport.pdr 4.10.2223 und ios.vxd 4.10.2225
- Q290831 scsiport.pdr 4.10.2224
- Q253711 ACPI Computer May Not Shut Down Properly If Device Cancels Standby
- Q253697 USB Enumeration Problems with OpenHCI Controller on Fast Computers
- Q249146 Sounds auf Computern zeitweise nicht möglich, auf denen Windows 98 Second Edition ausgeführt wird
- Q241084 Suspend-to-Disk Fix für Notebooks

Und noch ein paar Konfigurationswerte:
[DMA]
2 Standard-Diskettenlaufwerk-Controller
3 ECP-Druckeranschluss (LPT1)
4 DMA-Controller
0 (frei)
1 (frei)
5 (frei)
6 (frei)
7 (frei)

[IRQs]
0 Systemzeitgeb

3 Antworten

0 Punkte
Beantwortet von juergen54 Experte (2.7k Punkte)
Hallo,

Denke mal, das der Übeltäter die Festplatte selbst ist,
Kannst die ja mal austauschen und das System neu installieren.
0 Punkte
Beantwortet von baumnymphe Einsteiger_in (7 Punkte)
Hallo Juergen54,

vielen Dank für die Rückmeldung.

Ich glaube nicht, daß es die Festplatte ist. Laut den SMART-Attributen hat keine der beiden Platten defekte Sektoren oder andere Auffälligkeiten.
Zudem habe ich auf der ersten Festplatte 2 Windows 98SE-Installationen in getrennten und voreinander versteckten primären Partitionen. Eine Installation läuft mit dem vxd-Treiber und eine andere mit dem wdm-Treiber der Soundkarte (wegen unterschiedlicher Anforderungen der alten Spiele). Beide zeigen die Probleme beim Herunterfahren, sobald der Soundkartentreiber installiert wird, wobei der wdm-Treiber gefühlsmäßig etwas weniger anfällig zu sein scheint. Eine genaue Statistik habe ich darüber aber noch nicht angelegt.
Die Probleme traten auch schon auf, bevor das zweite System auf der Platte war, so daß ich eine Kreuzreaktion ausschließe. Wie gesagt, beide sind völlig unabhängig voneinander.

Aber Dein Vorschlag die Platte auszutauschen hat mich auf eine andere Idee gebracht: Vielleicht ist ja das Netzteil (BeQuiet BQT P4-350W-S1.3 v2) nach dem Tausch der Grafikkarte zu schwach und hat beim Einschalten bzw. Ausschalten manchmal mit Stromengpässen/-schwankungen zu kämpfen.

Das könnte auch erklären, warum bei einem Neustart von Windows XP (habe ich gestern mal testweise installiert) eine der beiden Festplatten manchmal mit einem recht auffälligen Geräusch komplett abschaltet und das BIOS beim Erkennen der Laufwerke solange stehen bleibt, bis die Platte wieder angelaufen ist.
Eigentlich hatte ich gehofft, daß das Netzteil ausreicht, da der Prozessor im Gegensatz zu einem Pentium IV ja recht sparsam ist.

openSUSE 12.2 macht diese Schwierigkeiten allerdings nicht. Linux ist wohl doch das bessere System, wenn man nicht gerade Spielen will.

Ich werde mal alle überflüssigen Teile (DVD-Laufwerk, Brenner, Diskettenlaufwerke, 3D-Beschleuniger) abklemmen. Mal sehen was dann passiert.

Viele Grüße
0 Punkte
Beantwortet von win98professor Experte (1.4k Punkte)
Hallo Baumnymphe,

wenn ich richtig sehe hast du zwei weitere Grafikkarten (2x Monster 3DII Voodoo2) installiert. Damit kann das Gesamtsystem bei einem 350 Watt Netzteil schon mal an seine Grenze kommen, muss aber nicht. Wenn deine NVIDIA Grafikkarte über 256 MB Ram verfügt, gibt es keine Probleme. Wenn du eine 512 MB Ram Karte in den AGP Port eingesteckt hast, dann ist der Betrieb unter Win98 nicht möglich. Wenn das Dateisystem zerschossen wurde und Scandisk unter Win98 verlorene Ketten findet, dann hilft meist nur noch die Neuinstallation. Du solltest bei einer Win98 Neuinstallation auf jeden Fall auf das Service Pack 2.1d zurückgreifen. Link. Vorher die angegebene Software wie DX 9, MP 9, IE 6 SP1 und Net Framework 1.1 installieren. Beide NVIDIA Treiber sind für Win98 ungeeignet. Der letzte einwandfrei funktionierende Treiber für deine Grafikkarte unter Win98+ME ohne das bekannte Shutdown Problem ist der NVIDIA ForceWare Treiber 71.84 Link.

Gruß Micha
...