1.7k Aufrufe
Gefragt in Tabellenkalkulation von
=INDEX(C50:N50;;VERGLEICH($A$51;C51:N51;0))



sucht den monat aus c50.N50 ist in ordnung
a51 steht der wert den sucht er sich von c51 - n51 ist in ordnung
nun habe ich aber eine neue zeile mit werten von c 52 :n52

wenn ich die formel änder in
=INDEX(C50:N50;;VERGLEICH($A$51;C51:N52;0))

kommt #NV

was mache ich falsch

danke für eure hilfe !!!!!

7 Antworten

0 Punkte
Beantwortet von saarbauer Profi (15.6k Punkte)
Hallo,

so auf den ersten Blick, ist die C51 falsch

=INDEX(C50:N50;;VERGLEICH($A$51;C52:N52;0))1

versuche es mal damit

Gruß

Helmut
0 Punkte
Beantwortet von
ja das stimmt blos dann sucht es mir ja das ergebnis aus der Zeilen
c52 : N52 ich möchte es aber über mehrere zeilen

mfg Rolf

danke
0 Punkte
Beantwortet von saarbauer Profi (15.6k Punkte)
Hallo,

deine Problembeschreibung ist nicht ausreichend um dir eine Lösung zu geben.

Du solltest mal darstellen was du genau machen willst.
Vielleicht wäre eine Beispieltabelle sinnvoll

Gruß

Helmut
0 Punkte
Beantwortet von paul1 Experte (4.9k Punkte)
Hallo Rolf,

Mit diesem Lösungsansatz kann nur runterkopiert werden und Zeile für Zeile abgefragt werden, wobei auch der Bereich $C$50:$N$50 in der Formel als absoluter Bezug festgelegt werden müsste.

Mir ist auch aufgefallen, wenn der Wert von A51 in mehreren Monaten vorkommen sollte, wird trotzdem nur ein Monat ausgegeben.

@Helmut hat schon recht, dass eine konkrete Beispieldatei zum besseren Verständnis der Problemstellung beitragen könnte, denn so wie von Dir geplant, wird es wahrscheinlich nicht gehen.

Gruß

Paul1
0 Punkte
Beantwortet von
Hi,

wenn ausgeschlossen werden kann, daß im Bereich C51:N52 Werte doppelt vorkommen, funktioniert folgende Formel:

=WENN(SUMMENPRODUKT((C51:N52=A1)*1)=0;"";INDEX(C50:N50;SUMMENPRODUKT((C51:N52=A1)*SPALTE(A1:L1))))

CU Aliba
0 Punkte
Beantwortet von
Danke Aliba deine Formel geht nochmals Danke
mfg Rolf
0 Punkte
Beantwortet von paul1 Experte (4.9k Punkte)
Hallo Rolf,

Ergänzung zu AW4:

http://www.excelformeln.de/formeln.html?welcher=39

schöne Grüße an Alle

Paul1
...