1k Aufrufe
Gefragt in Tabellenkalkulation von dutchi1972 Mitglied (419 Punkte)
Hallo zusammen,
Ich hab eine Tabelle in der vers. Werte drin stehen.
Ich hab einen Wert der Steht inseperat in Zelle B2,
diesen soll das Makro in der Tabelle in Spalte M suchen und mir als Ergebnis "die Zeilennr." in der der Wert gefunden wurde zurückgeben in Zelle A1.

ist das möglich ?

Gruß Dutchi

[*][sup]Admininfo: Führ bitte einen Thread nicht fort indem du einen Zweiten eröffnest, und vermeide Mehrfachanfragen. Die Datenbank wird es dir danken. Siehe FAQ 2 für deine nächste Anfrage.[/u][/sup]

3 Antworten

0 Punkte
Beantwortet von rainberg Profi (14.9k Punkte)
Hallo Dutchi,

per Formel ginge das so:

=VERGLEICH(B2:M:M;0)

Gruß
Rainer
0 Punkte
Beantwortet von rainberg Profi (14.9k Punkte)
Hallo Dutchi,

wenn Du auf VBA bestehst:
Sub zeile()
Dim intZeile As Integer
intZeile = WorksheetFunction.Match(Range("B2").Value, Range("M:M"), 0)
MsgBox intZeile
End Sub


oder als Change-Ereignis

Private Sub Worksheet_Change(ByVal Target As Range)
Dim intZeile As Integer
If Target.Address <> "$B$2" Then Exit Sub
intZeile = WorksheetFunction.Match(Range("B2").Value, Range("M:M"), 0)
MsgBox intZeile
End Sub


Gruß
Rainer
0 Punkte
Beantwortet von dutchi1972 Mitglied (419 Punkte)
Halllllooooo,

Entschuldige, hatte damals die Frage gestellt und zwischenzeitlich einen Lösung gefunden.... und leider nicht mehr hier im Forum herumgestöbert.
somit hab ich jetzt erst wieder gesehen das da noch was offen ist .

Entschuldige nochmal.

Ich bin normal immer so das ich auf alles (neg/pos Antworten) antworte.

Trotzdem danke dür eure Mühe und Antwort.

Gruß0 Dutchi
...