3.6k Aufrufe
Gefragt in Tabellenkalkulation von little-key Mitglied (333 Punkte)
Hallo liebe Forengemeinde,

ist es ohne VB möglich aus einer bestimmten Spalte einer Tabelle ein Wort zu finden und die darunter liegende Zelle in der Spalte den Wer zu ermitteln?

z.B. Wenn in Spalte G das Wort "Müll" gefunden wird, soll aus der Zelle darunter die Zahl (Wert) in eine andere Zelle eingetragen werden.

Wichtig! Das Wort kann nur 1x vorkommen und somit auch nur eine Zahl aus der darunter liegenden Zelle.

Vielen Dank schhon mal im voraus.

5 Antworten

0 Punkte
Beantwortet von computerschrat Profi (29.8k Punkte)
Hallo little-key,

wie viele Zeilen umfasst denn der Bereich, in dem "Müll" stehen kann?
Muss der Wert wirklich darunter stehen oder kann er auch daneben stehen? Wenn der Wert daneben stehen darf, dann wäre der SVERWEIS das Mittel der Wahl:
=SVERWEIS("Müll";G1:H5;2)
Hier im Beispiel stehen die Suchwerte in der Spalte g und die dazugehörigen Zahlen rechts daneben.

Wenn es nur wenige Zeile sind, könnte eine mehrfache WENN Anweisung das Problem lösen, bei vielen Zeilen ist die aber nicht mehr brauchbar.

Alternativ könntest du auch in einer Hilfsspalte (eventuell auch auf einem eigenen Blatt folgendes eintragen:
In XY1:
=WENN(G1="Müll";G2;0)
Die Formel kopierst du durch die ganze Spalte XY nach unten. Damit prüfst du in jeder Zelle XYi ob in Gi "Müll" steht und schreibst dann in XYi den Wert aus Gi+1, andernfalls 0.
In einer Summenzelle kannst du über die ganze Spalte XY summieren und hast somit den gesuchten Wert.

Gruß
computerschrat
0 Punkte
Beantwortet von little-key Mitglied (333 Punkte)
Schon mal vielen Dank.

Es sind max. 25 Zeilen.

Zeilen wären mir schon lieber.
Und, es können auch andere Bezeichnungen drin stehen.
0 Punkte
Beantwortet von computerschrat Profi (29.8k Punkte)
Dann würde ich die Methode mit =WENN(G1="Müll";G2;0) einsetzen und die in die 25 Zeilen kopieren.
Wenn du diese Spalte in einem eigenen Tabellenblatt unterbringst und dann auf der Hauptseite, in der Zelle mit dem Ergebnis einfach den Inhalt der Summe der Ergebnisse der Wenn-Zellen schreibst, dann ist das Ergebnis da ohne Makro und du kannst deine Anordnung der Daten so machen, wie du möchtest.

Gruß
computerschrat
0 Punkte
Beantwortet von m-o Profi (21.8k Punkte)
Hallo Mario,

versuch mal die folgende Formel:

=INDIREKT("A" & VERGLEICH("Müll";A1:A16;0)+1)

Die Suchwerte stehen in Spalte A. Die Bezüge musst du natürlich auf deine Tabelle anpassen.
Durch die Formel VERGLEICH wird das Wort "Müll" gesucht und die Zeile zurückgegeben, in der es gefunden wird.
Durch Indirekt und +1 wird der der Wert in der Zelle darunter ausgegeben.
Das funktioniert aber nur, wenn das Wort allein in einer Zelle steht; bei Müllfahrzeug wird z.B. kein Wert ausgegeben.
Wird das Suchwort nicht gefunden, so wird #NV ausgegeben.

Gruß

M.O.
0 Punkte
Beantwortet von little-key Mitglied (333 Punkte)
Hallo M.O.,

das funktioniert hervorragend.
Vielen lieben Dank, aber auch an computerschrat für die Mühe.
...