9.3k Aufrufe
Gefragt in Tabellenkalkulation von
Hallo,
ich habe eine Liste von Datum x - y und zu jedem Datum gehört eine Stundenanzahl (gefahrene Stunden mit Firmenauto)

Wie berechnet man sich die Stunden die zwischen dem zb 1.7.2014 und dem 10.7.2014 gefahren worden sind? Bzw. welche Funktion muss ich verwenden?

Die gefahrenen Stunden sollen sich automatisch wieder berechnen, wenn man statt dem 10.7. zB 20.7. eingibt.

BITTE UM HILFE !

Liebe Grüße
Christoph

2 Antworten

0 Punkte
Beantwortet von m-o Profi (21.6k Punkte)
Hallo Christoph,

Beispiel:

Spalte A: Datum
Spalte B: Stunden
Zelle E1: Anfangsdatum
Zelle E2: Endedatum

Formel für die Summierung der Stunden zwischen den beiden Daten (inkluse der jeweiligen Tage):

=SUMMEWENNS(B1:B18;A1:A18;">=" &TEXT(E1;"TT.MM.JJJJ");A1:A18;"<=" &TEXT(E2;"TT.MM.JJJJ"))

Die Bezüge musst du entsprechend auf deine Tabelle anpassen. Die Funktion SUMMEWENNS gibt es erst ab Excel 2007.

Hast du eine ältere Version, so musst du das mit SUMMENPRODUKT machen:

=SUMMENPRODUKT((A1:A18>=DATUM(JAHR(E1);MONAT(E1);TAG(E1)))*(A1:A18<=DATUM(JAHR(E2);MONAT(E2);TAG(E2)));(B1:B18))

Gruß

M.O.
0 Punkte
Beantwortet von paul1 Experte (4.9k Punkte)
Hallo Christoph,

als Alternative zur Summenproduktformel:

=SUMMEWENN(A:A;"<="&E2;B:B)-SUMMEWENN(A:A;"<"&E1;B:B)

Gruß

Paul1
...