2.2k Aufrufe
Gefragt in Tabellenkalkulation von b25812 Mitglied (509 Punkte)
Hallo,
ich möchte gerne eine Zählfunktion.
In der Spalte a stehen Wochentage diese beziehen sich dann auf die Zeile A-AK
Jetzt soll geprüft werden wo in der Spalte A der Samstag steht und ob z.b n auch was drin steht. Wenn ja dann sollte in spalte Z eine 1 stehen.
Der Monat hat vier Samstage also sollte im besten falle 4 mal in der Z Spalte stehen.
Beispiel:
A6+A13+A20+A25 stehen die Samstage
N6 + N20 steht nichts
N13+N25 steht 08:00 Uhr
dann sollte in in Z3 eine 2 stehen

ich hoffe Ihr könnt mir da helfen
Danke Gruß Andi

8 Antworten

0 Punkte
Beantwortet von computerschrat Profi (26.2k Punkte)
Hallo Andi

probiers hiermit in Z3

=SUMMENPRODUKT((A:A="Samstag")*(N:N<>""))

Gruß
computerschrat
0 Punkte
Beantwortet von b25812 Mitglied (509 Punkte)
Hallo,
leider scheint es nicht zu gehen, bei mir steht dann #Zahl.
Muß ich da noch was ändern?
Gruß Andi
0 Punkte
Beantwortet von computerschrat Profi (26.2k Punkte)
Hallo Andi,

kannst du eventuell mal eine Beispieltabelle auf www.file-upload.net hochladen und den Link darauf dann hier posten?
Ich bin jetzt nicht sicher, wie der Inhalt der Zellen wirklich aussieht und wie die Zellen formatiert sind.

Gruß
computerschrat
0 Punkte
Beantwortet von b25812 Mitglied (509 Punkte)
Hallo
hier mal eine Beispiel Tabelle
http://www.file-upload.net/download-9986710/Test-Z--hlen.xls.html

Gruß Andi
0 Punkte
Beantwortet von m-o Profi (19.3k Punkte)
Hallo Andi,

für Thomas so (überprüft nur kommen):

=SUMMENPRODUKT((B3:B33<>"")*(WOCHENTAG(A3:A33;1)=7))

oder falls du ganz sicher gehen willst (überprüft kommen und gehen):
=SUMMENPRODUKT((B3:B33<>"")*(C3:C33<>"")*(WOCHENTAG(A3:A33;1)=7))

Für die anderen musst nur die Spalte B (und im 2. Fall natürlich auch die Spalte C) entsprechend anpassen.

Gruß

M.O.
0 Punkte
Beantwortet von b25812 Mitglied (509 Punkte)
Hallo
danke für die Formel, funktioniert super !!!!

Gruß Andi
0 Punkte
Beantwortet von rainberg Profi (14.9k Punkte)
Hallo Andi,

eine komplexere dafür aber kopierbare Formel wäre:

=SUMMENPRODUKT((BEREICH.VERSCHIEBEN($A$1;2;VERGLEICH(I2;$A1:$G1;0)-1;31;)>0)*(WOCHENTAG($A$3:$A$33;2)=6))

Achte darauf, dass die Namen in Quelle und Ziel identisch sind und keine Leerzeichen enthalten.

Gruß
Rainer
0 Punkte
Beantwortet von b25812 Mitglied (509 Punkte)
Hallo Rainer,
geht auch Super
Danke
Gruß Andi
...