472 Aufrufe
Gefragt in Windows 7 von hallogen Experte (1.5k Punkte)
hallol
Ich plage mich seit 2 Tagen mit einem mir unerklärlichen Phänomen herum.
Ich habe hier einen störrischen PC zur Neuinstallation mit Windows7Prof 64bit
und ich habe mein Batchfile:

echo off
del /f C:\Users\........\SiteSecurityServiceState.txt
copy NUL C:\Users\......\SiteSecurityServiceState.txt
attrib +r C:\Users\.....\SiteSecurityServiceState.txt
start /min C:\"Program Files (x86)\Mozilla Thunderbird\thunderbird.exe"
start /min C:\"Program Files (x86)\MicroSIP\microsip.exe"
exit


Manuell ausgelöst läuft das Script ohne Probleme durch.
Ich würde es aber gerne über die Gruppenrichtlinien als Startscript laufen lassen.
Auf diese Weise weigert sich das Script aber die beiden Startbefehle abzuarbeiten.
Es passiert einfach nichts.
Um irgendwelche Fehlerquellen weitgehend auszuschließen
habe ich es nun schon mit einer komletten Neuinstallation nur mit Updates versucht.
Es hat nichts geholfen.
Nun bin ich mit meinem Latein am Ende.
Hat jemand eine Idee?
Danke.

2 Antworten

0 Punkte
Beantwortet von
Hi,
bei Leerzeichen im Pfad "" einfügen, wenn manche Programme nicht starten möchten.

start /min C:\"Program Files (x86)\MicroSIP\microsip.exe"

1. mal das /min weglassen, könnte eine unbekannte Operation sein!

2. %winbootdir% steht für C:\Windows im DOS-Bereich

start "" %winbootdir%\"Program Files (x86)\MicroSIP\microsip.exe"
0 Punkte
Beantwortet von hallogen Experte (1.5k Punkte)
@Lasko
Danke für die Rückmeldung
Hatte ich alles bis auf die Variante %winbootdir% bzw %appdata% schon alles versucht.
Funktionierte aber leider auch nicht.
Der Witz ist ja aber,daß das Batchfile auf meinem Haupt-PC von Anfang an funktioniert.

Lange Rede kurzer Sinn,ich habe meinen Fehler gefunden.
Mein Eintrag in die Gruppenrichtlinien, damit das Script startet gehört unter Benutzerkonfiguration-->Skripts
und nicht unter Computerkonfiguration-->Skripts.
...