914 Aufrufe
Gefragt in Tabellenkalkulation von tschonn Experte (1.2k Punkte)
Hallo,
hab ein Problem mit dem Berechnen von Gesamtstunden.
Es besteht eine Datei, in der die unterschiedlichen Arbeitsstunden der Mitarbeiter eingetragen werden. Am Ende des Blattes sollen für jeden Mitarbeiter die Gesamtstunden automatisch zusammengerechnet werden, auch wenn diese "negativ" wären, sprich am Montag wird um 23:00 begonnen und am Dienstag um 04:30 aufgehört.
Anbei ein kleines Beispielund schon mal danke für Eure Hilfe und Mühe....

A B C D
1 Tag Beginn Ende Name
2 Montag 18:00 6:00 Müller
3 Dienstag 06:00 18:00 Müller
4 Mittwoch 06:00 18:00 Bauer
5 06:00 14:00 Bauer
6 14:00 21:00 Schmidt
7 06:00 14:00 Meier
8 18:00 02:00 Bauer
9 06:00 18:00 Müller
10 06:00 18:00 Schmidt
11 06:00 14:00 Schmidt
12 06:00 14:00 Baumann
13 06:00 14:00 Baumann


Gesamtstunden
Müller
Bauer
Schmidt
Meier
Baumann

7 Antworten

0 Punkte
Beantwortet von tschonn Experte (1.2k Punkte)
Hat natürlich net hingehauen. Also:
Spalte A Tag
Spalte B Arbeitsbeginn
Spalte C Arbeitsende
Spalte D Name
und in den verschiedenen Zeilen die verschiedenen Tage
Darunter dann eine Übersicht:
Gesamtstunden neben dem Namen jedes einzelnen Mitarbeiters.

Hoffe es ist verständlich ;-)
0 Punkte
Beantwortet von
Hallo,

ob das jetzt die eleganteste Lösung ist, weiß ich nicht, aber sie
scheint zu funktionieren:

Angenommen in E17 steht Müller und darunter jeder Name genau
einmal, dann ist für die Summierung z.B. in D17 folgende Matrix-
Formel einzugeben.

=SUMME(WENN($E$2:$E$13=$E17;WENN($D$2:$D$13<$C$2:$C
$13;1+$D$2:$D$13;$D$2:$D$13)-$C$2:$C$13);0)

abzuschließen mit STRG+UMSCHALT+Enter

Die Ergebniszelle dann noch im Zahlenformat [hh]:mm formatieren,
oder falls du das Ergebnis lieber als Standardzahl sehen willst,
dann hinten an die Formel noch *24 anhängen.

Sollte das Problem alternativ auch etwas eleganter über
Summenprodukt lösbar sein, würde mich die Lösung interessieren.
Vielleicht findet sich ja hier noch wer, der das hinbekommt. Ich habs
leider nicht geschafft.

Gruß Mr. K.
0 Punkte
Beantwortet von tschonn Experte (1.2k Punkte)
Danke für die Antwort, werde es morgen mal ausprobieren. Allerdings sehe ich das Problem darin, dass die Namen in der Spalte öfters vorkommen werden.
Aber ich melde mich nach dem Testen nochmal.
0 Punkte
Beantwortet von
Allerdings sehe ich das Problem darin, dass die Namen in der
Spalte öfters vorkommen

Dann hab ich mich leider nicht richtig ausgedrückt. Die Namen können
vorkommen, so oft sie wollen. Wenn du aber an anderer Stelle eine
Summe ziehen willst, werden sie dort nur einmal vorkommen. In
meinem Fall hatte ab E17 jeden Namen noch einmal untereinander
geschrieben und die Formel aus D17 nach unten kopiert um alle
Summen sehen zu können.

Gruß Mr. K.
0 Punkte
Beantwortet von rainberg Profi (14.9k Punkte)
Hallo tschonn,

alternativ geht auch folgende Formel in G2:

=SUMMENPRODUKT((D$2:D$13=F2)*(REST(C$2:C$13-B$2:B$13;1)))

Die Datenmatrix befindet sich in B2:D13.
Die auszuwertenden Namen stehen in Spalte F ab F2 abwärts.

Gruß
Rainer
0 Punkte
Beantwortet von tschonn Experte (1.2k Punkte)
Hallo,
Vielen Dank an Euch beiden. Damit sich niemand umsonst Arbeit gemacht hat, habe ich die Formel von rainberg genommen und meiner Tabelle angepasst und den Tipp zur Zahlenformatierung von xlKing.
Funktioniert genauso wie ich wollte. nochmals Danke....
0 Punkte
Beantwortet von
Rainers Formel-Lösungen sind immer wieder genial. Die REST-
Funktion mit einzubauen, da muss man erstmal drauf kommen. :-)
...