186 Aufrufe
Gefragt in Tabellenkalkulation von b25812 Mitglied (509 Punkte)
Hallo,
ich hätte mal ein Frage.
Ich habe eine Tabelle in der es zu vergleichen gilt eine Artikel Nr. ein Bestand und
ein Mindestbestand.
In Spalte A und E stehen die Artikelnr.
In Spalte B ist der Istbestand und in F ist der Sollbestand.
Nun soll in D angezeigt werde ob ich was bestellen muss oder nicht.
Dazu müssen die Werte in Spalte A und E geprüft und verglichen werden und das
gleiche mit B und F.

Artikel NR. Bestand Spalte c Spalte d Artikel Nr. Mindestbestand
C 12 133/1 3 C 27 006 5
C 12 178/1 6 C 2540 5
C 1381 4 C 25 004 5
C 14 006 4 C 2287 5
C 14 114 5 C 1922 5
C 1922 1 C 14 114 5
C 2287 2 C 14 006 5
C 25 004 9 C 1381 5

Super wäre noch wenn positive Werte oder negative Werte Farblich anders
dargestellt werden.

Könnt Ihr mir da helfen ?

Mfg Tommi

5 Antworten

0 Punkte
Beantwortet von b25812 Mitglied (509 Punkte)
So ist die Darstellung hoffentlich besser.

Artikel NR. Bestand---Spalte-c------Spalte-d---Artikel Nr. Mindestbestand
C 12 133/1---- 3-----------------------------------------C 27 006-------5
C 12 178/1-----6-----------------------------------------C 2540-------- 5
C 1381----------4-----------------------------------------C 25 004------5
C 14 006-------4------------------------------------------C 2287--------5
C 14 114-------5------------------------------------------C 1922--------5
C 1922-------- 1-------------------------------------------C 14 114-----5
C 2287--------2------------------------------------------- C 14 006-----5
C 25 004----- 9--------------------------------------------C 1381------- 5

Mfg Tommi
0 Punkte
Beantwortet von m-o Profi (19.3k Punkte)
Hallo Tommi,

so könnte deine Formel für Spalte D aussehen. Voraussetzung ist, dass alle Artikelnummern in den Spalten A und E nur einmal vorkommen:

=WENNFEHLER(SVERWEIS(E2;$A$2:$B$9;2;FALSCH)-F2;"Kein Bestand gefunden")

Damit wird dir in Spalte D angezeigt, um wieviel der Bestand des Artikels in Spalte E unter bzw. über dem Mindesbestand liegt.

Du kannst die Zahlen so formatieren, dass negative Rot angezeigt werden. Auch besteht über die bedingte Formatierung die Möglichkeit, dass Zellen mit negativen Zahlen anders gefärbt werden.

Gruß

M.O.
0 Punkte
Beantwortet von b25812 Mitglied (509 Punkte)
Hallo M.O.
danke für die schnelle Antwort.
leider kommt bei mir die Meldung #Name?

Gruß Tommi
0 Punkte
Beantwortet von m-o Profi (19.3k Punkte)
Hallo Tommi,

welche Excel-Version hast du denn?
Falls du nicht Excel 2007 oder neuer hast, dann nimm die folgende Formel:

=WENN(ISTNV(SVERWEIS(E2;$A$2:$B$9;2;FALSCH));"Kein Bestand gefunden";SVERWEIS(E2;$A$2:$B$9;2;FALSCH)-F2)

Gruß

M.O.
0 Punkte
Beantwortet von b25812 Mitglied (509 Punkte)
Hallo M.O.
ich habe noch 2003. Klappt aber Super danke !!!

Gruß Tommi
...