397 Aufrufe
Gefragt in Skripte(PHP,ASP,Perl...) von
Guten Tag,

Mein letzter Kentnissstand
ist schon etwas veraltet also
beachtet bitte
aufkommende "bitte was?".
Zwischen [xurl=https://supportnet.de/faqsthread/2350237|SIW - System Information for Windows]Windows[/url] XP und
Windows 10 hatte
ich keinen Kontakt mehr zu
PCs gehabt.

Zum Thema: ich
programmiere diverse
Programme in Perl und lasse
sie
mittels CGI ausgeben. Da ich
mich noch relativ gut damit
auskenne,
scheidet die Option das es
an meinen Scripts liegt eher
aus. Zumal das
Problem schon bei dem
"Hello-World" auftritt.

Zum Problem: nach dem ich
mich mehr oder weniger mit
Windows 10
angefreundet habe, habe ich
mir den Apache Webserver
2.2. auf meinem
Laptop installiert. Testseite
und auch alles andere
funktioniert prächtig,
bis auf das, dass meine
Scripts je nach Länge des
Programms lange
Ladezeiten haben. Ein
einfaches Formular mit 8
Parametern benötigt
derzeit ca. 15 Sekunden.
Hab aber widerrum bemerkt
das wenn ich einen
Fehler einbaue, die
Fehlermeldung sofort
angezeigt wird. Ebenso die
vorangelegte %ENV-Datei
benötigt 10 Sekunden. 

Ich habe desweiteren keine
weiteren Programme wie
XAMPP o.ä.
installiert, lediglich Windows
10 Home und Apache.
Habe mich bereits auch
durchgegoogelt aber nichts
brauchbares
gefunden, lediglich Tipps
gefunden wie man Apache
mit dies und jenem
beschleunigen kann. Aber
wenn schon so kleine
Dateien Probleme
verursachen liegt es eher an
etwas anderem nur ich
komme nicht drauf
an was es liegen könnte..
hättet ihr vielleicht eine
Idee?

Lg und vielen Dank schon
mal im vorraus!


Nachtrag: im Error-Log wird
nichts darüber verzeichnet.

4 Antworten

0 Punkte
Beantwortet von computerschrat Profi (22k Punkte)
Hallo Otsik,

du hast vermutlich in den Quellen deiner Webseite verschiedene Referenzen auf "Localhost". Das kostet einiges an Zeit, weil es viele Zugriffe darauf gibt und jedesmal nach der Adresse gesucht werden muss. Ändere die Referenz mal von Localhost auf die Adresse des Localhost 127.0.0.1
Typischerweise steht die zentrale Referenz auf Localhost in der Datei web.config. Die Änderung bringt erfahrungsgemäß einen erheblichen Geschwindigkeitsschub.

Gruß
computerschrat
0 Punkte
Beantwortet von
Hallo computerschrat,

danke für deine Antwort.
Habe erstmal versucht alles auf 127.0.0.1 umzustellen aber leider
sehe
ich keinerlei Veränderung oder habe etwas falsch gemacht. Eine
web.config habe ich nicht da ich (bewusst) die Version 2.2 von
Apache
habe.
Ich denke es muss ein Problem bzw. fehlerhafte Einstellungen bei
mir
zwischen Perl, Apache und Windows 10 geben da wie gesagt selbst
das
einfache "Hello World"-Programm viel zu lange dauert und auf
meinem
alten Rechner mit Windows XP werden selbst große und komplexe
Programme innerhalb von Millisekunden ausgeführt.

Musste jedoch im Gegensatz zu meinem alten Rechner einiges
anders
machen. So lautet meine Shebang-Zeile "#!C:\Perl64\bin\perl" was
ich
seltsam finde da es normal mit "#!/usr/bin/perl" lief.
Ebenso musste ich in der httpd-conf den vollen Pfad zu den
jeweiligen
Ordnern angeben. Bei meinem alten Rechner musste ich daran
nichts
ändern obwohl ich es Ordnertechnisch gleich installiert habe (sprich
Perl
unter C:, Apache unter Programme usw.), hätte ich diese Änderung
in der
httpd-conf jedoch nicht gemacht wäre gar nichts gelaufen.
Vielleicht (zumindest vermute ich das) liegt es an einer dieser
"Dinge"
aber nun ja, bin ratlos..
0 Punkte
Beantwortet von
Moin, leider kann man aus deiner Beschreibung keine Schlüssel ziehen, einmal lief der Apache unter Linux (/usr/bin/...) und ein anderer Mal unter Windows XP.
Da es jetzt unter Windows 10 laufen soll, wird wohl wieder eine andere Vorgehensweise nötig sein.
Allgemein  benötigt Windows zusätzliche Software, wie beispielsweise die Laufzeitumgebung.
Mag sein, dass in der "Error-Log" (Apache) keine Fehler verzeichnet sind, aber wie sieht es damit unter Windows aus?
Das kannst du in der Ereignisanzeige nachsehen.
Sowie du es jetzt beschreibst, kann man gar nicht erkennen wo das Problem sein könnte, die Apache-Konfiguration ( httpd.conf) und/oder der Windows "Vorbau"...siehe oben.

[url=https://hosting.1und1.de/digitalguide/server/konfiguration/apache-webserver-einrichten-so-wirds-gemacht/]Apache-Webserver einrichten und konfigurieren[/url]
[i]1&1 Digital Guide » Webservers als Einzelkomponente[/i]

Gruß
0 Punkte
Beantwortet von computerschrat Profi (22k Punkte)
Hallo Otsik,

wie greifst du auf die Webseiten zu. Benutzt du eine lokale Adresse in deinem lokalen Netzwerk? Oder gehst du über die öffentliche IP-Adresse, ggf. über einen DynDNS? In dem Fall könnte es auch ein Problem mit der Namensauflösung geben, weil immer wieder die dynamische Adresse ausgelöst werden muss, und das kann bei einem ungünstig gewählten DNS-Server sehr viel Zeit kosten.

Gruß
computerschrat
...