567 Aufrufe
Gefragt in WindowsXP von
Hallo zusammmen,

habe Probleme dabei, einen Brother MFC L2700DW (Multifunktionsgerät, 4 in 1) an Windows XP ans Laufen zu bringen.
Das Gerät ist per USB am PC angeschlossen.
Das intergrierte FAX ist nicht mit dem Telefonnetz verbunden.
Im Gerätemanager des Windows-XP-PCs zeigt sich der Name des Druckers an zwei Stellen:
1. bei "Anschlüsse (COM und LPT)"
und
2. bei "Bildbearbeitungsgeräte".
In beiden Fällen haben die entsprechenden Einträge einen gelben Kreis mit schwarzem Ausrufezeichen darin.
UnterGerätestatus findet sich jeweils "Der Gerätetreiber für diese Hardware kann nicht initialisiert werden. (Code 37)".

Was ist zu tun, um das Multifunktionsgerät im vorliegenden Fall ans Laufen zu bringen?
Die zum Drucker gehörende CD ist vorhanden.

Grüße

16 Antworten

0 Punkte
0 Punkte
Beantwortet von
Mit der Treibersoftware von dieser Brother-Seite trat keine Verbesserung ein (War schon versucht worden.).

Kann es sein, dass da die "Zuordnung" des Anschlusses des Multifunktionsgerätes am PC nicht paßt (COM-, LPT-"Zuordnung")?
Ich meine, dass ich schon mal so etwas ähnliches hatte.
Kann mich jedoch nicht mehr genau daran erinnern.

Grüße
0 Punkte
Beantwortet von
Hallo, du musst alle Mainboard Treiber installieren, also der Chipsatz, USB und so weiter.
Unter Windows XP zumindest der SP2, der SP3 ist besser.
Was für Windows XP, 32/64 Bit?
Oft ist so, dass der Treiber auf der Supportseite des Herstellers frischer oder einfach "gefixt" ist, als der was auf der CD angeboten wird.
Lasse den Treiber aus dem Gerätemanager installieren, dort wo die Fragezeichen angezeigt werden, nur den Pfad zum  Treiberordner (vorher entpackt) zeigen- [u]nicht [/u]über die Setuproutine.
Es geht um die *.inf oder *.sys Dateien.
[quote]2. bei "Bildbearbeitungsgeräte".[/quote]Das kann auch der TWAIN Treiber sein, den braucht man für die Software nachher, beispielsweise der IrfanView, um damit scannen zu können.
Beachte auch die Installationshinweise: [url=http://support.brother.com/g/b/downloadhowto.aspx?c=de&lang=de&prod=mfcl2700dn_eu&os=7&dlid=dlf101000_000&flang=17&type3=405]Drucker- & Scanner-Treiber für den lokalen Anschluss[/url] « unter Vista steht auch was zum "MFC/FAX-Anwender", mal versuchen...

Gruß
0 Punkte
Beantwortet von
Vielen Dank für die Rückmeldung.

PC war über die letzte Nacht durchgelaufen.
Stelle gerade fest, dass die gelben Kreise mit schwarzem Ausrufezeichen darin verschwunden sind.
Allerdings steht das per USB angeschlossene Multifunktionsgerät z. B. auch als Drucker nicht zur Verfügung (u. a. auch kein Drucker-Eintrag im Gerätemanager).

Der vorliegende ältere PC hat zwei USB-Anschlüsse (vermutlich nur USB1.0) am Mainboard und weitere aufgrund einer zusätzlichen "Steckkarte" (vermutlich USB 2.0).
Jedenfalls war es so, dass der Drucker bei einem weiteren Versuch spät in der Nacht über einen der Mainboard-USBs funktionierte (allerdings mit dem Hinweis "langsamer Anschluss".
Daraufhin wurde das Multifunktionsgerät wieder an einem der "Steckkarten"-USBs angeschlossen, zu denen später die gelben Kreise mit schwarzem Ausrufezeichen darin verschwanden (s. o.).  
Grundsätzlich funktioniert diese "Steckkarte" (USB-Sticks lassen sich dort auslesen.).

Was kann da nicht richtig zugewiesen sein (Druckeranschluss über "Steckkarten"-USB)?
0 Punkte
Beantwortet von
Kann also den Treiber leider nicht einfach aus dem Gerätemanager installieren, da dort derzeit kein Hinweis mehr auf die Existenz des Multifunktionsgerätes vorliegt (fehlender Eintrag).
0 Punkte
Beantwortet von
Im Gerätemanager steht der Druckeranschluß unter "Anschlüsse (COM und LPT)" aktuell auf LPT3.
0 Punkte
Beantwortet von
Die beiden gelben Kreise mit schwarzem Ausrufezeichen sind wieder da.
Sie verschwinden, wenn sich das Multifunktionsgerät ausschaltet.

Habe versucht, aus dem Geräte-Manager heraus Treiber zu laden.
Dabei erfolgt auch ein Ladevorgang.
Allerdings kommt zum Schluß auch folgende Meldung:
"Der Gerätetreiber für diese Hardware kann nicht initialisiert werden. (Code 37)".

Wer weiß Rat?
0 Punkte
Beantwortet von win98professor Experte (1.3k Punkte)
Hallo,

dein Multifunktionsgerät ist ein Drucker / Scanner / Fax mit ausdrücklicher USB 2.0 Highspeed Schnittstelle. Einige Geräte, z. B. auch bei HP, benötigten zur einwandfreien Funktion ein USB v1.1 Update für den älteren Anschluss. Bei HP wurde dieses Update früher mal zur Verfügung gestellt, ist aber mittlerweile auch aus dem Netz genommen worden. Dein Multifunktionsgerät unterstützt außerdem lt. Anforderungen ausdrücklich keine nachträglich gesteckten USB Karten (Third party USB ports are not supported!). Ansonsten ist die Einrichtung immer wie folgt. Geräteanschluss trennen, Treiber deinstallieren > Neustart. Zur Installation wird Windows XP SP3 (SP3 fügt eine Menge neuer USB Updates ein) und ein aktuelles Net Framework benötigt. Multifunktionsgeräte mit Drucker / Scanner / Fax benötigen in der Regel Net Framework 3.5 SP1 oder Net Framework 4.0. Wenn alles aktualisiert wurde: Treiber von CD installieren > Neustart. Gerät wieder verbinden > automatische Treibereinrichtung startet. Falls die Einrichtung auch danach zu keinem Erfolg führt, ist das neue Multifunktionsgerät nicht mit deinem alten USB-Mainboardanschluss kompatibel.

Gruß Micha
0 Punkte
Beantwortet von
[quote]Der vorliegende [u]ältere PC [/u]hat zwei USB-Anschlüsse...[/quote]Ich finde schon, dass solche Informationen bereits bei der Fragestellung erwähnt sein sollten.
Ähnliches hatte ich mit meinem älteren Testrechner, eine 2x USB 2.0 PCI und dem CanoScan LiDE 20 Scanner dran.
Alle andere Geräte wie: USB Sticks, USB-RJ45 etc. funktionieren ohne Probleme, wie du beschreibst.
Beim Scanner war es so, der konnte nicht richtig initialisiert werden, der Schlitten hüpfte nur hin und her.
Egal, ob es unter Windows oder Linux getestet wurde.

Die aktuelle Konfiguration kannst du mit einem Live System austesten, also damit booten und mit dem Brother versuchen, direkt am USB Port, wie auch an der PCI Karte.
Über dem Terminal: [i]lspci[/i], wie auch [i]lsusb[/i] ausführen und so einige Informationen zum Mainboard, der PCI Karte auslesen lassen.
Ansonsten hilft ja nur der berühmte "Draufblick"...

"Vermutlich" ist keine gute Beschreibung bei einer Fehlersuche, mache Angaben zum Mainboard und der USB PCI Karte.

Da sich bei mir um einen Testrechner handelt, versuchte ich [u]nicht[/u] mit einer anderen USB PCI Karte, mit einem anderen Chipsatz drauf.
Andere USB Kabel hatte ich aber getestet, also welche mit einem Ferritkern und ohne, emm...mit zwei Ferritkernen (an jeder Seite eins) ebenfalls.
Einen aktiven Hub dazwischen zu schalten, wäre eine Möglichkeit, aber nicht getestet.

Viel Erfolg!

[i]Vielleicht sollte der ältere PC auch ein Testrechner werden...[/i]
0 Punkte
Beantwortet von
Vielen Dank für Eure Rückmeldungen.

Bei der 4-fach USB-KArte handelt es sich um eine "High Speed USB 2
5-Port PCI Adapter DU-520" von D-Link.

Das vorliegende Mainboard ist ein "Superb 4L" von Quantumn Designs Limited (mit einer Intel-Pentium-4-CPU).  

Betriebssystem: Windows XP SP3

Wie prüfe ich den Stand von "Net Framework"?

Wie weiter vorgehen?

Grüße
...