31 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Mitglied (660 Punkte)

Hallo und einen schönen Tag,

wer kann mir bei der Lösung einer Formel helfen.

Versuche aus zwei Zeilen den letzten Wert zu finden wenn in einer anderer Zelle Bedingung erfüllt ist.

Beispiel:

In den Zellen B18 bis i19 sind Werte ( in b18 steht 80,in c18 steht 99, in b19 steht 126 in c19 steht 44) das Ziel steht in den Zellen J18 bis J19 Ziel = 301 nun soll die die Zahl erscheinen die das Ziel erreicht hat. Hier ist es aus Zelle C19, da das Ziel 301 erreicht wurde.

Für eine Zeile funktioniert das aber für zwei Zeilen klappt es nicht. Die Formel für eine Zeile Ist.=WENNFEHLER((VERWEIS(2;1/(B18:I18<>"");B18:I1 ));0) Ergebnis ist 99 von Zelle C18

Das habe ich dann probiert.

=WENNFEHLER((VERWEIS(2;1/(B18:I19<>"");B18:I19 ));0) Da ich die Zahl aus C19 brauche. Dies klappt nicht.

Spalten kann ich nicht verwenden, ( oder?) da ich diese Formel wieder auf andere Zeilen anwenden möchte. Zum Beispiel in den Zeilen B26 bis I27) undsoweiter.

In der Hoffnung auf eine Lösung

Gruß Adde

1 Antwort

0 Punkte
Beantwortet von addeguddi Mitglied (660 Punkte)
ausgewählt von halfstone
 
Beste Antwort

Hallo an das Forum,

habe die Formel gefunden. Ist etwas umständlich aber es funktioniert.

Eingabe in den Zellen um den Wert zu finden von zelle C18 bis I18 und C19 bis I19 eine Hilfszelle und gibt diese ein.

Meine Hilfszellen sind von T1,T2 bis Y1,Y2in Z1 und Z2 steht die Zahl 

Für C: =WENNFEHLER((WENN(ISTLEER(C18:C18);"";KGRÖSSTE(C18:C18;1)) );"")

Für D:=WENNFEHLER((WENN(ISTLEER(D18:$I$18);"";KGRÖSSTE(D18:$I$18;1)) );"")

je nachdem wie viel Zellen berechnet werden müssen. Bie mir sind es die Zellen c 18 bis I19.

In der letzten Zelle wird der Wert von den letzt belegten Zellen angezeigt.

Hier ist es in Zelle Z1 und Z2

 Z1)=WENN(SUMME(U34:AM35)=0;"";VERWEIS(9^99;U34:AM34))

Z2)=WENN(SUMME(U34:AM35)=0;"";VERWEIS(9^99;U34:AM35))

Nun kann ich den Wert zur Auswertung durch =kgrösste von (Z1:Z2) in die Zelle importieren wo der Wert hin soll.

Gruß Adde

.

...