173 Aufrufe
Gefragt in Tabellenkalkulation von

Hallo,

Frage:

Ich möchte in Spalte A von Zeile 5-50 alle Sonntage fortlaufend Zeile für Zeile anzeigen.

In A1 steht: 01.01.2020

Dazu habe ich die Formel:

=WENN(WOCHENTAG(A1;2)=1;A1;8-WOCHENTAG(A1;2)+A1)-1

Soweit gut!

Jetzt möchte ich den nächsten Sonntag in der Zeile darunter anzeigen, dass mache ich mit:

=A5+7

und dass ziehe ich durch soweit ich lust habe!

Nun zur Frage:

Zusätzlich zu jedem Sonntag möchte ich dass geprüft wird, ob der Samstag >8 ist und dann den Samstag in der Liste mit ausgeben. (:

Soll dann quasi so aussehen:

Leider komme ich nicht weiter.

Hat jemand einen Rat für mich?

4 Antworten

0 Punkte
Beantwortet von m-o Profi (16.3k Punkte)

Hallo,

vielleicht stehe ich auf der Leitung, ab was meinst du mit

.. ob der Samstag >8 ist ..

Erkläre das doch mal bitte genauer.

Gruß

M.O.

0 Punkte
Beantwortet von
(:

also nochmal einfacher:

Ausgabe aller Sonntage + jeden 1. Samstag im Monat!
0 Punkte
Beantwortet von m-o Profi (16.3k Punkte)

Hallo,

probiere mal die folgenden Formeln:

Formel für Zelle A5:

=WENN(DATUM(JAHR(A1);MONAT(A1);1)-WOCHENTAG(DATUM(JAHR(A1);MONAT(A1);1)-6;3)+6<WENN(WOCHENTAG(A1;2)=1;A1;8-WOCHENTAG(A1;2)+A1)-1;DATUM(JAHR(A1);MONAT(A1);1)-WOCHENTAG(DATUM(JAHR(A1);MONAT(A1);1)-6;3)+6;WENN(WOCHENTAG(A1;2)=1;A1;8-WOCHENTAG(A1;2)+A1)-1)

Formel für Zelle A6:

=WENN(WOCHENTAG(A5;2)=6;A5+1;WENN(ZÄHLENWENN($A$5:A5;DATUM(JAHR(A5+7);MONAT(A5+7);1)-WOCHENTAG(DATUM(JAHR(A5+7);MONAT(A5+7);1)-6;3)+6)=0;DATUM(JAHR(A5+7);MONAT(A5+7);1)-WOCHENTAG(DATUM(JAHR(A5+7);MONAT(A5+7);1)-6;3)+6;WENN(WOCHENTAG(A5+7;2)=1;A5+7;8-WOCHENTAG(A5+7;2)+A5+7)-1))

Ziehe die Formel in Zelle A6 soweit wie benötigt nach unten. Beachte bitte, dass die Startzelle in dem ZÄHLENWENN-Teil der Formel absolut angegeben werden muss.

Die Formel für den 1. Samstag eines Monats habe ich hier gefunden: LINK

Gruß

M.O.

0 Punkte
Beantwortet von
super danke hat wunderbar geklappt!

LG
...