49 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Experte (1.1k Punkte)

Hallo brauche wieder einmal Hilfe.

Eventuell kann mir jemand eine BESSERE Lösung zukommen lassen.

Auf der Suche nach einer Lösung habe ich in vielen Foren gesucht aber nichts dergleichen gefunden.

Beispiel: Supportnet: =WENN(K130:K150>79;1;WENN(K130:K150<89;1)) erscheint Fehler Wert

Suche andere Formel für Zählenwenn, als die, die ich erstellt habe, denn diese ist sehr mühselig.

Diese Formel von mir bezieht sich nur auf K. Habe mehrere Formel -arten ausprobiert aber keine funktioniert so ich es mir gedacht habe.

=ZÄHLENWENN($K$130:$CD$150;"=80")+ZÄHLENWENN($K$130:$CD$150;"=81")+ZÄHLENWENN($K$130:$CD$150;"=82")+ZÄHLENWENN($K$130:$CD$150;"=83")+ZÄHLENWENN($K$130:$CD$150;""=84)+ZÄHLENWENN($K$130:$CD$150;"=85")+ZÄHLENWENN($K$130:$CD$150;"=86")+ZÄHLENWENN($K$130:$CD$150;"=87")+ZÄHLENWENN($K$130:$CD$150;"=88")+ZÄHLENWENN($K$130:$CD$150;"=89")

In Zelle Ci12 sollen Werte die wenn 80 bis 89 erreicht haben, als 1 gezählt werden. Aus den Bereichen von k130:k150 plus Werte aus Zelle t130:t150, W130:W150, af130:af150, Ai130:ai150, Ar130:AR150, AU130:Au150, BD130:BD150, BG130:BG150, BP130:BP150, BS130:BS150 und CB130:150 plus Werte.

In Zelle Ci13 sollen Werte die von von 90 bis 99 als 1 gezählt werden. Aus den Bereichen von k130:k150 plus Werte aus Zelle t130:t150, W130:w150, af130:af150, Ai130:ai150, Ar130:AR150, AU130:Au150, BD130:BD150, BG130:BG150, BP130:BP150, BS130:BS150 und CB130:150 plus Werte

In Zelle Ci14 sollen Werte die von von 100 bis 170 als 1 gezählt werden. Aus den Bereichen von k130:k150 plus Werte aus Zelle t130:t150, W130:w150, af130:af150, Ai130:ai150, Ar130:AR150, AU130:Au150, BD130:BD150, BG130:BG150, BP130:BP150, BS130:BS150 und CB130:150 plus Werte

In Zelle Ci15 soll der Wert von 180 als 1 gezählt werden. Aus den Bereichen von k130:k150 plus Werte aus Zelle t130:t150, W130:w150, af130:af150, Ai130:ai150, Ar130:AR150, AU130:Au150, BD130:BD150, BG130:BG150, BP130:BP150, BS130:BS150 und CB130:150 plus Werte

Auf eine Lösung würde ich mich sehr freuen.

Gruß Adde

4 Antworten

+1 Punkt
Beantwortet von computerschrat Profi (24.6k Punkte)
Hallo Adde,

ich bin nicht sicher, ob ich die Aufgabenstellung richtig verstanden habe. Suchst du eine einfachere Formel, die innerhalb eines Bereichs Zellen zählt, deren Inhalt innerhalb eines Wertebereichs liegt? Dann kannst du die Funktion ZÄHLEWENNS verwenden. Hier kannst du mehrere Kriterien angeben, die erfüllt sein müssen. Zum Beispiel:

=ZÄHLENWENNS($K$130:$CD$150;">=80";$K$130:$CD$150;"<=83")

Das würde die Abfrage schon mal ein Stück weit vereinfachen.

Gruß computerschrat
0 Punkte
Beantwortet von addeguddi Experte (1.1k Punkte)
Hallo Computerschrat,

vielen Dank für deine Antwort. Die Formel hatte ich auch erstellt, diese funktioniert auch. Doch diese Formel deckt alle Spalten ab. Die Formel die ich suche, ist das sie nur den Bereich berechnet für die vorgegebenen Spalten da sich immer um mehrere Spieler handelt und ich diese Formel auch für die Zelle DO 11 mit den Spalte/ Zellen N130:N150, Q130:Q150, Z130:Z150  usw. erstelle muss, Damit für jeden Spieler das errechnet wird, der In den Zelle als Beispiel N3 Steht. .

Vielleicht gibt es dafür eine Lösung.

Gruß Adde
+1 Punkt
Beantwortet von m-o Profi (18.1k Punkte)
Hallo Adde,

das kannst du mit Summenprodukt lösen:

=SUMMENPRODUKT((K130:K150>79)*(K130:K150<90))

Hier wird die die Anzahl der Werte im Bereich K130 bis K150 ausgegeben, die größer 79 und kleiner 90 sind.

Für die verschiedenen Spalten addierst du einfach die Werte:

=SUMMENPRODUKT((K130:K150>79)*(K130:K150<90)) + SUMMENPRODUKT((T130:T150>79)*(T130:T150<90))+...

Für die anderen Werte kannst du die Formel einfach anpassen.

Gruß

M.O.
0 Punkte
Beantwortet von addeguddi Experte (1.1k Punkte)

Hallo M.O.

vielen Dank. das klappt super. Ich hatte das auch probiert mit Summenprodukt , aber habe das  * nicht eingegeben sondern  ; daher hat es nicht bei mir funktioniert.

Schönen Tag noch 

Gruß Adde

...