34 Aufrufe
Gefragt in Tabellenkalkulation von addeguddi Experte (1.1k Punkte)
Bearbeitet von addeguddi

Hallo wer kann mir einen Tipp geben.

folgendes Problem!

Das ist die Formel von der ersten Auswertung grösser 49 kleiner 61

=SUMMENPRODUKT(('6 Spieler 4 Runden für TV  1'!$K$130:$K$150>49)*($L$130:$L$150<61))

= Ergebnis 1 ist OK.

Das ist die Formel von der zweiten Auswertung grösser 59 kleiner 71= Ergebnis 1 ist OK

=SUMMENPRODUKT(('6 Spieler 4 Runden für TV  1'!$K$130:$K$150>59)*($L$130:$L$150<71))

= Ergebnis 1 ist OK.

Jetzt ist das Problem vorhanden! Denn nun addiert er die 1 von grösser 59 kleiner 71 in die Zelle der ersten Formel.

Hier erscheint nun nicht mehr die 1 sondern 2 und die Berechnung wird weiter geführt für jede Spalte/ Zelle.

Beispiel Zelle A ist 1, B ist 1 C ist leer  usw. dann wird aus Zelle a die 2 in Zelle B bleibt die 1. Wird in Zelle C  auch eine 1 erzielt steht dann in Zelle A die 3, in B eine  2 und C die 1. 

Es sollen also nur die Werte in den Zellen erscheinen wenn nicht grösser 61, 71, 81 usw.

Wie kann man das ändern, dass sich die Zahl erhöht?

Eine Möglichkeit habe ich ausprobiert: Wenn man nach dem Summenprodukt die Formel -wenn(B1>0;1) dann erhöht sich die Zahl in A1 nicht, müsste aber das - für die Zellen B bis j1 eingeben.

Auf Hilfe würde ich mich freuen wenn überhaupt möglich

Gruß Adde

1 Antwort

0 Punkte
Beantwortet von addeguddi Experte (1.1k Punkte)
Bearbeitet von addeguddi

Habe eine Lösung gefunden

Nach Summenprodukt ein minus eingeben für die Spalten die nicht addiert werden sollen.

Das ist die ursprüngliche Formel. 

=SUMMENPRODUKT(('6 Spieler 4 Runden für TV  1'!$K$130:$K$150>49)*($K$130:$K$150<61))

Das sagt aus, das nur Werte von 50 bis 60 gezählt werden.

Das ist die veränderte Formel.

Die folgende Formel ist der Eintrag ist in Spalte/Zeile F2 hier werden die Spalten von G2 bis M2 abgezogen

=SUMMENPRODUKT(('6 Spieler 4 Runden für TV  1'!$K$130:$K$150>39)*($K$130:$K$150<51))-WENN(G2>0;1)-WENN(H2>0;1)-WENN(I2>0;1)-WENN(J2>0;1)-WENN(K2>0;1)-WENN(L2>0;1)-WENN(M2>0;1)

Für den Eintrag in Spalte/Zeile G2 kopiert man -WENN(H2>0;1)-WENN(I2>0;1)-WENN(J2>0;1)-WENN(K2>0;1)-WENN(L2>0;1)-WENN(M2>0;1)

Für den Eintrag in Spalte/Zeile H2 kopiert man -WENN(I2>0;1)-WENN(J2>0;1)-WENN(K2>0;1)-WENN(L2>0;1)-WENN(M2>0;1) usw.

Ist zwar mühselig aber es funktionert.

Vielleicht hat jemand eine bessere Lösung!

Gruß Adde

...